locked
Windows 7 Search is not working properly RRS feed

  • Question

  • Files I know I have are not showing up in search results. I've tried running diagnostic, troubleshooting, indexing options etc with no luck!

    My pc is brand new and the search function was working fine about a month ago. Help!


    Frank
    Tuesday, November 2, 2010 4:03 AM

Answers

  • Is this a folder that you created and Then copied to Windows? If it is, Create a new folder, and move the contents of the old into the new. You can rename it later to the same name.

    Then try a search for the contents. If it works, delete the old folder.

    • Marked as answer by Arthur Xie Monday, November 8, 2010 2:46 AM
    Wednesday, November 3, 2010 4:04 PM

All replies

  • Yes, many users are not happy with the search in Win 7.

    Methods here: http://windows.microsoft.com/en-US/windows7/Improve-Windows-searches-using-the-index-frequently-asked-questions

    Why aren't files from an indexed folder showing up in search results?

    Change permissions for the folders\files not found(especially if copied from another machine), rebuild the index, and hopefully it works.  Add file types if they are unique. Rebuild the index when you can go do something else.

    Hopefully that works.

    Wednesday, November 3, 2010 12:28 PM
  • Thanks but this part....

     

    Why aren't files from an indexed folder showing up in search results?

    [quote]To add the System permission to a folder

    1. Right-click the folder, click Properties, and then click the Security tab.

    2. If you don't see System listed under Group or user names, click Edit.

    3. Click Add, type System in the box that appears, and then click Check Names.

    4. Under Matching names, click System, and then click OK until all of the open dialog boxes you've opened are closed.

    You'll need to rebuild the index once you've made this change. To learn about rebuilding the index, see Change advanced indexing options. [/quote]

     

     

    ....Im not able to do because there is no security tab when I click on the folder for its properties. :(


    Frank
    Wednesday, November 3, 2010 3:37 PM
  • Is this a folder that you created and Then copied to Windows? If it is, Create a new folder, and move the contents of the old into the new. You can rename it later to the same name.

    Then try a search for the contents. If it works, delete the old folder.

    • Marked as answer by Arthur Xie Monday, November 8, 2010 2:46 AM
    Wednesday, November 3, 2010 4:04 PM
  • Yes it is...will try thanks!
    Frank
    Friday, November 5, 2010 5:50 AM