none
excel file currently in use

    Question

  • File is on server

     

    Person 1 running Office XP has an Excel file open.  Person 2 with Office 2007 goes to open excel file. Person 2 receives file in use by Person 1 message.  So Person 2 cancels opening the file.  Goes to Person 1 and says please close file. Person 1 closes file.  Person 2 opens file but is unable to save changes.

     

    "file name.xls' is currently in use. Try again later.

     

    Using Windows Explorer, if you try to delete the file you receive a Cannot delete file name: It is being used by another peron or program.

     

    Close any programs that might e using the file and try again later.

     

    Suggestions?

    Michelle

     

    Tuesday, April 29, 2008 7:59 PM

All replies

  • More information.  If excel file is converted to .xlsx this problem disappears. 

     

    Would still like to know of a solution since it would be nice to be able to delete the locked files.

     

    Michelle

    Wednesday, April 30, 2008 4:44 PM
  • May the error message could be right and indeed there is a program trying to access the file. You could use msconfig utility in order to prevent memory residents to load in your Windows and test again. If prolem is solved, you should enable the residents one by one in order to find the bad guy.

     

    Not an easy solution but it could helps

     

    Xavier

     

    • Proposed as answer by graham chow Thursday, November 25, 2010 10:33 PM
    Friday, May 02, 2008 5:17 PM
  • Excel 2007 SP1 routinely gives this error with files on network shares even when no other user has been using the file.

    When opening the file is says it is locked by 'another user' and that other user is you! (or itself) You can opt to be notified when it is ready for editing and a few seconds after it opens you get the notification that it's ready. Happens to everyone I know using Excel 2007.

     

    Microsoft are in such denial that there is anything wrong with their software these days, so don't call it a a 'bug' (because there aren't any anymore). I call it a 'misfeature', one of those features you could really do without. Someone at Microsoft will be able to completely justify this behaviour as part of the design. (And do it without smirking too!).

    Thursday, June 12, 2008 6:10 AM
  •  

    Well, I don't know about a bug in Excel but I have this happen often with some heavy users of the Office suite here as well. However, in every case it is a file stored on a Windows 2003 server that is also running McAfee as the virus protection suite. Restarting the McAfee service _always_ unlocks the problem file so it can be saved. I won't say that Office 2007 does not have another problem that may lead to the same issue, however my issue that is still unresolved appears to also be directly related to McAfee.

     

    I'm still searching for a resolution. McAfee acknowledges that this was a problem with past software, prior to 8.5i release but that 8.5i should have fixed it. Go figure.

    Tuesday, July 22, 2008 1:21 PM
  • I have seen this same issue in the follwoing cirmstances...

    1. Excel file (2003) is opened by "Fred" on a Terminal Server session, the connection is lost (terminal sever set to trash session on lost connection).  Upon reconnection, the file reports as been open and locked for editing by "Fred"
    2. Excel file (2003) is opened by "Fred" on a Terminal Server session, the file is copied to somewhere else (off domain) and when the copy is opened by someone else somewhere it still reports as being open and locked for editing by "Fred"

    I thus conclude that the "opened by" information is actually stored within the .xls file and is nothing to do with the files ACL or NTFS lock status.  This being the case, it must be possible to unlock these files left in this transient state.... if only MS would tell us how!

    • Proposed as answer by Steal_tear Monday, December 06, 2010 5:46 AM
    Tuesday, September 02, 2008 11:48 AM
  • I've got a excel file that's locked on a Netware box. The user that it claims has it is no longer here and not logged in. My problem is I can't delete this file. I've got the rights to do so but it's showing locked, how do I get pass this file lock and delete this??

    Thursday, December 04, 2008 3:31 PM
  • The problem that happens on a computer is quite the same problem. There is the description:

    When the person is opening files in excel 2007, very often he has the message "<file name> is locked for editing by 'another user' " . Then he press cancel, open it again, and it's all right, in read-write mode.

    The problem, with the time, appears more and more.

    What we have checked:
    - the files are never opened by others users, and this user is the creator and only person who is using these excel files
    - some days, the problem appear rarely, some days it's really disturbing the way how he is working

    The configuration:
    - network with windows server 2003, updated. The services who are running on it are basically files server, active directory server, dhcp and dns server. Classic!
    - the user has a computer with Vista sp1
    - the vista system and office 2007 is updated

    The unsuccessful operation:
    - uninstalling the anti-virus on the server
    - disabling the uac on the desktop
    - check that the shadow copy is not enabled on the server
    - try to call the microsoft support - they have indefinitely a technical problem!
    - try to check the locked files on the server with Process Explorer. The file that Office 2007 tell it is locked is not locked with this tool.

    Like I can't call microsoft support, my last hope is to find a solution by the way of this forum. If you have any advice on how to find solution about that, let me know.

    Thank you for any helps
    Tuesday, December 09, 2008 12:32 PM
  • The windows file explorer war causing this problem in our case, try disabling the "detail window" in the file explorer or switch to classic explorer mode (no preview).

    I think the windows explorer is opening the file and is fetching some information about this file while excel is opening the file.

    hth,
    mbr_

    Thursday, January 08, 2009 3:59 PM
  • I experience this issue when trying to save an .xlsx file in Excel 2007 that is stored on a network share on a Windows 2003 server.

    I went onto my 2003 server, right-clicked my computer  > clicked Manage

    I then clicked System Tools > Shared Folders > Open Files

    I found the file that was causing me issues, right-clicked the file and selected "Close Open File".

    Keep in mind that the client pc that was accessing this file over the network share never closed the file!

    I was then able to successfully save the file!

    So, not quite a fix but a workaround for the time being!

    -Ryan
    • Proposed as answer by nekrozon Tuesday, March 03, 2009 4:38 AM
    Tuesday, March 03, 2009 4:38 AM
  • Hi, we are having the same problem and i am wondering what you found to be the solution?
    Wednesday, October 14, 2009 8:09 PM
  • I, too, am a this type of problem.

    1) User1 opens Excel2007 .xlsx file from server (read-write).
    2) User2 opens same file (gets it ReadOnly, of cours).
    3)  User1 saves file successfully, many times...
    4)  User1 comes to the point where she is UNABLE to save as "..file is currently in use. Try again later.", however this user has it READ-WRITE!
    5)  User2 closes file, after which time User1 can now save.

    ?

    Monday, November 09, 2009 5:43 PM
  • I am having the same exact problem as MojoRobbins.  Anyone have any ideas?
    Wednesday, March 24, 2010 5:55 PM
  • Is everyone accessing the file with Office 2007?
    Wednesday, March 24, 2010 5:58 PM
  • Hey All!
          I have tried this on Office 2007 as well as on Office 2010. It happens when you save a file in .xls format and share it. Please help if you know the solution.

    .xlsx format works fine.

    Wednesday, May 05, 2010 3:09 PM
  • My company is having similar problems, but it's mostly in PowerPoint.  Has anyone else experienced it with that application?  I spent some time working with Microsoft and they seemed to think that AV programs cause the issue especially since it was hard for us to replicate it.
    Monday, May 10, 2010 7:19 PM
  • Hello Brothers!

    Some of the Host Files of Office 2007 Updates has Debug Pakeage....

    I don't know what's number or kind file.......

    any way...to get the solutins see the Advance, Save & Trust Center on Office Menu

    Goog Luck 

    Tuesday, May 11, 2010 12:41 PM
  • hi guys,

     

    i have the same problem but my case was in Office 2003.

     

    When the user open the .xls show message: "File in use". Really there is no user with the file open. I check on my computer /manager.

     

    Can you help me please,

     

    Felippe Borges

    MG - Brazil


    Felippe B. Carvalho MCP - MCDST - MCSE 2003 - FCP Master
    Tuesday, July 06, 2010 8:04 PM
  • Hello all,

     

    I have a suer with a similar issue. However in this case it is when he tries to SAVE an Excel file. He gets the prompt that the file is currently in use bit does not state another user and we are certain that he is the only person working on this particular file. The file is an XLSM file located on a network share (Windows Server 2003). It seems to be isolated to this one user currently and has happend on multiple Excel files as well as a Powerpoint file. 

     

    Thanks for any assistance on this issue!

     

    Details:

    - Office 2007 (fully updated)

    - Windows 7 Pro x64 (fully updated)

    - Server 2003 Standard (Domain Controller, File Server)

     

    • Proposed as answer by naseem saifi Saturday, October 01, 2011 11:33 AM
    Friday, July 16, 2010 4:55 PM
  • This issue is still occurring and has appeared at another client's network as well. It appears to be isolated to Excel and PowerPoint and the only common denominator is Office 2007 and Windows 7. The user in question in both situations is the only user working on the file. The user has full read/write permissions to the file and location. Any help would be greatly appreciated.
    Monday, August 16, 2010 7:40 PM
  • Hi.  Same issue, slightly different twist.

    Here is what we have:

    Fileserver:  2008 R2

    Workstations:  Windows 7, 64 bit

    Office 2007.

    Everything is patched up to date.

    User tries to access a spreadsheet on the network drive that they have FULL permissions to.    User receives the following error:

    File whatever.xlsx is locked for editing by 'another user'.  Open read-only....

    So, I copied the file locally and it opens fine. 

    Also, if I open Excel with a blank spreadsheet, select 'Open' and browse to the network file, it opens EVERY time.  Never fails.  If I try to open with explorer, I get this message.

     

    Any help?

     

    Thanks

    John

    Tuesday, September 07, 2010 3:48 PM
  • Hi,

    I too am experiencing a similar issue.  Have a new Windows 7 install with Office 2010 accessing an excel file on a Windows 2003 server.  Only when using Windows Explorer do I consistently get the message "file is locked by another user".  I select Notify as the option and in about 30 seconds, I'm notified to set read-write so I can modify the file.

    This happens only over a remote network link using Windows 7 Explorer; works fine in the office.  If anyone has any ideas, i would be greatly appreciated.

    Barry

    Friday, September 10, 2010 2:27 AM
  • Same problem here
    Monday, October 11, 2010 8:56 PM
  • We are having similar problems.  Our system:

     

    Client: Win7 x64 Enterprise and Professional

    Office: 2007

    Server: 2003 and 2008 R2 

     

    I've tried on both Server 2003 and Server 2008 and I get the same result.  I've tried the same setup with XP Pro SP3 and I the error goes away (or at least it didn't happen during my test period).

    Tuesday, October 26, 2010 11:14 PM
  • Same problem on our system, just 2 (of 40)users so far.
    Client: Win7 x32 Ent  (Fully updated)

    Office: 2007 (SP2)

    Fileshare: Win7 Ent (Fully updated)

    When user open office doc (Excel, Word, Powerpoint, Access) everything is fine, but when trying to save we get the same msg.

    When user open Excel (or Word), create new content, and does a "Save" to network drive, we get same error.

    Whenever user access files on shared drive, new .tmp files are created.  User can not delete these files. (or rather they disappear, but then reappear if you refresh the view). The files can be deleted by the same user from another PC (same config)

     

    Does not make any diff which format we are using  (xls, xlsx, xlsm)

    Re: Suggestions about "bitdefender" and other "anti" software causing the problem, I have tried to clean both workstation and fileserver of everything except  Win7 and Office2007, same problem.

    Also tried a file share on a Win2008 R2 Server,  same problem.

    Tried using a file share on a NAS (Thecus N8800 with Linux OS) and saving works fine, but open problem occurs (see next)

    After rebooting the Fileserver, for a short time the user can delete the .tmp files, and can open/save office files. However when opening files, we often get "Already in use" and the choice of "Read-Only" "Notify" "Cancel". Select Cancel, close the office 2007 program and try again it usually allow opening the file (sometimes it takes 2 tries).

    Open/Save/Close of Office 2007 files on the local hard drive works fine.

    Wednesday, November 03, 2010 4:00 PM
  • Similar problem with a strange work around.

    On Windows 2003 server an .xls file is not open in any session anywhere that can be seen.
    User tries to open the .xls file using a shortcut to the share on the server.
    User gets a Microsoft Excel window warning them: '...xls is currently in use. Try again later.
    No matter how much later she tries, hours, days, weeks, the issue remains.

    Here's a kicker: When changing the shortcut to point to the fully qualified domain name for the server name user can open and save the file. But once user goes back to using server name in share (i.e. \\servername\sharename vs. \\servername.whatever.com\sharename) the problem reoccurs. For the same user another file in the same share in a different folder works with the servername route to the file and not the fully qualified domain name. Go figure! Also using the IP address in place of the servername (i.e. \\ipaddress\sharename) works but not sure if it will work in all cases.

     

    Friday, November 05, 2010 7:53 PM
  • Hi Townfield

    I am having the same problem here at my company user philip opens name.xls from the server (2003 std edition) philip using win 7pro with office 2003 all up to date with the lates updates both desktop and server.

    but on open it keeps saying that the file is in use by Philip  gives the option to use it in read only

    i have restarted the server user PC and still same problem even tried to delete it from the server but file is in use

    has anyone got a salutation for this problem ? as its becoming a little frustrating lol

     

    Thanks

    Wes

    Monday, December 06, 2010 5:54 AM
  • I'm seeing this problem occur on invidual PCs (running both Win7 Pro and Ultimate), where a user will open the file, close it and be unable to move or delete the file.  This is happening with .xlsx, .dwg and .doc files.  The only work around I've come up with is to, once you've closed the file/app, open a different file with the app used for the previous file.  Once this happens, it appears that the orienting the application on a new file, it seems to unlock the previous file.  While there is a work around, it would be nice if there was actually a way to get it to release the file once the application stops using it.  Has anyone found something that corrects this issue?

     

    Thanks,

    Dave

    Monday, December 13, 2010 4:51 PM
  • Also having this issue. User is using Win 7 Pro x64 connected to a Win Server 2008 x64 domain. Folder redirection is in use, file server runs through the Server 2008. Office 2010 (previously 2007) is installed on machine and this "file in use" message pops up frequently when trying to save. When the user goes to save again in a few minutes, everything works just fine. There is no one else using the file, no backups running (durring the workday) on the server, etc. 
    Tuesday, December 14, 2010 4:13 PM
  • In my case, the local backup software had errored and locked the file. how I found it:

    On the server itself at the command line I ran HANDLE.EXE > files.txt
    http://technet.microsoft.com/en-us/sysinternals/bb896655

    I opened files.txt and did a search for the locked file. This told me whch process had it open (in my case, Tivoli backup)

    Use task Manager and kill the process in question.

    Done!

     

    Wednesday, January 05, 2011 6:28 PM

  • Hi.  Same issue, slightly different twist.

    Here is what we have:

    Fileserver:  2008 R2

    Workstations:  Windows 7, 64 bit

    Office 2007.

    Everything is patched up to date.

    User tries to access a spreadsheet on the network drive that they have FULL permissions to.    User receives the following error:

    File whatever.xlsx is locked for editing by 'another user'.  Open read-only....

    So, I copied the file locally and it opens fine. 

    Also, if I open Excel with a blank spreadsheet, select 'Open' and browse to the network file, it opens EVERY time.  Never fails.  If I try to open with explorer, I get this message.

     

    Any help?

     

    Thanks

    John

    Had a user with the same issue today.  Although these were Excel files saved as HTM files for internet viewing, this particular user was unable to open any of the files on the network share, getting the same error above.  This user has Full Control of the folder also, and yet Everyone does not have Full Control, only Modify.

    Today I was at their laptop and found that using File-Open opened the files EVERY time.  Using Explorer and double clicking on the files resulted in the error almost every time on any of the dozens of files.  I am surprised to find this post now as I searched for quite some time today and found nothing that worked.

    This makes no sense, but is a solid workaround.

    Wednesday, January 05, 2011 11:12 PM
  • Add another organization to the list of those experiencing the issue:  (Greetings Brothers in pain ;-)

    Users are unable to delete the files. It is a Win2k3 R2 SP2 server - shared folder.

    I copied the file (.xls) but after I copied it, the copy could not be deleted or renamed because it was "in use". I had Just Created it!!!

    I tried to use Excel 2007, or 2003 with no difference.

    Of the two people who supposedly are using the file, only one was on-line. The server does not show the file to be open by anyone.

    I copied the file to my desktop and STILL can't open it. Because it was locked.

    I changed all the file security on both the server copy and the one on my desktop so only I can access it but that made no difference.

    I am running McAfee and I tried restarting all the services, but no change. McAfee logs don't show anything for today.

    This issue comes and goes with no indication of what causes it. There is no trace of the file being open or accessed, but it still is only available read only. I can delete the desktop file, but not the server share even when deleting from the console. Cant delete from CMD window either.

    Has anyone talked to Microsoft and about this and if so, what did they say? Has anyone paid for their support on this?

     

    Eric

     

    Tuesday, February 15, 2011 7:28 PM
  • Yet another organization with this issue. Users open an existing file, make changes then try to save them and receive the error

    "file name.xls' is currently in use. Try again later.

    No other users are accessing the file at the time, no server file locks, users have modify access to directories and files, no backup is accessing the files, on access scan has been disabled and they're still getting the error.  Kicker is this is very sporadic.  I can duplicate at a rate of roughly 1/100.

     - 1500 XP clients with Office 2007 accessing files - VSE8.7i on clients

     - 75 file servers running W2K3R2 STD and ENT

     - McAfee VSE8.7.0i on servers with on access scan enable

     - some accessing files through DFS namespace and some with direct drive mappings to a server.

     - Office products affected - excel, word, ppt

     - both 2003 and 2007 versions of the files affected (.xls and .xlsx)

    Changing the file name or saving to local system allows save, but it's no longer an acceptable workaround.

    Help!

    - Kearstin

     

    Thursday, February 17, 2011 4:03 PM
  • Yet another organization with this issue. Users open an existing file, make changes then try to save them and receive the error

    "file name.xls' is currently in use. Try again later.

    No other users are accessing the file at the time, no server file locks, users have modify access to directories and files, no backup is accessing the files, on access scan has been disabled and they're still getting the error.  Kicker is this is very sporadic.  I can duplicate at a rate of roughly 1/100.

     - 1500 XP clients with Office 2007 accessing files - VSE8.7i on clients

     - 75 file servers running W2K3R2 STD and ENT

     - McAfee VSE8.7.0i on servers with on access scan enable

     - some accessing files through DFS namespace and some with direct drive mappings to a server.

     - Office products affected - excel, word, ppt

     - both 2003 and 2007 versions of the files affected (.xls and .xlsx)

    Changing the file name or saving to local system allows save, but it's no longer an acceptable workaround.

    Help!

    - Kearstin

     

    Hi Kearstin,

    Have you tried using the File, Open dialog in Excel (or other MSO apps), rather than double clicking the file in Explorer?  Strangely, that worked on a network I admin.  I have no idea why it works (since Explorer is the file manager in MSO), but it has consistently.

    Terry

    Thursday, February 17, 2011 4:22 PM
  • This is the same error we are getting.  We run Vista and Office 2007.  However, the problem only started IMMEDIATELY after installing Kasperksy Internet Security 2011.  We ran CA before that and it never occured.  (CA is rubbish by the way, don't buy it).

     

    I rang Kaspersky support and they asked me to temporarily turn off the protection, and the error disapeared.  I turned the protection back on and it reappeared.  They told me to repair Kapersky (essentially a re-install) but the probem still exists.

    Can someone else on this thread try the same trick with their antivirus to see if it resolves it?  The problem might be with a setting on the virus protection rather than Microsoft.

    Tuesday, February 22, 2011 2:20 AM
  • I have found that if in Windows Explorer you go to "Organize" then "Layout" and uncheck the "Details pane" that it resolves the issue.
    Thursday, February 24, 2011 9:29 PM
  • I have found that if in Windows Explorer you go to "Organize" then "Layout" and uncheck the "Details pane" that it resolves the issue.


    Hmm, I just did a quick test and it seems to be working.  I opened an excel file 50 times and did not receive the error. I normally get the error somewhere in the neighborhood of 5-20 opens. 

    Can some other people test this out?

    BTW, I'm running Windows 7 Pro 64bit with Office 2007.

    Thursday, February 24, 2011 9:56 PM
  • We're seeing the same issue. I am curious of those who are experiencing the issue, what version (if any) of McAfee is running.
    Monday, February 28, 2011 7:18 PM
  • I have found that if in Windows Explorer you go to "Organize" then "Layout" and uncheck the "Details pane" that it resolves the issue.


    Hmm, I just did a quick test and it seems to be working.  I opened an excel file 50 times and did not receive the error. I normally get the error somewhere in the neighborhood of 5-20 opens. 

    Can some other people test this out?

    BTW, I'm running Windows 7 Pro 64bit with Office 2007.


    Seems to have resolved our problem too.  Doesn't really make a lot of sense!

    Have also found this forum where disabling their network protection has resolved the issue.  Might be more than one issue at play..

    http://microsoft-personal-applications.hostweb.com/TopicMessages/microsoft.public.word.application.errors/2058895/3/Default.aspx

    Tuesday, March 01, 2011 4:08 AM
  • I have found that if in Windows Explorer you go to "Organize" then "Layout" and uncheck the "Details pane" that it resolves the issue.


    Hmm, I just did a quick test and it seems to be working.  I opened an excel file 50 times and did not receive the error. I normally get the error somewhere in the neighborhood of 5-20 opens. 

    Can some other people test this out?

    BTW, I'm running Windows 7 Pro 64bit with Office 2007.


    Seems to have resolved our problem too.  Doesn't really make a lot of sense!

    Have also found this forum where disabling their network protection has resolved the issue.  Might be more than one issue at play..

    http://microsoft-personal-applications.hostweb.com/TopicMessages/microsoft.public.word.application.errors/2058895/3/Default.aspx

     

    Did you try opening the file within Excel without using Explorer?  That consistently worked on a network I admin.

    Terry

    Tuesday, March 01, 2011 4:25 AM
  • This exact problem is also on 2010. Must  be they don't see a reason to fix it. What a pain
    Friday, March 04, 2011 4:16 PM
  • Thank you makaveli05 - this did seem to take care of the problem. I'll stop back if it shows up again.
    Friday, March 04, 2011 4:30 PM
  • I have several users complaining about Word-documents that are "locked for editing by 'another user' - if the close it and reopen it works fine.

    I will list the things I have tried just to add to the troubleshoot-discussion.

     

    - OS's: W7 x64 Pro both with and without SP1, XP Pro SP3 - all fully updated.

    - Office: 2003, 2007 - both fully updated.

    - AV: Tried with/without any Antivirus - disabled real-time scan in Windows Defender as well and stopped the service just in case.

    - Explorer: Tried to fiddle with Windows Explorer settings as well - Details, list and no preview-pane. No cigar here as well.

    - Location: Tried 3 network locations: A NetApp Filer, a Synology NAS, and a Windows 7 Workstation - all experienced the same issues.

     

    DOCX seems to be the only ones causing trouble - if I try with DOC I don't experience the error.

     

    The only "workaround" I have found is to open the files through MSO -> File -> Open -> No errors - even if I open 50 files at a time.

     

    Friday, March 18, 2011 12:34 PM
  • I've had some luck with an Excel file that's hung, by doing the following:

    1) Reboot

    2) Don't open any SW

    3) Delete old C:\Documents and Settings\<MyNtID>\Local Settings\Temp~DF####.tmp files

    4) Reboot

    5) Once, I also had to set the file to "read only" in Windows explorer, then changed it back (unchecked read only)

    • Proposed as answer by RWR71 Thursday, April 21, 2011 12:30 PM
    • Unproposed as answer by RWR71 Thursday, April 21, 2011 12:30 PM
    Friday, April 15, 2011 6:18 PM
  • Sorry for the PROPOSE As Answer, i am new here,

    but i had the same issue on a server, i solved it with help from the tool LOCKHUNTER who gave me the proces that was locking the files, cideamon.exe, which belongs to Windows SEARCH. somehow Windows Search was installed on the file and print server. after killing the proces the files were available again, and off course i uninstalled Windows Search.

    So check if you have installed Windows Search on your system, and disable or uninstall it.

    i hope you can try this.




    Thursday, April 21, 2011 12:35 PM
  • We've had the same problem and solved it this way:

    XLS-files locked after being opened. Both Office 2007 and 2010. Windows 2003 R2 fileserver.

    Did following steps at the file server:

    1. Ran HANDLE.EXE > files.txt (as mentioned by NWEA Requisition Team above) to locate the process locking the file. It was cideamon.exe locking several files.
    2. Double-click My Computer, point to Explorer Bar on the View menu, and then click Search.
    3. Click Change preferences, and then click Without Indexing Service.
    4. Click No, do not enable Indexing Service, and then click OK.

    The files was released immediately.

     

    Wednesday, May 04, 2011 10:01 AM
  • We had the Same Issue

    Windows 7 - Office 2010. xlsx Files.

    Workaround was opening the file from Excel, rather than from Windows Explorer.

    Monday, May 23, 2011 1:39 AM
  • It works for me !!!  Thank You...
    Thursday, May 26, 2011 8:37 AM

  • We had the Same Issue

    Windows 7 - Office 2010. xlsx Files.

    Workaround was opening the file from Excel, rather than from Windows Explorer.

    Yes, I reported this as a viable workaround on Jan. 5, Feb. 17, and Mar 1, in this thread, although with MSO 2007.
    Thursday, May 26, 2011 1:25 PM
  • We recently disabled Sophos' on-access scanning on both the file server and user's machine. We originally thought turning it off on the server fixed it, but the issue cropped back up a week later. It's been almost a week now with no issues since disabling on-access on the user's machine, so maybe that's it. I certainly hope so since there don't seem to be any other immediate fixes. 
    Friday, May 27, 2011 12:43 PM
  • Check your AD DNS for errors. In my case, a lingering NS record from a failed demotion operation caused what you're experiencing.
    Thursday, July 14, 2011 6:49 PM
  • I have the same setup using a NAS and found that Windows Explorer work around worked. Hopefully, Mircosoft will come up with a lasting fix. 

    Thx Hank

    Thursday, September 08, 2011 12:12 AM
  • Hi all,

    We had the same problems : Windows 7 and Office 2010 gave the message that the .xls file was in use when you tried to save the file, but nobody had it open.

    The problem was our McAfee Virus Scanner on the server. The scanner had the file in use. Exclude .xls files and it works.

    Best regards,

    Pascal

    Tuesday, September 20, 2011 2:06 PM
  •  

    I had the same problems : The problem was Symantec on the server and users .  Exclude .xls and word  files and it works.

    • Proposed as answer by ashrafis Monday, October 10, 2011 7:35 AM
    • Unproposed as answer by ashrafis Monday, October 10, 2011 7:36 AM
    • Proposed as answer by ashrafis Monday, October 10, 2011 7:36 AM
    Monday, October 10, 2011 7:35 AM
  • This obviously has many suggested resolutions.  Although some have reported excluding files in the AV program as a solution, this does not work consistently, as some test workstations had no AV installed at all (standalone).  And excluding the files from scanning is not something that is advised, especially on a network, if that is where the security layer exists.

    IMO, the best workaround was opening the file from Excel, rather than from Windows Explorer.  

    Monday, October 10, 2011 2:01 PM
  • We have worked pretty hard at this issue, and as TerryR said, there have been many suggested solutions all related to AV programs.

    For other reasons, we had to redo/reset all permissions to all our shared files, and after that we have not had any problems.

    I don't have the ref at hand, but there is a MS knowledge article about MS Office sometimes cause permissions to be messed up.

    There are various products out there that can help managing file permissions, we chose Security Explorer 8 from Script logic.

    We first removed all permissions, then started by assigning new inheritable permisson at the lowest level and worked our way thru the directory strucktures adding/changeing/removing-inheritance as required. 

     

     

    Monday, October 10, 2011 3:51 PM
  • This has nothing to do with firewalls or permissions.  The only thing I am running on my laptop is Microsoft Security Essentials.  All my Word and Excel documents worked fine until last night when Microsoft pushed out a forced update that rebooted my computer.  Now I have this junk to deal with.  Thanks a ton Microsoft.
    Saturday, October 15, 2011 12:33 AM
  • Hi,

     

    I have had same problem ...

    disable TCP autotuning on share store (server) ...

     

    how?

    run cmd as administrator

    and run command netsh interface tcp set global autotuning=disabled

     

    Trnda

    Thursday, December 29, 2011 7:19 PM
  • I have chased this problem for a long time where Excel files were getting locked.  I found indexing service was locking the files and prevented them from being deleted.  Shutting down the service and deleting the files worked for me.
    Thursday, January 12, 2012 9:32 PM
  • Hi, same problem here. I've getting this problem long time ago, but no one knows the right solution ;((

    When I've used shared folders on my win2k3 or win2k8r2 servers, this problem wasn't persistent, so I resolved it like @nekrozon do, "closing open file@ that made conflict.

    But now I'm using QNAP 559Pro+ and this issue is driving me MAD! Trying to disable oplocks make that all users (exept admins) can't create\save folders\files. And now I can't close open files, just haven't this option ;(

     

    Clients Windows XP SP2 and Windows 7 Ultimate, all 32bit. Servers 2008R2. Looks like problem often occures from win7 clients

    What should I do? 

    Friday, January 13, 2012 1:01 PM
  • I have chased this problem for a long time where Excel files were getting locked.  I found indexing service was locking the files and prevented them from being deleted.  Shutting down the service and deleting the files worked for me.
    I tried the above answer, but it did not help as indexing was already turned off for searching. BUT, IIS did have indexing enabled. After turning off indexing on the file from within IIS, I was able to delete the Excel file I was having troubles deleting. Try turning off indexing by right-clicking your file, and removing indexing. Then delete the file from the offending directory. Should work. Good luck to all!
    • Proposed as answer by suppahmario Wednesday, February 15, 2012 9:01 PM
    • Unproposed as answer by suppahmario Wednesday, February 15, 2012 9:01 PM
    Wednesday, January 25, 2012 4:40 PM
  • I have chased this problem for a long time where Excel files were getting locked.  I found indexing service was locking the files and prevented them from being deleted.  Shutting down the service and deleting the files worked for me.

    I tried the above answer, but it did not help as indexing was already turned off for searching. BUT, IIS did have indexing enabled. After turning off indexing on the file from within IIS, I was able to delete the Excel file I was having troubles deleting. Try turning off indexing by right-clicking your file, and removing indexing. Then delete the file from the offending directory. Should work. Good luck to all!

    Currently experiencing same problem. Although I noticed that if I attempt to open the locked Excel document using Excel (Office) 2003, then the file lock disappears and I can also open it using Office 2007 and 2010.

    mc

    Wednesday, February 15, 2012 9:06 PM
  • Did you trying having everyone involved disconnect from the server and log off from windows and then log back on and reconnect.  This some times works like task manager, but sometimes task manager does not see certain workbooks open. For example if you use vb code to open or edit a workbook but forget to make the workbook visible within vb it will not show up with the task manager but it will still show up as open.  Anyone else who opens that same file will open it read only.  Restarting the computer of the person who had the file open will close all open files on that computer.

    Good Luck,

    Matt

    Learn Excel Online for Free

    • Proposed as answer by PizzaDude36 Monday, March 26, 2012 3:37 PM
    • Unproposed as answer by PizzaDude36 Monday, March 26, 2012 3:37 PM
    Sunday, February 26, 2012 5:00 PM
  • Uh, this problem was giving me a headache for two days. Here is my twist and solution.

    Wrote VBA script in Access mapping Sharepoint drive and then automatically downloading excel files to a local folder. In my early code, forgot to close out the open workbook within a nested if (sort of hid itself) and the fun began. Couldn't close, delete, rename, etc the file. Went to Sharepoint server deleted source file (no luck), tried finding all open active workbooks via VBA (no luck), tried converting to .xlsx (no luck). Finally thought a brute force simple approach might work.

    Task Manager, killed every Excel process open...which there were a lot of open procs besides the one's I was running. This worked.

    Office 2007
    Windows XP
    Sharepoint 2007

    Monday, March 26, 2012 3:44 PM
  • Hi,

    I'm too having this issue for some time now and im unable to solve it.

    It doesn't always happen. once in a while, when a user tryes to save a shared file, Excel or word (so far now) Excel hangs and eventually it closes. And from that point forward no user can open this file and receives the "file is being used by another user" information.

    Server is windows 2008 R2. This started happening since migration from XP and office 2007 to 7 with office 2010 on client side. 

    When I take a look on the client machine, i can see the excel process still running with no excel window available and i am unable to stop it. I have to shutdown the machine manually!!

    On the server side, on the file services, there's no information about any user editing this file so i cannot determine if it is a server or client issue.

    So far, i've uninstalled Symantec End Point Protection, disabled SMB2 (both client and server), converted xls/doc to xlsx/docx and installed all updates available. I tryed any other solution i can find (googling) but none result.

    Dows anyone have any solution even if temporary?

    Thanks in advance everyone!

    Wednesday, April 04, 2012 2:23 PM
  • As has been mentioned many times in this thread, the workaround is to open the files from within the office apps (File, Open), not from Explorer.
    • Proposed as answer by KenTech32707 Thursday, April 05, 2012 8:51 PM
    • Unproposed as answer by KenTech32707 Thursday, April 05, 2012 8:51 PM
    • Proposed as answer by TerryR. _ Thursday, April 05, 2012 9:03 PM
    Wednesday, April 04, 2012 7:03 PM
  • The excel file may be open by another process and not actually by the user name indicated in the message. In my case, the Excel file was opened by the Windows Indexer service on the file server. I stopped the indexing service and was able to delete the file. I had arleady tried stopping the antivirus and Backup Exec services.

    I found what process had the file open by running the OpenedFilesView utility.

    Just download OpenedFilesView, unzip and double click on OpenedFilesView.exe.

    • Proposed as answer by KenTech32707 Thursday, April 05, 2012 8:57 PM
    Thursday, April 05, 2012 8:56 PM
  • Stopping other programs and/or services has been discussed, but it is not regarded as an answer.  For whatever reason, Explorer is causing the issue, and when the files are opened and saved from within MSO using File, Open, there is not a problem.
    Thursday, April 05, 2012 9:05 PM
  • Hi there

    I need some assistance:

    Scenario

    I have installed Windows 7 from scratch created a test account along with the in built admin account.

    Customized it to the way we want. I have copied the temp account to the default profile.

    I have sysprepped it and it is on the domain.

    This is all working well however when I open a spreadsheet in a shared area and my colleague is trying to open the same document it says the following error:

    “This file is locked in for editing by ‘test’ to view read only click read only.

    When my colleagues open the document and I open for editing at the same time it says “this file is locked in for editing by ‘dbronson’.

    Other windows 7 machines gives the users name that the file is locked in by but my machine says ‘test’.

    Any ideas as to how I can make my machine to say file locked in my ‘spatel’?

    Before I have added this PC on the domain I have deleted the temp and test account.

    Help please I am pulling my hair out trying to fix my issue.

    Thanks

    I have tried deleting the temp files and rebooted my machine but doesnt make a difference.

    Any ideas?

    Tuesday, April 17, 2012 4:03 PM
  • Hi there

    I need some assistance:

    Scenario

    I have installed Windows 7 from scratch created a test account along with the in built admin account.

    Customized it to the way we want. I have copied the temp account to the default profile.

    I have sysprepped it and it is on the domain.

    This is all working well however when I open a spreadsheet in a shared area and my colleague is trying to open the same document it says the following error:

    “This file is locked in for editing by ‘test’ to view read only click read only.

    When my colleagues open the document and I open for editing at the same time it says “this file is locked in for editing by ‘dbronson’.

    Other windows 7 machines gives the users name that the file is locked in by but my machine says ‘test’.

    Any ideas as to how I can make my machine to say file locked in my ‘spatel’?

    Before I have added this PC on the domain I have deleted the temp and test account.

    Help please I am pulling my hair out trying to fix my issue.

    Thanks

    I have tried deleting the temp files and rebooted my machine but doesnt make a difference.

    Any ideas?

    Not sure if this will help but throwing it out to help you to shoot in the dark. :)

    Do you have any certificates with the name of the "Test" account sitting in your personal cert folder, c$\Users\UserID\AppData\Roaming\Microsoft\SystemCertificates\My\Certificates?

    You can take a look at the "Thumbprint" under the Details tab in certmgr.msc>Personal>Certificates to find out. Simple right click to delete the certificate if you find any named under the Test account name. Hope this helps. 


    Peace

    Wednesday, May 09, 2012 4:01 PM
  • hello,

    I had the same problem but when I disable the file preview the problem was fixed. If you work with an Active Directory you can disable this via GPO

    Hope it's helps

    Jan

    • Proposed as answer by JDECLE02 Tuesday, September 18, 2012 8:39 AM
    Tuesday, September 18, 2012 8:32 AM
  • In our case the file was unlocked by changing the folder view settings to not show hidden files. Prior to this we had tried closing sessions, closing files, having the original user reboot his PC and rebooting the server.
    • Proposed as answer by ALW0229 Wednesday, October 03, 2012 1:16 PM
    Wednesday, October 03, 2012 1:16 PM
  • I had the same issue.

    For me the issue was resolved when I disabled/enabled offline files.

    Tuesday, February 26, 2013 10:21 PM
  • Thank you so much nekrozon! This method worked perfectly for me!
    Friday, June 28, 2013 8:14 PM
  • I experience this issue when trying to save an .xlsx file in Excel 2007 that is stored on a network share on a Windows 2003 server.

    I went onto my 2003 server, right-clicked my computer  > clicked Manage

    I then clicked System Tools > Shared Folders > Open Files

    I found the file that was causing me issues, right-clicked the file and selected "Close Open File".

    Keep in mind that the client pc that was accessing this file over the network share never closed the file!

    I was then able to successfully save the file!

    So, not quite a fix but a workaround for the time being!

    -Ryan
    Works like a charm!
    Friday, June 28, 2013 8:15 PM
  • Excel 2007 SP1 routinely gives this error with files on network shares even when no other user has been using the file.

    When opening the file is says it is locked by 'another user' and that other user is you! (or itself) You can opt to be notified when it is ready for editing and a few seconds after it opens you get the notification that it's ready. Happens to everyone I know using Excel 2007.

     

    Microsoft are in such denial that there is anything wrong with their software these days, so don't call it a a 'bug' (because there aren't any anymore). I call it a 'misfeature', one of those features you could really do without. Someone at Microsoft will be able to completely justify this behaviour as part of the design. (And do it without smirking too!).

    Try to Disable the Preview pane.


    Tuesday, August 06, 2013 5:51 PM
  • You are getting that error because Microsoft has arrogant idiots working for them.  I'm a Big Microsoft fan but some of the things they do are half-fast.  That procedure makes everyone's Start menu and folders assume the name Administrator or whatever the name of the account you were using.

    They need to do something where it can forget the reference to the account who's files you used to mirror the profile.

    Of course I don't know how to do that myself but if Microsoft's Engieers are so great then they should know how to figure that out and fix it.  Just like the idiots that decided hiding a file extension is a good thing. Obviously they don't worry about getting viruses named filename.jpg.vbs. but I digress.

    Maybe deleting the original account or the SSID of that account might do the trick, or maybe the MS engineers will get their head out of their brass and start using common sense.  It's almost like they say, "We gave you the idea, you work out the problems."


    Helpful nice guy

    Thursday, August 29, 2013 9:10 PM
  • To all of you, you are WAYYYYYYY off base.  It has nothing to do with any of what you are saying.  Although those reasons will all give you the same problem, that is not the cause or the resolution.  The problem is a hidden file ~filename.xls or whatever the Office program may be.  FYI It took me 10 years to find this fix.  I always knew about this file but never knew it would cause so much pain.  FYI if you've ever lost a file that you need, look for this file.  You can use it to recover the missing file.  I've used it to save 100s of executives who lost presentations they were working on.

      • Logon to the server if the file is a network file or the local computer if the file is stored on the local computer.
      • Go to the Control Panel or open Windows Explorer.
        1. Control Panel – Folder Options
        2. Windows Explorer – Tools then Folder Options.
      • Go to the View Tab and Select “Show Hidden Files, Folders and Drives”.
      • Click OK.
      • Go to the folder that contains the file and look for the file name but with a ~ sign before the name.
      1. Filename.xls = ~Filename.xl
      2. Delete the file with the ~tilde sign i.e.  ~Filename.xls
    1. If the file is on the server you may have to go to the local computer and delete the local file as well.
    2. Have the end user try opening the file again.
      1. You may have to wait 10 minutes before it actually works.
      2. Also, you may have to reboot the server, but you may not have to.

    Helpful nice guy

    Thursday, August 29, 2013 9:21 PM
  • To delete...Open compmgmt.msc connect to the file share under system tools> shared folders>open files> find the file which you want to close right clck> close open file.

    Hope this helps...

    • Proposed as answer by Jinskullz Thursday, January 09, 2014 7:41 PM
    Tuesday, November 19, 2013 4:24 AM
  • Background:  Our share is on a 2008R2 server, my pc is Windows 7 Pro 64-bit and I have Office 2010 installed on my pc.

    What works for us to enable the deletion of locked temporary files is to use Explorer to temporarily (<1 second needed) rename the folder containing the Excel file. 

    When I use Explorer to return to the folder containing the Excel file, any .tmp files related to the problem are gone and stay gone.  If a ~filename file exists, it can be manually deleted.

    BTW...  This problem never occured until I switched from Windows XP to Windows 7.

    The problem seems related to Explorer DIRECTLY launching a file that can be modified from a server share.  For example, I don't experience the problem if I create a shortcut to the file (even if the shortcut is put in the same folder as the Excel file) and I INDIRECTLY launch the Excel file by using the shortcut.




    • Edited by MPH-NE Monday, December 30, 2013 4:24 PM
    Thursday, December 19, 2013 6:15 PM
  • this worked for me!

    Thank you!

    BTW: Windows 7 Pro 64Bit with Office 2010

    Scott

    Friday, January 24, 2014 5:08 PM