none
SBS 2008 Exchange 2007 and Outlook 2007 out of office issues RRS feed

  • Question

  • Hi I have a sbs2008 server installed as a AD server running exchange. Created pop3 connector for collecting email and all users either have office 2007 and office 2010. When i setup the user profile I am able to open outlook and it finds the user and then goes through setting up the user with no problems. Mail works fine but it seems that i am not able to set out of office or even get active sync to work. I had a look at the web and tried a whole host of things but nothing seems to be working for me. I do not where to look anymore. Please help

    Tuesday, June 21, 2011 3:22 PM

All replies

  • What did you already try?

    im asking because otherwise you will receive lots of possible solutions you already tryed.

    Tuesday, June 21, 2011 3:29 PM
  • i tried looking at DNS setting as well as auto discovery issues. When i run a connectivity test from outlook and just enable auto discover it fails. someone suggested to change the VPN IP pool but that did not even change anything. It points to me that auto discover is not set up correctly. Microsoft has this wonderful service and was only implemented in 2008 which seems to be causing a lot of problems if not configured correctly. Please advise.
    Tuesday, June 21, 2011 4:44 PM
  • Hello,

     

    The OOF feature is based on the autodiscover service. You can check the following informaiton and let us know if the autodiscover works or configured correctly.

     

    [Collect AutoConfiguration Status in Outlook]

    ===================================

    a. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Test Email Autoconfiguration”.

    b. Confirm that your email address is in the address field, uncheckUse Guessmart” and “secure Guessmart authentication” boxes. Then click the “Test” button.

    c. Once it runs, please send me a screen shot of the Log tab and Results tab.

     

    [CAS server configuration information]

    =============================

    On CAS server, open “Exchange Management Shell” and type the cmdlet:

     

    Get-autodiscovervirtualdirectory | fl >c:\auto.txt

    Get-clientaccessserver | fl >c:\cas.txt

    Get-ExchangeCertificate |fl >c:\certlog.txt

     

    Thanks,

    Simon

    Thursday, June 23, 2011 6:12 AM
    Moderator
  • Hello Simon

     

    Please find attached info you requested. 

    http://s1097.photobucket.com/albums/g345/cyrilj1/

     

    Name                          : Autodiscover (SBS Web Applications)

    InternalAuthenticationMethods : {Basic, Ntlm, WindowsIntegrated}

    ExternalAuthenticationMethods : {Basic, Ntlm, WindowsIntegrated}

    BasicAuthentication           : True

    DigestAuthentication          : False

    WindowsAuthentication         : True

    MetabasePath                  : IIS://SERVER.mydomain.local/W3SVC/3/ROOT/Autod

                                    iscover

    Path                          : C:\Program Files\Microsoft\Exchange Server\Clie

                                    ntAccess\Autodiscover

    Server                        : SERVER

    InternalUrl                   : https://remote.mydomain.co.za/Autodiscover/Aut

                                    odiscover.xml

    ExternalUrl                   : https://remote.mydomain.co.za/Autodiscover/Aut

                                    odiscover.xml

    AdminDisplayName              : 

    ExchangeVersion               : 0.1 (8.0.535.0)

    DistinguishedName             : CN=Autodiscover (SBS Web Applications),CN=HTTP,

                                    CN=Protocols,CN=SERVER,CN=Servers,CN=Exchange A

                                    dministrative Group (FYDIBOHF23SPDLT),CN=Admini

                                    strative Groups,CN=First Organization,CN=Micros

                                    oft Exchange,CN=Services,CN=Configuration,DC=am

                                    bledown,DC=local

    Identity                      : SERVER\Autodiscover (SBS Web Applications)

    Guid                          : 03915eeb-4a06-4db7-9713-9d72d154536a

    ObjectCategory                : mydomain.local/Configuration/Schema/ms-Exch-Au

                                    to-Discover-Virtual-Directory

    ObjectClass                   : {top, msExchVirtualDirectory, msExchAutoDiscove

                                    rVirtualDirectory}

    WhenChanged                   : 2010/03/23 09:50:24 PM

    WhenCreated                   : 2010/03/23 08:09:09 PM

    OriginatingServer             : SERVER.mydomain.local

    IsValid                       : True

    Name                           : SERVER
    OutlookAnywhereEnabled         : True
    AutoDiscoverServiceCN          : SERVER
    AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service
    AutoDiscoverServiceInternalUri : https://remote.mydomain.co.za/Autodiscover/Au
                                     todiscover.xml
    AutoDiscoverServiceGuid        : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
    AutoDiscoverSiteScope          : {Default-First-Site-Name}
    IsValid                        : True
    OriginatingServer              : SERVER.mydomain.local
    ExchangeVersion                : 0.1 (8.0.535.0)
    DistinguishedName              : CN=SERVER,CN=Servers,CN=Exchange Administrativ
                                     e Group (FYDIBOHF23SPDLT),CN=Administrative Gr
                                     oups,CN=First Organization,CN=Microsoft Exchan
                                     ge,CN=Services,CN=Configuration,DC=mydomain,D
                                     C=local
    Identity                       : SERVER
    Guid                           : bdf5200b-0c5d-4387-85c1-e6480a92d041
    ObjectCategory                 : mydomain.local/Configuration/Schema/ms-Exch-E
                                     xchange-Server
    ObjectClass                    : {top, server, msExchExchangeServer}
    WhenChanged                    : 2011/05/16 08:50:15 PM
    WhenCreated                    : 2010/03/23 08:03:59 PM
    AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System
                         .Security.AccessControl.CryptoKeyAccessRule, System.Securi
                         ty.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {remote.mydaomain.co.za, mydaomain.co.za, SERVER.mydaomain
                         .local}
    HasPrivateKey      : True
    IsSelfSigned       : False
    Issuer             : CN=mydaomain-SERVER-CA
    NotAfter           : 2013/05/15 08:40:09 PM
    NotBefore          : 2011/05/16 08:40:09 PM
    PublicKeySize      : 2048
    RootCAType         : Registry
    SerialNumber       : 612BB895000000000006
    Services           : IMAP, POP, IIS, SMTP
    Status             : Valid
    Subject            : CN=remote.mydaomain.co.za
    Thumbprint         : 61025A9B452632BC4A9F104DA26A2CBC02451CD2
    AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System
                         .Security.AccessControl.CryptoKeyAccessRule, System.Securi
                         ty.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {SERVER.mydaomain.local}
    HasPrivateKey      : True
    IsSelfSigned       : False
    Issuer             : CN=mydaomain-SERVER-CA
    NotAfter           : 2012/02/09 07:58:08 PM
    NotBefore          : 2011/02/09 07:58:08 PM
    PublicKeySize      : 2048
    RootCAType         : Registry
    SerialNumber       : 38A81ECF000000000005
    Services           : IMAP, POP, SMTP
    Status             : Valid
    Subject            : CN=SERVER.mydaomain.local
    Thumbprint         : 0D0D295D74B3EB83E84C3D1A9400A3CB3B4EF815
    AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System
                         .Security.AccessControl.CryptoKeyAccessRule, System.Securi
                         ty.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {remote.mydaomain.co.za, mydaomain.co.za, SERVER.mydaomain
                         .local}
    HasPrivateKey      : True
    IsSelfSigned       : False
    Issuer             : CN=mydaomain-SERVER-CA
    NotAfter           : 2012/03/22 09:40:05 PM
    NotBefore          : 2010/03/23 09:40:05 PM
    PublicKeySize      : 2048
    RootCAType         : Registry
    SerialNumber       : 61575DAB000000000004
    Services           : IMAP, POP, IIS, SMTP
    Status             : Valid
    Subject            : CN=remote.mydaomain.co.za
    Thumbprint         : 91E3F07CEFBF6AB35A562E2AD2445C8F2C8BA55A
    AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System
                         .Security.AccessControl.CryptoKeyAccessRule, System.Securi
                         ty.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {Sites, SERVER.mydaomain.local}
    HasPrivateKey      : True
    IsSelfSigned       : False
    Issuer             : CN=mydaomain-SERVER-CA
    NotAfter           : 2012/03/22 07:45:30 PM
    NotBefore          : 2010/03/23 07:45:30 PM
    PublicKeySize      : 2048
    RootCAType         : Registry
    SerialNumber       : 61059378000000000002
    Services           : IMAP, POP, SMTP
    Status             : Valid
    Subject            : CN=Sites
    Thumbprint         : 37C8C81AFCDF1DB50F2607D619948C291B0D9F34
    AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System
                         .Security.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {mydaomain-SERVER-CA}
    HasPrivateKey      : True
    IsSelfSigned       : True
    Issuer             : CN=mydaomain-SERVER-CA
    NotAfter           : 2015/03/23 07:54:57 PM
    NotBefore          : 2010/03/23 07:44:57 PM
    PublicKeySize      : 2048
    RootCAType         : Registry
    SerialNumber       : 72AF6273BDFCE0904F2322387F4B06AE
    Services           : None
    Status             : Valid
    Subject            : CN=mydaomain-SERVER-CA
    Thumbprint         : 021FE4D7BB5459E9D09EB12A3F83F3BAC0419163
    AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System
                         .Security.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {WMSvc-WIN-CDZLZ3R2JN6}
    HasPrivateKey      : True
    IsSelfSigned       : True
    Issuer             : CN=WMSvc-WIN-CDZLZ3R2JN6
    NotAfter           : 2020/03/20 07:29:24 PM
    NotBefore          : 2010/03/23 07:29:24 PM
    PublicKeySize      : 2048
    RootCAType         : Registry
    SerialNumber       : 05C3084557C75C914877710197C8136A
    Services           : None
    Status             : Valid
    Subject            : CN=WMSvc-WIN-CDZLZ3R2JN6
    Thumbprint         : 2D6A6668B31305D041E32F07AE77B049153EBCDB
    Regards
    Cyril

    Friday, June 24, 2011 2:47 PM
  • If you want to use ActiveSync then you will need a static IP address. If you have a static IP address then you can drop the POP3 connector. The POP3 connector is only designed to help you move to SMTP delivery.

    Ensure that remote.example.com resolves internally to the internal IP address of the server. The SBS server should set that up for you if you use the wizards to configure it. That also depends on the server being your DHCP server, not a router etc.

    Start by running the Fix My Network wizard in the SBS management console, which will identify issues and offer to resolve them.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Friday, June 24, 2011 9:36 PM
  • Hello,

     

    From the log files, the OOF issue occurs because the autodiscover service cannot be accessed.

     

    You can verify the following settings:

     

    Check the SSL settings

    ==================

    1. Open IIS Manager

    2. Expand the Web Site

    3. Select each of the virtual directories

    4. In the middle pane, Select "SSL Settings" per virtual directory

    5. Under "Client Certificates", make sure the option "Ignore" is selected instead of "Accept" or "Require"

     

    Check the authentication settings

    ======================

    1. Highlight the AutoDiscover virtual directory and double-click on Authentication.

    2. Click on Windows Authentication to highlight it, and then click on Advanced Settings.

    3. Uncheck Enable Kernel-mode Authentication to remove the setting.

    4. Click OK to save the setting.

    5. Do an IISreset /noforce

     

    If it still does not work, please manually access the autodiscover url via IE:

     

    https://remote.mydomain.co.za/Autodiscover/Autodiscover.xml

     

    Let me know the detailed error code.

     

    Thanks,

    Simon

    Monday, June 27, 2011 1:38 AM
    Moderator
  • Hello Simon

     

    Thank you  for this feedback it worked and I can now run the test with out any errors. I can also activate oof via Microsoft outlook but it seems that I have another problem. After turning on out of office and I test internal mail all works but when I send a mail from outside to that mailbox i do not get an out of office reply. Everything seems to work internally but no out of office replies are going out. I had a look at the CAS and made sure that out of office is allowed. Where do I look to see if out of office is really enabled and that it is trying to send a reply to the external people.

     

     

    Thanks

    Cyril 

    Monday, June 27, 2011 12:58 PM
  • Hi Cyril,

     

    I am glad to hear the progress.

     

    You can check the following article to check the “Per User Settings” and “Per-Domain Settings” for the OOF feature:

     

    http://blogs.technet.com/b/exchange/archive/2006/10/06/3395024.aspx

     

    Thanks,

    Simon

    Tuesday, June 28, 2011 2:21 AM
    Moderator
  • Hello Simon

     

    Thank you for all the helpful information you have given me thus far. I read through the article and all my settings are per the article and still only internal people get and out of office reply but no one from outside my domain gets any reply. I am not sure where to look. Do you have any ideas.

     

     

     

     

     

    Thanks

    Cyril

    Wednesday, June 29, 2011 10:32 AM
  • Hello,

     

    To further troubleshooting the issue, I suggest we check the message tracking log and see whether the OOF message is generated or not:

     

    1. Enable Message Tracking log.

    2. Reproduce the issue.

    3. Check the message tracking to see if it is generated.

     

    Configure Message Tracking

    http://technet.microsoft.com/en-us/library/aa997984.aspx

     

    Thanks,

    Simon

    Friday, July 1, 2011 1:31 AM
    Moderator
  • I think your problem is the "POP3 Conector". When you configure Out Of Office auto reply, Exchange auto reply the messages it receives by SMTP.

    That's ok with domain internal messages. However, if you have a POP3 connector, perhaps your external messages don't get Exchage mailbox by SMTP, but they are directly put in your mailbox, so Exchange don't auto reply them.

    PD: I know this is a old thread, but I thought it could be interesting for reference.

    Friday, August 16, 2013 9:20 AM