locked
Dead keys in Windows 7 not functioning properly RRS feed

  • Question

  • [.edit: it appears that the problem has more to do with Windows 7 dead keys itself. I'll keep the topicstart as it is, but a better problem description is in my second post in this topic]

    Hi,

    Having a Dutch native language I'd like to be able to write characters with diacritics and such. However, also being a programmer, I don't like for the quote buttons to behave like dead keys. So what I did a while back was download Microsoft Keyboard Layout Creator, and made my own keyboard layout based on the US International layout, but with the dead keys behind CTRL+key combination. So, for example, to write an ë, I'd do: CTRL+" e. This has been great help for me, and I've used the layout for years in Windows XP.

    I recently upgraded to Microsoft Windows 7, so I downloaded the latest MSKLC to rebuild a new setup for Windows 7 (just to be safe) (I'm running x64 btw, I used the 64 bit version of XP as well). The setup installs the layout fine, and it worked. For a moment.

    A few days after the install, it suddenly stopped working. The dead keys do no longer seem to be there anymore, it's like it's just a US keyboard layout now. Uninstalling and reinstalling my layout didn't help. I tried US International as I figured perhaps the whole dead key thing was broken, but US International worked fine. So I tried building a new setup package. Renamed my layout, rebuilt setup, ran setup, and it all worked again. But again, a few days later, no dead keys.

    What is going on? Is something corrupting my layout or keyboard settings. If that would be an option, is there anything I can do to monitor these kinds of changes, for example making a backup of a relevant part of the registry during a working layout and comparing that to the a future version when it no longer works?
    Friday, November 20, 2009 9:18 PM

All replies

  • Ok, apparently this has nothing to do with MS KLC.

    Here's the issue. I have a Windows 7 x64 install, and as keyboard layout I have as default "US" and as secondary "US International". I start my computer, open notepad, select "US International" from the language bar. Then, when I type a " followed by an e I get an ë. Perfect. Then, in the regional options, I set the "US International" layout as default, and reboot my PC.

    With my PC restarted, I open up Notepad, verify that US International is selected, and then I type a " and an e. All I get is a single e. The " key does absolutely nothing. Same goes for other dead keys like ' and ^. Weirdly enough, the ` *is* functioning properly. Switching the layout to US and I get all working keys, but of course without dead key functionality. Switching back to US International and the problem rearises.

    So, as it appears, the dead keys of the layout with which I happen to boot my PC with seems to be broken throughout that Windows session. This seems to be the case for *every* layout that has dead keys. What on earth is wrong with my machine?
    Tuesday, November 24, 2009 11:22 PM
  • Same problem here.. Dead keys are very buggy. Sometimes have to press the quotation mark 3 times to get one (and then I get 2). Trick to get ë is to press " two times and then press e instead of one time ".
    Thursday, December 10, 2009 1:54 AM
  • I also have the SAME problem, but in Greek Polytonic. It used to work fine before, and one day just screwed up!

    When i press ";" for the accent "΄" above a vowel, all I get is a double ΄΄ or == ++ with other accents.

     

    I haven't touched any settings to cause this problem. I suspect it was the latest windows update or something. The stupid thing is NO ONE WILL HELP!!!!!!

    Tuesday, August 3, 2010 9:16 PM
  • With me, it turned out I had keylogger malware installed. I suggest you use a good virus scanner and scan your complete PC.
    • Proposed as answer by Escovan Friday, December 2, 2011 7:06 AM
    Wednesday, August 4, 2010 10:15 AM
  • I am experiencing this same problem, which just started today, on a Windows 7 Home machine.  Did you every find a way to fix this problem?  It is very annoying, and I've spent hours trying to find a solution.  I hope you can help!  Thanks!
    Tuesday, November 29, 2011 3:38 AM
  • Customer with same problem, further diagnosed turned out to have opened an e-mail attachment with malware. Though the Trojan-payload was instantly removed by AVG, the Keylogger in this case had to be removed by Malwarebytes Anti Malware ( http://www.malwarebytes.org free version is sufficient). After succesful removal, the problem was solved. I advised my customer to change al passwords used in the period (48h) of infection.
    • Edited by Escovan Friday, December 2, 2011 7:13 AM
    Friday, December 2, 2011 7:10 AM
  • @Chryselephantine

    Did you ever found a solution for the double accents? I have the same problem. So, for example: `e should give è, but gives ``e. Thats also with other letters and accents.

    • Edited by AT RC1 Thursday, June 14, 2012 7:30 AM
    Thursday, June 14, 2012 7:06 AM
  • I had this same problem with my Toshiba NB250 with Windows 7. It did turn out to be malware. I tried using AVG and MalwareBytes as user Escovan above did. They identified malware, but were not successful in deleting—it kept reappearing. Finding too annoying to continue, I re-installed the Windows OS altogether again. A drastic measure perhaps, but finally I cäñ ùsé dead keys again.
    Wednesday, September 19, 2012 12:05 AM