none
Windows to go system wont update, wont install apps, and troubleshooting doesn't work RRS feed

  • Question

  • I installed Windows 8 enterprise eval x64 as a windows to go setup.  Everything works fine except when I goto the store to download an app I get the "your purchase could not be completed" error.  When I try to check for updates it fails with code 80070057, when I try to use the trouble shooting program i get the same error as the updates.  I'm running as an admin with my Microsoft account, I have tried a local account.  I have been searching all day.

    Like electronic music? www.thespanningtree.net

    Tuesday, August 21, 2012 8:29 PM

All replies

  • Have you done this?

    http://blogs.msdn.com/b/hyperyash/archive/2012/08/15/enabling-windows-store-on-windows-to-go-machines.aspx


    "A programmer is just a tool which converts caffeine into code"

    Tuesday, August 21, 2012 8:39 PM
    Answerer
  • I have, t'was the first thing I did.  I can access the store fine, its just when I click "install" on an app.

    Like electronic music? www.thespanningtree.net

    Tuesday, August 21, 2012 8:51 PM

  • Hi,

    Please try another Microsoft Account and see if the app can be installed.

    Regarding the Windows Update issue, please check the following:

    1. Check the issue with clean boot:

    1) Start Task Manager and disable the startup items.
    2) Run msconfig and disable the services which are not Microsoft services.
    3) Reboot the computer and check Windows Update again.

    Please also refer to the following article:

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
    http://support.microsoft.com/kb/929135

    2. Run the following commands one by one to rename SoftwareDistribution folder:
    Net stop wuauserv
    CD %systemroot%
    Ren SoftwareDistribution SoftwareDistribution.old
    Net start wuauserv

    Hope this helps.

    Thanks.


    Nicholas Li

    TechNet Community Support

    Thursday, August 23, 2012 7:33 AM
    Moderator
  • Run the Get-AppxLog Powershell command to see more details:

    Get-AppxLog

    http://technet.microsoft.com/en-us/library/hh856039.aspx


    "A programmer is just a tool which converts caffeine into code"

    Thursday, August 23, 2012 8:40 AM
    Answerer
  • Output from Get-AppxLog:

    Time                      ID           Message
    ----                      --           -------
    8/21/2012 3:57:28 PM      301          The calling process is C:\windows\System32\svchost.exe
    8/21/2012 3:57:28 PM      603          Started deployment Register operation on a package with main parameter: file:///
                                           C:/Program%20Files/WindowsApps/Microsoft.ZuneVideo_1.0.927.0_x64__8wekyb3d8bbwe/
                                           AppxManifest.xml. See http://go.microsoft.com/fwlink/?LinkId=235160 for help
                                           diagnosing app deployment issues.
    8/21/2012 3:57:28 PM      10001        Finished servicing package Microsoft.ZuneVideo_1.0.927.0_x64__8wekyb3d8bbwe.
                                           Setting the package state to enabled returned with 0x80070002.
    8/21/2012 3:57:28 PM      400          Deployment Register operation on Package
                                           Microsoft.ZuneVideo_1.0.927.0_x64__8wekyb3d8bbwe from:  (C:\Program Files\Window
                                           sApps\Microsoft.ZuneVideo_1.0.927.0_x64__8wekyb3d8bbwe\AppxManifest.xml)
                                           finished successfully.

    Also Nicholas Li, non of your suggestions made a difference.


    Like electronic music? www.thespanningtree.net

    Saturday, August 25, 2012 2:16 PM
  • I have the same problem.

    I have done some research into it and it seems that if you don't use an eternal Hard Disk Drive it won't work.

    Now from what I hear you must be using an external Flash Drive.

    Here is what I have found: The issue is that Microsoft has two different Mass Storage drivers. One if for Hard Disk Drives and the other is for Flash Drives. The second one (flash drives) has some internal issues with Microsoft Update and now I guess with the Windows Store. There is a converter driver avalble for download that will make it look like a Hard Disk Drive to the OS (operating system) but it was made in 2001 and it wasn't updated. It didn't work for me but it has worked for some other people.

    I don't have the links at the moment but if you absolutely want them then I can find them again.

    Hopes this helps

    -Elliot Labs

    Edit:

    I also think that there are some library (in Explorer) errors because of this.


    • Edited by Elliot Labs Thursday, January 31, 2013 1:01 AM
    Thursday, January 31, 2013 12:34 AM
  • I have a similar problem. Windows update will not load although I can reach the windws update site. Cant install updates manually either. Can't add .net 3.5 from within programs/windows features or using dism.exe. I have also tried creating a freshly copied sxs folder to the local drive and enabling new features using dism pointing to that sxs flder and that fails too.

    I have created this os on an external usb flash drive as a diagnostic tool so it woud be very helpful to get updates and earlier .net functionality to support yet more diagnostic software . I thnk Elliot is onto something with the mass storage drivers; update anyone?

    Cheers!


    C Edwards



    Thursday, February 14, 2013 4:39 PM
  • I have found the thread again after a bit of digging:

    http://www.eightforums.com/windows-updates-activation/6954-windows-go-windows-8-rp-windows-update-check-fails-8007005-a.html

    Hope this helps!

    Wednesday, July 10, 2013 11:56 AM
  • I am having the same issue trying to install windows 7 32bit on a usb for use on a broken laptop without hdd.

    the problem is indeed connected with the flashdrive drivers. 
    I have windows updating, fixed system restore and created a paging file now through the helpful comment of Elliot Labs.

    I havent had the time to try it yet, but i was wondering if this might be an option?

    www.getusb.info/flip-your-bit-usb-utility-to-make-local-drive/

    "BootIt is a Lexar based utility to flip the Removable Media Bit setting of a USB drive.  What this means, is you can take a Lexar drive (and many other brands) and make it appear as a Local Drive on your PC rather than Removable Storage."



    • Edited by PimpleMaze Sunday, August 28, 2016 1:33 PM
    Sunday, August 28, 2016 1:17 PM