.Net 4 still rebooting


  • I know this has been asked multiple times, but I wanted to throw this out here anyway.

    I'm using SCCM 2007 to install .Net 4.0 in a Task Sequence.

    I'm using the suggested command line:

    dotNetFx40_Full_x86_x64.exe /q /norestart /ChainingPackage ADMINDEPLOYMENT

    In the execmgr.log it is still running an exit code of 3010 and rebooting.

    I know I could put it in a wrapper and say if 3010 give 0, but this is suppose to work, but it's not.

    Any suggestions?

    Friday, February 08, 2013 7:38 PM


All replies

  • I have used:"dotNetFx40_Full_x86_x64.exe /q /norestart" through a few thousand task sequence completions with no issues.

    I haven't ever had the need for the "/ChainingPackage" switch, maybe just take that out and see what happens???

    There are also some suggestions on this post as well:

    If you are still having problems, you could just surrender and add .NET 4.0 to the reference image itself. However, that might go against your deployment philosophy. :)

    Friday, February 08, 2013 9:22 PM
  • That's the post I got the /ChainingPackage from.

    I have no problems putting it in the deployment, which is how the majority of the users got it, but we will have machines that don't have it installed that we need to get.

    I first tried /q /norestart and that allows a reboot as well.

    Friday, February 08, 2013 9:26 PM
  • Try running it as a command line in a task sequence.
    • Marked as answer by MPUnderwood Monday, February 11, 2013 1:02 AM
    Saturday, February 09, 2013 3:11 PM
  • Okay, that seemed to fix my problem.

    I'm not sure why that worked but when you select Run Command Line in a Task Sequence on the Options tab there is a text field called Success codes, and by default it list 0 and 3010 so it never reboots.

    Monday, February 11, 2013 1:02 AM