locked
Skype delegate access for rooms, Office 365 RRS feed

  • Question

  • Hoping someone can help out with this one.

    We had on premise solution for SfB and Exchange. Our PAs were able to book Skype-enabled meetings as delegates for conference rooms. We have now migrated to office 365(Skype is still hosted on premise) and the functionality of booking rooms as delegate is not working.

    They can book meeting on behalf of the room, just not Skype enabled meeting. They get error 'You do not have permissions to schedule Skype meeting on behalf of the owner...'.

    We checked the SIP and SMTP settings but they are identical.

    We tried to move test Skype account to the cloud but it did not make any difference.

    We can sort of get it working by signing into Skype as the conference room, error message is then slightly different(The accounts for Outlook and Skype do not match), and in a very convoluted way we can get them to match and able to book meetings. It is not a workaround as it only works until Outlook is closed and it would be very laborious for PAs to keep on logging into Skype as conference rooms(we have lots of them!).

    Anything obvious we missed?

    Saturday, October 7, 2017 11:37 AM

Answers

  • Ok, if anyone else struggles with this, I have figured it out.

    After migration, rooms need to be provisioned as Skype Room System accounts as per this article : https://technet.microsoft.com/en-us/library/mt691570.aspx

    Also note that is you can't find the registrar pool address, 'Get-CsTenant' should help.

    For some rooms, provisioning as above did the trick. For some, we had to login as the room, re-add the delegates, restart Skype and then it worked.

    • Marked as answer by techzd Friday, October 13, 2017 2:32 PM
    Friday, October 13, 2017 2:32 PM

All replies

  • Hi techzd,

    Based on your description, did you mean that you migrate Exchange server to office 365, and the skype for business server is still o premise?

    For your issue, could you please give us a screenshot ?

    The issue appeared when you migrate Exchange sever to Office 365, is that specific user had this issue?If you migrated to exchange online and SFB still on-premise, did you configure integration between them?

    If the issue only appeared after your migrating, we suggest you check if you have correct steps for migrating exchange server.

    Moreover, open Outlook client> Click on ‘File’ > ‘Account settings’ > ‘Delegate Access’ > ‘Add’ user whom you want to allow calendar rights. (Give Editor Rights on calendar in order to manage complete calendar).

    I will share a document about how to setup Skype for Business meeting Delegation without Enterprise Voice, please refer to
    https://24x7itconnection.com/2015/09/22/how-to-setup-skype-for-business-meeting-delegation-without-enterprise-voice/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Alice-Wang Monday, October 9, 2017 6:45 AM
    Monday, October 9, 2017 6:38 AM
  • To answer your questions: Yes Skype for business server is still on premise but Exchange is being migrated. This process is not complete yet although most of the mailboxes are now in the cloud. Can't provide screenshot as travelling and on iPad right now, but error message as above "You do not have permissions to schedule Skype meeting on behalf of the owner..." We did not have this issue prior to migrating, affects all users who are setup as delegates as far as we can tell. This issue is specific to PAs booking conference rooms as a Skype meeting but it does not affect the same users booking Skype meetings on behalf of senior management. In another words, if the delegate is another user, Skype booking works, if it's a conference room, we get an error message. Both methods worked prior to migration. Is there anything specific to rooms we overlooked?
    Monday, October 9, 2017 6:20 PM
  • Hi techzd,

    Thanks for your reply.

    According your description, I noticed that “if the delegate is another user, Skype booking works”, do you mean the user which is added as a delegate for another user can schedule a Skype meeting successfully, but if he is added as a delegate for a conference room, it fails with no permission error. If I understand correctly, do you use room mailbox for a conference room?

    If yes, I think it may be an idea to check the room mailbox account.
    Please first check if the room mailbox is migrated to online or still located on-premise.
    Then confirm the room mailbox delegate setting is correct in ECP.
    You could refer to this link for migration room mailbox:
    https://social.technet.microsoft.com/wiki/contents/articles/31163.how-to-migrate-resource-room-mailboxes-to-office-365.aspx

    As the error is related to permission, please try to run this command in Exchange server side:

    “Add-MailboxFolderPermission -Identity room@contoso.com:\Calendar -User ed@contoso.com -AccessRights Editor”

    Another way, if possible could you please try to delete and re-create or create a new delegate in your environment for testing to see if it can work.

    Thanks for your understanding and patience!


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Wednesday, October 11, 2017 9:01 AM
    Wednesday, October 11, 2017 8:42 AM
  • Yes I can confirm that we use Room Mailbox and issue only occurs with Rooms.

    We created test room account, it is already migrated, so is my user account. Deleting and recreating permissions made no difference. Tried with several different delegates.

    I checked both MailboxFolderPermission and Mailbox Permission, have full access on mailbox and Editor access for calendar. Also removed permissions several times via powershell.  The room does not show up in Skype under people 'I manage access for'. Logged on as room and removed/re-added me as delegate, restarted both Outlook and Skype. Still no joy.

    FYI, he global enableExchangeDelegateSync policy is set to 'True'.

    Since posting we had couple other users with delegate permissions issues(this time they can't even schedule on behalf of user, never mind room!). Again no matter what we do we can't make them work, although all worked prior to migration. Just makes me think the delegate permissions in Skype/Outlook have some inherent faults. Seems to be ok when it works but if it breaks...

    Wednesday, October 11, 2017 2:01 PM
  • Ok, if anyone else struggles with this, I have figured it out.

    After migration, rooms need to be provisioned as Skype Room System accounts as per this article : https://technet.microsoft.com/en-us/library/mt691570.aspx

    Also note that is you can't find the registrar pool address, 'Get-CsTenant' should help.

    For some rooms, provisioning as above did the trick. For some, we had to login as the room, re-add the delegates, restart Skype and then it worked.

    • Marked as answer by techzd Friday, October 13, 2017 2:32 PM
    Friday, October 13, 2017 2:32 PM
  • Hi techzd,

    Thanks for your sharing, it is really helpful.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 16, 2017 3:07 AM