GPO setting for OneDrive For Business?


  • Here's the situation:

    • 6000 users already have Lync 2013 (Office 365)
    • 6000 users already have Office 2013 ProPlus
    • Some of these users have OneDrive For Biz installed, but not configured.
    • We are now to the point where we want to give OneDrive to everyone and sync it to their Office 365 account

    When someone launches OneDrive for the first time, they are required to click the sync button. When they click this it activates and adds a "OneDrive @ CompanyName" folder in Windows Explorer.  How do I deploy OneDrive with it pre-configured so the user doesn't have to click "Sync?"  Is there a GPO?  Can I add something to a deployment package?

    Thursday, June 12, 2014 3:13 PM


All replies

  • We are having the same issue. When we deploy an image through SCCM, the onedrive software is on there, but when the user launches it the first time, they have to put their Onedrive URL into a box and click sync. Many of our users have difficulty in doing so and would like to find a solution to this by allowing it to autoconfigure with the users credentials as we have SSO accross the board in our orginization.

    Any help would great

    Thursday, June 12, 2014 9:19 PM
  • At least my users don't need to know their URL.  I have a GPO to set UseOnlineContent = 2 and this presets it for them in my environment.



    I'm not sure why this is set under "14" since I am using Office 2013.  It works.

    Thursday, June 12, 2014 9:29 PM
  • Hi,

    Based on my knowledge, Group policy can’t help us change this.

    As far as I know, we need to click the Sync button manually the first time to sync libraries, and OneDrive for Business will handle it automatically the next time when we are connected to the SharePoint site. 

    Regarding this question, in order to get better help, we can also ask for more suggestions in the following forum.

    Office Forum Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Best regards,

    Frank Shen

    Monday, June 16, 2014 8:40 AM
  • Hi,

    It's been a while. How is the issue? If you need further assitance, please don't hesitate to let us know.

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Best regards,

    Frank Shen

    Tuesday, June 24, 2014 2:54 PM
  • IMHO this question is not answered and will continue to be asked by any organization trying to adapt OneDrive for business, like ours!

    OneDrive only deserves the 'for Business' addition when it can be centrally managed and configured without user intervention with at least the following:

    • Local location of the OneDrive cache
    • Which library to sync
    • Turn sync on
    • prevent user from changing above settings

    Otherwise OneDrive will not be reliable with folder redirection etc.

    Friday, August 01, 2014 5:59 AM
  • Completely agree here. We have thousands of users and having a requirement for them to type a long string of characters in will only create more work for the support teams each and every time someone logs onto a new computer. 
    Thursday, August 14, 2014 11:21 AM
  • Craig-

    My users don't need to type in a long string because I have that enabled in a GPO via this regkey


    value = 2

    This DOES NOT solve the problem where the users need to hit Sync the very first time.

    Thursday, August 14, 2014 3:02 PM
  • Any "ping" with answer?


    Tuesday, September 15, 2015 2:00 PM
  • There is a significant change coming to the OneDrive Biz client this year.  First Office 2016 launches, then an updated 1D client will be released (by end of year) that combines the Biz and Consumer clients to match the mobile experience.  This will bring some level of GPO control to the enterprise.  Other features are coming as well.
    Tuesday, September 15, 2015 3:23 PM
  • I have it so users just have to put in their email address, and then it uses SSO to login.

    this is using the new onedrive.exe  I have not tired these GPO setting yet...

    Monday, January 11, 2016 9:45 PM