none
Nothing is being displayed when the SharePoint site has been mapped as a network drive for users

    Question

  • Hi all,

    I have mapped a SharePoint site as a network drive and nothing is being displayed inside the drive for the users. Please note that for administrators, it is showing properly when they open the drive but not for users. Please note that these users currently have read permission on the site collection, subsites and document libraries. It is only within folders of the document library that they have write permissions.

    Thanks to tell me how to allow users to view content of the SharePoint network drive.

    Kind Regards,

    Monday, March 27, 2017 4:53 PM

All replies

  • Be sure the webclient service is running on the client machine, and did you get an authentication request when initially configured?
    Monday, March 27, 2017 7:11 PM
  • Hi LiinaaS,

    Do you mean users cannot view the content in the network drive after they map the SharePoint site to it in their own computers?

    Users who can view the content in the network drive need to have contribute permission level at least.

    I suggest you giving at least Contribute permission level to these users to view network drive.

    Best regards

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, March 29, 2017 8:36 AM
  • Hi Grace,

    Yes, the users cannot see anything in it after the SharePoint site has been mapped as a network drive to their PCs. I have made a copy of the Contribute permission level and assign it to the users. Still, they are unable to see the contents of the network drive. Please help me to solve this issue.

    Thanks

    Kind Regards,

    Thursday, March 30, 2017 5:36 AM
  • Hi LiinaaS,

    Whether you give the user Contribute permission at site collection level?

    If not, please add permission at site collection level.

    If yes, right click the name of network drive, click “share with”, check the user permission level:

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, March 30, 2017 9:55 AM
  • Hi Grace,

    You mean that I need to add permissions at the site collection level on SharePoint. Can you please send me a screenshot of how to do it? Thanks

    Thursday, March 30, 2017 12:53 PM
  • Hi LiinaaS,

    Go to site settings->users and permissions->site permissions.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, March 31, 2017 12:57 AM
  • Hi Grace,

    It will not be possible to add Contribute permission level for these users because at the site collection, users require read access only. Please advise whether there is another solution to achieve network drive to be created.

    Thanks

    Friday, March 31, 2017 5:21 AM
  • Hi LiinaaS,

    I suggest you creating a new permission level which have all permissions as “Read” Permission level and add an additional permission “Browse Directories”, follow the steps:

    1.        Go to site settings->site permissions->permission level in the ribbon.
    2.        Find out and click “Read” permission and click “copy permission level”.
    3.        Give a name to new permission level and select additional “Browse Directories” permission under site permissions, then grant the relevant users the new permission level.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Proposed as answer by csedwilliams Thursday, April 06, 2017 3:10 PM
    Tuesday, April 04, 2017 9:59 AM
  • Hi LiinaaS,

    Is there any update?

    If the reply helps you, you can mark it as answer.

    Have a nice day!

    Best regrads,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, April 14, 2017 1:25 AM