locked
The server cannot join the array RRS feed

  • Question

  • I have UAG DirectAccess working fine on a single server.  I want to add a second server with NLB.  I've tried the technet article... I've tried the TLG's.  I even did a find and replace on the TLG to insert my IP's and followed the TLG to try to create an array for UAG and then setup NLB.  Every time I try to join the second node (UAG2 from the TLG) I get the error message "The server cannot join the array".  I've tried the internal IP address, the internal DNS name (UAG2.domain.local) and still receive that message.  I have even edited the TMG configuration on UAG1 and added UAG2 to the "Managed Server Computers" computer set.

    I can ping in both directions internally and access mmc consoles from UAG2 to UAG1.  Both have UAG SP1 Update 1 as well as Win2008R2, SP1.  It feels like a communication problem between the two UAG servers, but I can't figure it out.

    Both are virtual machines on HyperV.  Any help would be appreciated.

    Friday, June 29, 2012 8:51 PM

All replies

  • I was getting this error when trying to add an array member too.  The issue was TMG version numbers were different on each node.  Open the TMG console on each node and check the Help About menu and compare the version strings.  Do the same with the UAG console and make sure the version strings match.  Below is the list of SP and UR.  Once these were all matching with the latest version, I was able to join the array. 

    TMG Versions:

    RTM 7.0.7734.100
    SP1 7.0.8108.000
     UR1 7.0.9027.400
     UR2 7.0.9027.410
     UR3 7.0.9027.441
     UR4 7.0.9027.450
    SP2 7.0.9193.500
     UR1 7.0.9193.515

    UAG Versions:

    UAG SP1 RTM 4.0.1752.10000 – updated 2 December 2010
    UAG SP1 UR1 4.0.1773.10100 - KB 2585140 - November 2011
    UAG SP1 UR1 4.0.1773.10190 - KB 2649262 - April 2012

    Tuesday, July 10, 2012 7:34 PM