locked
Security warning Data Connections have been disabled when opening av worksheet from MOSS-2007 in Excel RRS feed

  • Question

  • We have a Microsoft Office Sharepoint Server 2007 and use Excel 2007.  I have a document library on the sharepoint-site where I have some worksheets that users in the firm can open in Excel 2007.  The worksheets use data connections to a MS-SQL-server.  When users open the worksheets in Excel the data are automatically refreshed from the data connections. 

    My problem is that excel in some occasions shows the message "Security warning Data Connections have been disabled."  I have told the users to just select Options and enable all data connections.

    My wish is that the users never get this security message.  Some users don't see the message and believe that they are working with fresh data.

    The MS-SQL server is in our internal Network and I want that this server shall be a trusted site.  What is the best way to make this server a trusted location or is there a better way to avoid the message?

    The worksheets are saved on the sharepoint-site and the sheets are automatically refreshed from the MS SQL-server when opening?  I have talked with technichians working with  MS-Office in my firm.  They were not sure about how to solve this problem since the worksheets are saved on a sharepoint-site. 

    I have seen that there are trusted locations in Excel, but I can only define networksdrives there and not a server. 

    I am grateful for any tips about how to solve this problem.

    Best regards

    Atri


    Torunn Midtsjø

    • Edited by Mike Walsh FIN Saturday, February 19, 2011 9:14 AM Text was so faded as to be unreadable. Replaced wih readable text.
    Friday, February 18, 2011 9:39 PM

Answers

  • Hi,

     

    According to your description, I suggest that you should have to add location where you excel file resides into trusted location list. You can do this by following these steps:
    1.       Start Excel 2007, click on the "Office" button.
    2.       Click on the "Excel Options" button.
    3.       Select "Trust Center" tab and click on the "Trust Center Settings..." button.
    4.       Select "Trusted Locations" tab.
    5.       Make sure that checkbox "Disable all Trusted Locations. Only files signed by Trusted Publishers will be trusted." is not checked (do this just if that complies with your company security policies).
    6.       Click on "Add new location..." button.
    7.       In the Path enter location that will be trusted. Example: "C:\Users\UserID.Domain\Documents". If required, select checkbox "Subfolders of this location are also trusted". Optionally enter description for this location.
    8.       Click "OK" button.
    1. Click "OK" to close "Trust Center" dialog.
    2. Click "OK" to close "Excel Options" dialog.

    Please have a try.

    Best regards
    David Hu

     

    • Marked as answer by Emir Liu Monday, March 7, 2011 11:22 AM
    Tuesday, February 22, 2011 1:16 AM
  • Hi Torunn,

    I am sorry to tell you that I understand on the point 7 incorrectly. The path of excel mustn't be disk-address, it could be an address in the network. Please have a try again. Thank you for pointing out the error at the same time.

    Best Regards
    David Hu

    • Marked as answer by Atmiddelsea Tuesday, March 1, 2011 9:13 AM
    Monday, February 28, 2011 1:32 AM

All replies

  • Hi,

     

    According to your description, I suggest that you should have to add location where you excel file resides into trusted location list. You can do this by following these steps:
    1.       Start Excel 2007, click on the "Office" button.
    2.       Click on the "Excel Options" button.
    3.       Select "Trust Center" tab and click on the "Trust Center Settings..." button.
    4.       Select "Trusted Locations" tab.
    5.       Make sure that checkbox "Disable all Trusted Locations. Only files signed by Trusted Publishers will be trusted." is not checked (do this just if that complies with your company security policies).
    6.       Click on "Add new location..." button.
    7.       In the Path enter location that will be trusted. Example: "C:\Users\UserID.Domain\Documents". If required, select checkbox "Subfolders of this location are also trusted". Optionally enter description for this location.
    8.       Click "OK" button.
    1. Click "OK" to close "Trust Center" dialog.
    2. Click "OK" to close "Excel Options" dialog.

    Please have a try.

    Best regards
    David Hu

     

    • Marked as answer by Emir Liu Monday, March 7, 2011 11:22 AM
    Tuesday, February 22, 2011 1:16 AM
  • Hi David!

    Thanks for your reply!

    I do just have one more question according to point 7. 

    The excel files is located on a Sharepoint-site.  The data-connections in the excel-sheets goes to a MS-SQL server.  Is it the Sharepoint-site or is it the MS-SQL-server that has to be a trusted site in Excel? In your example you mention disk-C as a path, but I am not sure if that will be correct in my case.

    The path to both the Sharepoint-site and the the path to the MS-SQL-server will not be a disk-adress, but an adress in the network.  I guess it is possible to select a http-adress or maybe an ip-adress as a trusted site?

    Best regards

    Torunn


    Torunn Midtsjø
    Friday, February 25, 2011 3:26 PM
  • Hi Torunn,

    I am sorry to tell you that I understand on the point 7 incorrectly. The path of excel mustn't be disk-address, it could be an address in the network. Please have a try again. Thank you for pointing out the error at the same time.

    Best Regards
    David Hu

    • Marked as answer by Atmiddelsea Tuesday, March 1, 2011 9:13 AM
    Monday, February 28, 2011 1:32 AM
  • Hi David!

    Thanks again for taking the time to answer my questions.  I am quite sure this will solve my problem

    Best regards

    Torunn


    Torunn Midtsjø
    Tuesday, March 1, 2011 9:15 AM