locked
Lync 2010 RC set-csrgsqueue PS command RRS feed

  • Question

  • Hi,

    I am trying to change an RGS Queue timeoutthreshold. The full details of get-csrgsqueue | fl are as :

    Identity          : service:ApplicationServer:svr-lync-fe-01.domain.com/e1b8
                        6f53-a4ac-4744-bb6e-87b35555a606
    TimeoutAction     : Action=Terminate
    OverflowAction    : Action=Terminate
    Name              : Test Queue
    Description       :
    TimeoutThreshold  : 300
    OverflowThreshold : 5
    OverflowCandidate : NewestCall
    AgentGroupIDList  : {service:ApplicationServer:svr-lync-fe-01.domain.com/f06
                        c60cf-93ac-4173-a8ba-5f8c8f72cd11}

     

    When using set-csrgsqueue it asks for the 'instance' which i cannot find. btw -identity does not work as it needs to bind instance.

     

    Any ideas?

     

    Thanks, Alex.

    Tuesday, October 5, 2010 12:18 PM

Answers

  • Hi Alex,

    The Instance parameter is actually the queue instance itself (not a parameter of the queue). So you have basically two options to edit queues:

    1. Through the pipeline

    Get-CsRgsQueue | % { $_.TimeoutThreshold = 60; $_ } | Set-CsRgsQueue

    2. With an in-memory variable

    $a = Get-CsRgsQueue
    $a.TimeoutThreshold = 60
    Set-CsRgsQueue $a

    Cheers,
    Frédéric

     

    • Marked as answer by Alex_Harvey Tuesday, October 5, 2010 1:22 PM
    Tuesday, October 5, 2010 12:52 PM

All replies

  • Hi Alex,

    The Instance parameter is actually the queue instance itself (not a parameter of the queue). So you have basically two options to edit queues:

    1. Through the pipeline

    Get-CsRgsQueue | % { $_.TimeoutThreshold = 60; $_ } | Set-CsRgsQueue

    2. With an in-memory variable

    $a = Get-CsRgsQueue
    $a.TimeoutThreshold = 60
    Set-CsRgsQueue $a

    Cheers,
    Frédéric

     

    • Marked as answer by Alex_Harvey Tuesday, October 5, 2010 1:22 PM
    Tuesday, October 5, 2010 12:52 PM
  • worked perfectly, thanks again.
    Tuesday, October 5, 2010 1:23 PM