PS 2013 auto-synch data with Project Pro RRS feed

  • Question

  • I have opened a PS2013 (hosted separately) enterprise project file to edit using Project Pro 2013 on my desktop. 

    While making updates to the resource assignments on a new task, and prior to committing those updates by hitting "OK", all of my changes disappeared, leaving my resource assignments blank again.  After several attempts to recreate this glitch, I discovered this event will occur exactly every 5 minutes by the clock.  When the clock hits that 5 minute mark, my unsaved changes all disappear.

    Is this a synch setting by which PS (or maybe SharePoint) does a compare with Project Pro, and makes the latter match the former?  If so, can the attributes be adjusted/changed?

    Your thoughts?

    Monday, December 1, 2014 2:38 PM

All replies

  • Hi,

    I've never seen or heard such a timer process or bug like this. Note that when you use the lower panel (task form) to enter assignments data, you have to hit the "ok" button in order to validate.

    Can you reproduce this issue on another machine? With another project? With another user?

    Hope this helps,

    Guillaume Rouyre, MBA, MVP, P-Seller |

    Monday, December 1, 2014 3:01 PM
  • Had my office partner try as well from her computer and login, on the same, and different projects.  Exactly the same result.  On that same 5 minute mark.

    Yes, we are using the task form in the lower panel.  And once I "commit" the changes by hitting "ok" (or hitting return twice after the last change), they are not affected.  The event only wipes out any "unsaved" changes.

    If it was just a 5 minute "inactivity" issue, I wouldn't be too concerned.  But this event happens every 5 minutes around the clock.  So if I start editing 15 seconds before that next 5 minute event, my changes are lost when it fires.

    Monday, December 1, 2014 3:53 PM
  • Can you check which are the options in the file menu, options, save:

    Hope this helps,

    Guillaume Rouyre, MBA, MVP, P-Seller |

    Monday, December 1, 2014 4:13 PM
  • My autosave is off.

    I thought maybe the local project cache synch might be the trigger?  But I don't see an option for setting the timing.  And why it would unilaterally decide that my changes were not as important than the baseline file....

    Monday, December 1, 2014 5:21 PM
  • This is a known bug.


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Blog contains my field notes and SQL queries

    Tuesday, December 2, 2014 6:36 PM
  • Thanks Mike.  This appears to be something different from the one you reference. 

    This doesn't do anything to assigned resources.  It only happens when entering resources/units/work in the task form split, and only if you haven't hit "ok" or otherwise committed those assignments to the task.  Once committed, this mysterious 5 minute event doesn't impact any resource assignments. 

    Tuesday, December 2, 2014 7:06 PM
  • Do you have any macros in your global or project files?  Maybe something that is set to run on a schedule?  If you run a macro, even if it's not related to the data you're putting in the task form, it removes the ability to "undo" -  maybe it does the same thing to uncommitted changes?

    Elli J Project Solutions Specialist Blog:

    Tuesday, December 9, 2014 12:33 AM
  • Thanks Elli.  Double checked, and found no pesky VBA code anywhere.

    Update - this appears to be a network connection interruption issue.  I can replicate the symptom by unplugging from the LAN.  All my uncommitted changes disappear.

    Now I'm thinking a GPO refresh at the Domain Controller (which may be set for every 5 minutes)?  Could that cause just enough of a network interruption?

    Tuesday, December 9, 2014 2:18 PM
  • The default GPO at the domain controller is 5 minutes, but I don't think the refresh at that level should interrupt workstation connectivity - you would think more people would notice this behavior if it did.  The default on the user workstation is 90 minutes - could it be that yours are set to 5 minutes for the workstations?  Maybe you could try turning off the GPO refresh at the workstation level, or set it to a different interval and test?

    Elli J Project Solutions Specialist Blog:

    Tuesday, December 9, 2014 4:35 PM