locked
UAG publish CRM 2010 Web - missing ribbon RRS feed

  • Question

  • Hi

    I am trying to publish CRM 2010 through the UAG, but I do not get the top ribbon displayed, there is simply just a white/blank area, where the ribbon should be.. Have used the standard settings for CRM4 Web publishing. Have tried displaying CRM in the portal, and also tried to open it in a new window.

    Tried to disable "VeryfiURL", just for testing, didnt do anything.

    Running SP1, and have also installed Rollup 1, as described by a Microsoft Supporter on the forum.

    The error I get is:

    "MSCRM4 failed. The URL /"environment"/{634405392730000000}/WebResources/Ribbon_main_system_library.js contains an illegal path. The rule applied is Default rule. The method is GET."


    -
    Wednesday, June 1, 2011 11:37 AM

All replies

  • You may need to amend some of the default ruleset rules as discussed here: http://blogs.technet.com/b/ben/archive/2010/03/15/troubleshooting-ruleset-issues.aspx

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Wednesday, June 1, 2011 2:58 PM
  • Hi

     

    But from what I understand, if you set "Evaluate without enforcement", the rules isnt enforced, or I am wrong?


    An update:

    For some reason the ribbon gets displayed in the CRM if I choose Calender!, but none of the other selection show a ribbon, and the calender ribbon stays on.

    Friday, June 3, 2011 7:29 AM
  • Hi,

    did you find a solution for your problem? I am facing exact the same issue when trying to publish CRM 2011 with UAG.

    No ribbon bar, except for the calender...

    I already tried to play around with the rulesets without any improvement!

    Wednesday, November 2, 2011 8:28 AM
  • Hi all,

    was this issue solved anyway? I am currently facing the same issue with an Apache Reverse Proxy.
    Internaly CRM is running proper. An this webresoruce url is not even called during the load of crm (claims based auth enabled)

    When I access it from external through the Apache Reverse Proxy it trys to load this webresource like

    <url>/<crmorg>/%7B634982561690003236%7D/WebResources/Ribbon_main_system_library.js?ver=1449190221

    This ends up with an 404. The iis server is not able to responde with content.

    <url>/<crmorg>/WebResources/Ribbon_main_system_library.js?ver=1449190221 is working proper, respondigjn with the jscript
    (this is the way this jscipt is loaded on all other referenece system I can review...

    The rewrite rule (WebResourceRule) on the iis seems to work as the Test pattern is working proper with the
    url above.  And it is also bringing the same result like for working url without the "%7B634982561690003236%7D" between

    Pattern: /?([0-9a-zA-Z][^/]*)?/?((?:%7b|\{)[^/]*(?:%7d|\}))?/?webresources/([^\\?]+)

    Rewrite URL: /{R:1}/Handlers/WebResource.ashx?name={R:3}

    The funny thing is that for both urls bringing the same result, or should bring as
    R:1 is <url> and R:3 is <crmorg> , "%7B634982561690003236%7D" is R:2 which is not used in this context...

    But anyway we have the open question why CRM is responding with the URL including the "%7B634982561690003236%7D"
    when the traffic runs over the Reverse Proxy?

    Maybe someone has an proper hint for me.
    Thanks a lot...


    Christian


    Cheers Christian

    Friday, April 12, 2013 8:37 AM