locked
External Communication Issues with Skype for Business RRS feed

  • Question

  • We have a Skype for Business Server 2019. [On-Prem] [Not Online]

    Communication within the internal network appears to work fine. Chat works, Video/Audio works, file transfers work. There does not appear to be anything that is causing issues with communication inside of the network.

    However all of the external traffic is having some problems. External users can connect into Skype no problem (no certificate issues), but cannot establish an audio/video feed it will all fail due to network issues. Also cannot transfer any files it will fail almost immediately as well.

    Right now the following ports are open on the firewall and NAT directly to the Skype server [444, 3478, 5061, 5062, 664, 554, 4443]. All traffic from 443 is routed through a pass through sorted by FQDN to its destination server. Also tried to route 443 traffic external to 4443 traffic to see if that resolved some issues but it did not. I am guessing this has something to do with how the topology is set up or some other factor that I am missing somewhere. Any insights you have on this problem would be immensely helpful.

    Thank you! 

    Tuesday, April 21, 2020 2:35 PM

All replies

  • Hi JordanReich,

    Could external users chat with each other?

    Does this issue persist all the time? Or what do you do before this issue happened?

    According to your description, this issue seems related to the A/V Edge service on Edge server.

    It recommends you check if the service on the Edge server are running.

    Then, check if you enable external access correctly. Verify by the following steps:

    1. Go to Skype for Business server control panel > Federation and External Access  
    2. Under External Access Policy page, open the default Global policy and check the Enable communications with remote users option.                                
    3. Under the Access Edge Configuration page open the default Global policy and check the Enable remote user access option.                                                         

    If it is no luck, you can check if there is any related error message in Edge server event viewer.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, April 22, 2020 2:38 AM
  • Hi Sharon,

    Thank you for the quick response!

    Yes external users can chat with users inside of the network and vice versa. There does not appear to be any issues in the chat realm of things at all.

    All services appear to be working fine.

    In reviewing the settings that you have provided to check everything appears to be set as you suggested already.

    As you have suggested I have also taken a look at the edge server event viewer. (We use one environment for everything related to Skype we do not run a multi server environment).

    Attempted a connection and received the following error @ 06:24 AM, my time.

    The error I do see in the event logs consistently repeated is the following:

    "Skype for Business Server 2019, File Transfer Agent cannot get replication status from Replica Replicator Agent on Edge" - That there is no endpoint listening.

    I will follow this rabbit hole and report back shortly.

    Thanks!

    Wednesday, April 22, 2020 1:27 PM
  • Hi JordanReich,

    According to the error message, it seems to be a firewall issue.

    You can follow this blog to troubleshoot: https://www.wavecoreit.com/blog/serverconfig/event-id-1046-file-transfer-agent-cannot-send-replication-data-to-replica-replicator-agent-on-edge/.

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, April 24, 2020 7:19 AM
  • Hi JordanReich,

    Is there any update on this case?

    Please feel free to drop us a note if there is any update.

    Have a nice day!


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, April 30, 2020 8:51 AM
  • Hi Sharon,

    Thank you for keeping on top of this. Yes we went through a fairly significant reconfiguration and have been able to get the system up and running where it was failing before. 

    We now only have one outstanding issue where Android phones cannot connect into Skype for Business. It returns an error of "we can't sign you in please check your account info and try again". 

    All of the mobile options appear to be enabled correctly. Any thoughts?

    Thanks!

    Thursday, April 30, 2020 1:07 PM
  • Hi JordanReich,

    Can user log in IOS client?

    Do you deploy and configure mobility for Skype for Business server?

    If not, please refer to this article to set up mobility service which allowing mobile devices to be able to take advantage of Skype for Business Server Mobility feature.

    If you have set up mobility service, you could check if there is any related error message in front-end server event viewer.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Monday, May 4, 2020 8:52 AM
  • Hi JordanReich,

    Is there any update on this case?

    Please feel free to drop us a note if there is any update.

    Have a nice day!


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, May 12, 2020 5:26 AM