none
Users Do Not Show in Resource Center Project Server 2010 RRS feed

  • Question

  • Hello!

    I am trying to set-up a Project Server for my company.  I have the Administrator's Guide and am going through it as I get things set up.  I am trying to put a test project on the site to make sure I have everything set up correctly.  I have several users set up, but not one shows up in the Resource Center?  I checked the 'Allow User to be Assigned as Resource" box in the main set-up.  I tried deleting a user, then going to the Resource Center and adding the user through Add Resource, but still nothing?  It does add them to the directory, but no resources show up in Project Professional 2010, nor PWA when I try to assign a resource to a task?

    These are work resources that have logon accounts.  Anyone have an idea of where I am going wrong?

    Thanks in advance for any help!

    Monday, September 17, 2012 4:25 PM

All replies

  • Nathan --
     
    Do you have the All Resources view applied in the Resource Center page in PWA?  If you navigate to the Queue, are any Queue jobs blocked or not processing?  Let us know and we will try to help.

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Monday, September 17, 2012 5:09 PM
    Moderator
  • Yes, all resource view was applied and no jobs are blocked.  However, when I use the default administrator account, I can view resources.  But, when in a different group with lower permissions I cannot.  Is it because of the "Manage Active Directory" is allowed on the default administrator account and not on others?

    I would assume this would be a problem for anyone set as a 'Project Manager'.  If I am adding users that are in our active network directory as resources, I want the Project Managers and Resource Managers to be able to view and select the users as resources in their projects, but to not be able to delete them.  Is there another way around this?

    Monday, September 17, 2012 5:47 PM
  • Nathan --
     
    If you can see the resources when you are logged into Project Server 2010 as a member of the Administrators security group, but you cannot see them if you are logged in as a member of the Project Managers group, then this means that you have changed the permissions in the Project Managers group to disallow this.  So, precisely WHAT permissions have you changed in either the Project Managers group, or the My Organization category, or the My Projects category?  Let us know and we will try to help.
     

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Monday, September 17, 2012 7:17 PM
    Moderator
  • Dale,

    I have not changed any permissions.  They are all still at the default settings.  It is the Manage Active Directory permission that governs this.  How do people get around this currently?  If my Resource Center is made up entirely of members of my active directory, they cannot be added to a Project by the Project Manager, unless they have Allow under "Manage Active Directory".

    Currently, for this situation to work an Administer must create a new project, and assign a Team in the Build Team property.  After those resources are chosen, the Project Manager has access to the selected Team the Administrator assigned.  I do not want this to work like that.  I want the Project Managers to be able to pull different Resources from the pool based on availability, but cannot do this without allowing Project Managers to Manage the Active Directory.

    Is there a way to accomplish this without giving the Project Managers the ability to delete people from the active directory?

    Monday, September 17, 2012 7:41 PM
  • Nathan --
     
    I can assure you that the Manage Active Directory permission is NOT the source of your problems.  Out of curiosity, are you using the built-in security groups that ship with Project Server 2010?  For example, have you added your PMs to the default Project Managers group?  If so, they have permission by default to see ALL resources in the Resource Center, and to see all resources in the Build Team dialog in Microsoft Project 2010.  Let us know and we will try to help.
     

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Monday, September 17, 2012 11:51 PM
    Moderator
  • As dale said this is not about the Manage AD permission.

    As he said make sure the user in question is in the Project Managers security group in project server.

    if they already are then

        • Open the Project Managers group
        • In the Categories list box verify that My Organization is there
        • If it is not then you dont have the 'default' configuration. Add My organization to the list of categories for this group.
        • If it IS then select it.
        • In the grid that pops up see if the View Enterprise Resource Data and Assign Resource permissions are checked.
        • If they are checked already then close this page and go to Manage categories
        • Click on My Organization
        • In the REsource section is the option button "All current and future resources' checked?
        • If no then check it.


    Brian Kennemer - Project MVP
    DeltaBahn Senior Architect
    endlessly obsessing about Project Server…so that you don’t have to.
    Blog | Twitter | LinkedIn


    Tuesday, September 18, 2012 12:03 AM
    Moderator