locked
windows mail cannot be set as default mail client RRS feed

  • Question

  • Hi Guys

    I am not sure if I have posted this question in the correct place so apologies in advance if I have placed it, in the wrong place.

    my problem which I require  a solution for  is:

    I cannot set windows mail as my default client hence when I try to send a page or a link from IE7 or Firefox, I get a "application not installed properly error".

    Background info

    I have uninstalled the office 2007 trial oem application and the office 2007 verification assistant, therefore outlook has been removed


    I have tried the following:

    • entering default programs and setting windows mail as default ( unsuccessful)
    • In IE7 entering /Tools/Options/programs and setting windows mail as default, this would take me to default program again ( unsuccessful)

    • Installing thunderbird and going through all the procedures above ( unsuccessful)


    Also after all this the "send page", "send link options in IE7 are still greyed-out so i have been very unsuccessful at trying to get something to work that should in essence work just work automatically 
     

    Can someone please help

    Friday, January 9, 2009 11:03 AM

Answers

  • Hello,

     

    The issue should be caused by improper default email program setting. Let us try the following steps to test the issue:

     

    First set Windows Mail as the default email client.

     

    1. Click Start, select Default Programs.

    2. Click Set program access and computer defaults.

    3. Click Custom, and select Windows Mail in Choose a default e-mail program:).

    4. Click OK.

     

    If the above steps could not work well, we'd better change the registry keys.

     

    1. Click Start, copy and paste regedit in the Start Search bar and then click Enter.

    2. Navigate to the following key:

        HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    3. Right click Mail key and select Export to make a backup.

    4. Double click (Default) subkey in the right pane.

    5. Type Windows Mail as the value data.

    6. Click OK.

     

    Then restart the computer to test the issue.

     

    Good Luck!

    • Marked as answer by Andy Song Monday, January 19, 2009 6:54 AM
    Monday, January 12, 2009 9:00 AM

All replies

  • Hello,

     

    The issue should be caused by improper default email program setting. Let us try the following steps to test the issue:

     

    First set Windows Mail as the default email client.

     

    1. Click Start, select Default Programs.

    2. Click Set program access and computer defaults.

    3. Click Custom, and select Windows Mail in Choose a default e-mail program:).

    4. Click OK.

     

    If the above steps could not work well, we'd better change the registry keys.

     

    1. Click Start, copy and paste regedit in the Start Search bar and then click Enter.

    2. Navigate to the following key:

        HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    3. Right click Mail key and select Export to make a backup.

    4. Double click (Default) subkey in the right pane.

    5. Type Windows Mail as the value data.

    6. Click OK.

     

    Then restart the computer to test the issue.

     

    Good Luck!

    • Marked as answer by Andy Song Monday, January 19, 2009 6:54 AM
    Monday, January 12, 2009 9:00 AM
  • Andy

    thanks for the info I will keep that safe for next time. I managed to fix the problem by re-installing office 2007 (treated myself) . It's interesting that as soon as it installed my options for default email client started to work again, could this be a bug?

    Thanks again for the technical advice I am sure I will use it in anger for a friend soon?

    Cheers

     Dinos

     

    Friday, January 23, 2009 6:07 PM