locked
Server Connect website not accessible RRS feed

  • General discussion

  • Hi,

    I've done a clean install of the RTM (TechNet) Server 2012 R2 Essentials. Everything looks good, except that when I go to:

    <a href="http:///connect">http://<server>/connect

    I am prompted for a user ID and password "The server <server> at Digest requires a username and password"

    No matter what I put in here (standard user ID, Server Admin ID, or Administrator) it isn't accepted and I don't get to the Connect website.

    Can anyone shed some light as to what is going on here? I don't understand the reference to Digest - it is not the name or my server or domain or anything else I can remember configuring. Otherwise, everything seems to be OK.

    Thanks for your help,

    Dave

    • Changed type AnnaWYModerator Monday, September 30, 2013 1:07 PM please post to the right forum
    Sunday, September 15, 2013 5:17 PM

All replies

  • Hi Dave,

    Thanks for your posting.

    Please try to remove the authorization section in the web.config file and go to use Anonymous user identity.

    For detailed solution steps, please refer to this forum:

    Authentication on our webapp - need help to disable it:

    http://forums.asp.net/t/1457215.aspx

    In addition, In order to solve the problem more efficiently, I recommend you post the thread to the ASP.NET forum.

    http://forums.asp.net/

    I hope this helps.

    Monday, September 16, 2013 9:33 AM
    Moderator
  • Hi Anna,

    Thanks for the response.

    I will also post in ASP.NET forum, but I wonder if there is a problem with IIS? When I run up IIS Manager, I can see that the "Default Web Site" (which has the Connect page under it) has a status of stopped. When I try to start it, I get an error:

    "The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80/ for site 1. The necessary network binding may already be in use. The site has been disabled. The data field contains the error number."

    I'm not sufficiently familiar with IIS to know where to check other uses of Port 80. This is a pretty clean install so I don't think I have done anything to change the default config.

    Also, looking at web.config, I assume you mean the web.config in the root (Default Web Site) folder? Under, <system.web>, this has setting settings for:

        <authentication mode="None" />
         ...
              <add accessType="Allow" users="*"/>

    Is this sufficient?

    Thanks for your help.

    Dave

    Monday, September 16, 2013 11:25 AM
  • Hi Dave,

    To solve the error "The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80/ for site 1…”, please follow the steps listed in this article to fix it:

    You receive a "The process cannot access the file because it is being used by another process" error message when you try to start a Web site in the Internet Information Services MMC snap-in:

    http://support.microsoft.com/default.aspx?id=890015

    Since this problem is an IIS issue, I recommend you post the thread to IIS forum for more efficiently support.

    http://forums.iis.net/

    To change authorization rules with modifying the web.config under <system.web>, these article maybe helpful for you:

    Setting authorization rules for a particular page or folder in web.config:

    http://weblogs.asp.net/gurusarkar/archive/2008/09/29/setting-authorization-rules-for-a-particular-page-or-folder-in-web-config.aspx

    Web.config Location / Authorization / Windows Authentication problem....:

    http://forums.asp.net/t/1002975.aspx

    I hope this helps.

    Tuesday, September 17, 2013 1:40 AM
    Moderator
  • Can you post up a screen shot of the IIS section?


    Don't Retire TechNet

    Thursday, September 19, 2013 6:21 PM
  • Susan, Anna,

    Thank you for your help.

    I know have the Connect site working. If I edit the Site Bindings (for the Default Web Site), the bindings for both Port 80 and Port 443 were both set to "All Unassigned". Setting them to the actual IP address of the server then allowed me to start the Default Site and allow computers to access the Connect page (and successfully download and install the client connection software).

    See screenshots to show some of this.

    So, my questions now is -  Is this supposed to work with "All Unassigned"?

    Thanks again for your help

    Dave

    Saturday, September 21, 2013 11:37 AM
  • Did you run the domain name wizard and the connect to the network wizard first?  You don't set IP addresses or site bindings on this little guy like this.

    Bindings are all unassigned.

    Also it looks like your default web site is stopped right now?


    Don't Retire TechNet

    Saturday, September 21, 2013 4:51 PM