locked
Small Business Server 2011 Essentials Remote Web Access fails to connect to Windows 8.1 PC RRS feed

  • Question

  • I am using Remote Web Access (RWA) gateway with Small Business Server 2011 Essentials.

    There are several workstations all running Windows 7, and have been using RWA without an issue for well over a year.

    There is now a Windows 8.1 Pro PC added to this domain, but the Remote Desktop does not connect.

    The Windows 8.1 PC appears in the RWA pages, It requests the credentials to connect, and then fails with the following error:

    Remote Desktop can't find the remote computer "COMPUTERNAME". This might mean that the "COMPUTERNAME" does not belong to the specified network. Verify the computer name and domain that you are typing to connect to.

    I can connect to all other PC fine (running Windows 7). I have tried from different locations and PC's and the results are the same.

    I thought I had fixed this problem a few weeks back.  After running all updates on the server and Windows 8.1 PC, and rebooting both, the RDP worked, but I think it only worked once and then failed the next time someone tried to use it. I have not had a successful connection to the Windows 8.1 PC since.

    I am at a loss on how to troubleshoot this as there are no errors on the system which can't be accessed.

    Any suggestions will be appreciated.

    Saturday, August 2, 2014 7:12 AM

Answers

  • So it turns out my problem is more basic in a way.

    I turned off the Firewall on the Windows 8.1 PC and the RDP is now working.

    All the correct exceptions have been allowed, but unless I turn the Firewall off altogether, RDP is appears to get blocked by the Firewall.

    So now I am trying to work out why the Firewall blocks RDP, even though it is configured not to.

    • Marked as answer by Justin Gu Wednesday, August 20, 2014 1:18 AM
    Saturday, August 2, 2014 10:45 AM
  • Hi Mr Cheese,

    à I turned off the Firewall on the Windows 8.1 PC and the RDP is now working.

    Thanks for sharing in the forum. Your time and efforts are highly appreciated.

    Based on your description, this issue is related to Firewall. Would you please let me know current situation of this issue?

    Just addition. Please open Control Panel, select Windows Firewall and click Allow an app or feature through Windows Firewall. Then please check if Remote Desktop is allowed. Meanwhile, please click Advanced settings in Windows Firewall panel and click Inbound Rules, then check if rules which be related to Remote Desktop were enabled.

    If any update, please feel free to let me know.

    Hope this helps.

    Best regards,

    Justin Gu

    • Marked as answer by Justin Gu Wednesday, August 20, 2014 1:18 AM
    Tuesday, August 5, 2014 1:50 AM

All replies

  • So it turns out my problem is more basic in a way.

    I turned off the Firewall on the Windows 8.1 PC and the RDP is now working.

    All the correct exceptions have been allowed, but unless I turn the Firewall off altogether, RDP is appears to get blocked by the Firewall.

    So now I am trying to work out why the Firewall blocks RDP, even though it is configured not to.

    • Marked as answer by Justin Gu Wednesday, August 20, 2014 1:18 AM
    Saturday, August 2, 2014 10:45 AM
  • Hi Mr Cheese,

    à I turned off the Firewall on the Windows 8.1 PC and the RDP is now working.

    Thanks for sharing in the forum. Your time and efforts are highly appreciated.

    Based on your description, this issue is related to Firewall. Would you please let me know current situation of this issue?

    Just addition. Please open Control Panel, select Windows Firewall and click Allow an app or feature through Windows Firewall. Then please check if Remote Desktop is allowed. Meanwhile, please click Advanced settings in Windows Firewall panel and click Inbound Rules, then check if rules which be related to Remote Desktop were enabled.

    If any update, please feel free to let me know.

    Hope this helps.

    Best regards,

    Justin Gu

    • Marked as answer by Justin Gu Wednesday, August 20, 2014 1:18 AM
    Tuesday, August 5, 2014 1:50 AM