none
Office 365 Pilot Users - Exchange Needs your Credentials in Skype for Business RRS feed

  • Question

  • We are in the midst of migrating On-Premise Exchange mailboxes to Exchange Online.

    Currently, our Autodiscover DNS entries point to our On-Premises Exchange Client Access Server. This works very well with Skype For Business On-Premises integrating Calendar and Status information.

    Eventually all of our users will be using On-Premise Skype for Business with Exchange Online. Once we have migrated everyone we change our Autodiscover DNS entries to match the Exchange Online URLs.

    Unfortunately though, we have a small pilot user group who now have their Mail in Exchange Online. They will be using Skype for Business On Premises with Exchange Online, and at the moment the are all continually prompted to enter their Exchange credentials whenever they have Skype for Business open. This is definitely due to the autodiscover DNS entries not pointing to the Exchange online Tenant URLs for our Domain, but is there a way we can fix this for our pilot users during the migration?I can't change the Autodiscover DNS entries as it will break the remaining 500 or so users' integration between Skype for Business and Exchange.

    I've been hunting for a solution to this issue and no one seems to have a good way to fix this during a pilot migration.

    Wednesday, November 27, 2019 5:59 PM

All replies

  • Hi TheWaker1,

    Do you enable office 356 MFA?

    If you set up mailboxes in Exchange Online in Office 365 by using Modern Authentication and Multi-factor Authentication (MFA) with OAuth. You need to unblock MFA in Exchange Online. You have to set the “AllowADALForNonLynIndependentOfLync” registry key correctly for Windows desktop clients.

    Note that serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method.

    For more information, please refer to:

    https://docs.microsoft.com/en-in/SkypeForBusiness/troubleshoot/hybrid-exchange-integration/allowadalfornonlyncindependentoflync-setting

    In addition, you could try to log out of Skype for Business, delete the saved credentials, and enter the password again.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, November 28, 2019 5:06 AM
    Moderator
  • No this is not the issue unfortunately. We have these settings turned on already. 

    The issue is that Skype makes use of an autodiscover DNS entry to configure its connection to Exchange. Skype Can't find Exchange after a user is migrated to O365 (our pilot users). The Internal and External EWS URLS don't populate any longer for users who have been migrated to Exchange Online.

    Thursday, November 28, 2019 9:19 PM
  • Hi TheWaker1,

    Maybe, you should refer to Skype for Business server integrate with Exchange online:

    https://blogs.technet.microsoft.com/nagshettykadwadi/2017/10/18/integrate-skype-for-business-server-with-exchange-online-unified-messaging-in-hybrid-scenario/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.



    Tuesday, December 3, 2019 10:01 AM
    Moderator
  • Hi TheWaker1,

    Is there any update on this case?

    Please feel free to drop us a note if there is any update.

    Have a nice day!

     


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 11, 2019 9:22 AM
    Moderator
  • Here I will provide a brief and temporary summary of this post.

     

    <Request/Expectation>:

    User is migrating Exchange on-premises to online.

    When the Autodiscover DNS entries point to the On-Premises Exchange Client Access Server, it works well.

    When the Autodiscover DNS entries point to the Exchange online, the SFB client continually prompts to enter exchange credentials.

     

    <Suggestions>:

    Refer to the integrate SFB with Exchange online.

     

    <Reference Links>:

    https://blogs.technet.microsoft.com/nagshettykadwadi/2017/10/18/integrate-skype-for-business-server-with-exchange-online-unified-messaging-in-hybrid-scenario/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, December 27, 2019 8:55 AM
    Moderator