locked
File Association... RRS feed

  • Question

  • Ok, get this...

    This is the 2nd time the following has happened in my company:

    We create compressed files everyday with a .DAILY extension that is unzipped and uncompressed after double-clicking on the .DAILY file.  When the files get unzipped, the files then need to be opened in Notepad to view the contents.  Well...we have a few novice users here, after they got a new Windows 7 pc (64-bit)...when the screen appeared asking them which program to use to open the files, they erroneously clicked "OK" on the first thing in the list, which is "Adobe Reader", instead of choosing "Notepad".  In Windows XP, this was an easy fix.  Go to the file association area and associate the file with the proper program, in this case Notepad, and you're all set.  Well, I do that in Win 7 and nothing happens!  It correctly lists "Notepad" as the program to open the file in the "File Association" area...but it still tries to open in Adobe when I actually double-click the file!  (Even the unzipped files...they originally showed Adobe's icon next to the file...then after I made the change in File Association, the icon next to the file changed to the Notepad icon...but it STILL tries to open in Adobe!)

    The first person this happened to, we had to format the PC and start from scratch!  It simply would not associate properly, no matter how hard we tried (had the entire IT staff look at it).  It happened again today and there's no way I'm formatting this PC!  So I need some help please!!!  Thank you.

    JD
    Monday, March 7, 2011 4:55 PM

Answers

  • Okay, so your problem is with .TXT instead of .DAILY - that doesn't reduce your options to "reformat harddisk" as noted in your original post.  If Adobe Reader doesn't behave your last resort is to uninstall it, check that .TXT is opened in notepad, and install Adobe again.

    What does assoc .txt (in a CMD-window) say?  It should be txtfile - if not fix it with assoc .txt=txtfile (in an admin-CMD-window).

    What does ftype txtfile say? It should be txtfile=%SystemRoot%\system32\NOTEPAD.EXE %1

    If not fix it with ftype txtfile=%SystemRoot%\system32\NOTEPAD.EXE %1

    After you checked that, and if it still does not work, we can tackle your real problem.

    • Marked as answer by Cloud_TS Saturday, March 26, 2011 4:45 AM
    Tuesday, March 8, 2011 8:04 PM

All replies

  • One quick and easy way to do this in Windows 7 is to navigate to the file directory. Then hold the SHIFT key and right-click the file and choose OPEN WITH and then CHOOSE DEFAULT PROGRAM. This will open a new dialog window. From there, click BROWSE and navigate to c:\Windows\System32\ in which you will see NOTEPAD.exe. Before clickin ok (on the OPEN WITH dialog window), make sure and check the box that says "Always use the selected program to open this kind of file" option. Then click OK to save.

     

     

    This will ensure the file type is always associated with that application... In this case, NOTEPAD.exe.

    Monday, March 7, 2011 11:20 PM
  • DAILY shouldn't occur too often when you search with regedit.  Make sure to start the search at the top ("computer"), not at your last regedit-position.   I get a bunch of "Idaily trigger" hits, skipped with F3.  A "Daily" key below "usagestats", skipped with F3.   Ditto "DailyPing", no "DAILY" at all.  Whatever you find is related to your problem.  If you find a "DAILYfile" or "autoDAILY" value (REG_SZ) for ".DAILY" search that value (again from the top).

    Don't modify anything for now, just check what you see.  If you hate "regedit" use "assoc .DAILY" and "ftype whatever-assoc-said" in a CMD-shell.  Use "ftype /?" and "assoc /?" to see the syntax.  If you intend to kill obvious nonsense with "assoc" or "ftype" you need an admin-CMD-shell.  But your issue is not that simple, something beyond assoc/ftype is wrong.

     

    Monday, March 7, 2011 11:26 PM
  • Well...I mean, maybe I'm not explaining it correctly...

     

    I've done what you described above already.  It already correctly shows "Notepad" to be associated with .TXT files (in the file association area).  But it STILL opens with Adobe!  The user originally chose Adobe (accidentally) and even though we go back and select Notepad, and select "Always use the selected program to open this kind of file" check-box, it STILL opens in Adobe.

     

    It's madddening.  Any ideas??

     

    Thank you!!

     

    JD

    Tuesday, March 8, 2011 6:55 PM
  • My apologies...I should have left that part about the .Daily files out.  We just double-click on that file and opens a zipped window with the files that were in the .DAILY file.  Those files, the ones included in the .Daily emails, are text files and should open with Notepad.  Well, when the user double-clicked on the file that should open to Notepad, it asked for which program to open the file with...and the user, at that point, should have browsed out and selected "Notepad".  She, instead, just clicked "Ok", which selected the highlighted item...Adobe Reader.

    So when I went to her computer, it showed the .TXT file to open with Adobe in the File Association area.  I changed it so it opened in Notepad (and made sure "Always use this..." was checked).  So then she goes back to a different .TXT file...and it STILL opened in Adobe Reader!  Even though, if you go into File Association, it shows the Notepad icon next to the .TXT extension and it claims it opens .TXT files in Notepad!  But it just doesn't...it always tried Adobe for some reason.  Makes no sense at all.

    Thank you!!


    JD

    Tuesday, March 8, 2011 7:02 PM
  • Okay, so your problem is with .TXT instead of .DAILY - that doesn't reduce your options to "reformat harddisk" as noted in your original post.  If Adobe Reader doesn't behave your last resort is to uninstall it, check that .TXT is opened in notepad, and install Adobe again.

    What does assoc .txt (in a CMD-window) say?  It should be txtfile - if not fix it with assoc .txt=txtfile (in an admin-CMD-window).

    What does ftype txtfile say? It should be txtfile=%SystemRoot%\system32\NOTEPAD.EXE %1

    If not fix it with ftype txtfile=%SystemRoot%\system32\NOTEPAD.EXE %1

    After you checked that, and if it still does not work, we can tackle your real problem.

    • Marked as answer by Cloud_TS Saturday, March 26, 2011 4:45 AM
    Tuesday, March 8, 2011 8:04 PM