locked
Windows updates re-enable wake-armed state for mouse, keyboard and NIC, why? RRS feed

  • Question

  • Hi,

    I notice that every now and then, especially when Windows updates were installed, my mouse, keyboard and NIC regain the ability to wake up the computer. This happend the last time when the "big" Windows 10 update in November 2015 was released. I wonder why.

    Background: normally, I do not want that mouse movement or pressing a key on my keyboard wakes up my computer from hibernation, so I disable all wake events in device manager in the Energy settings of every device. If a device can be used to wake up the computer, it can be disabled here, and that's what I keep doing all the time. You can check which devices currently can wake up the computer using the following commandline:

    powercfg -devicequery wake_armed

    What I notice since Windows 7, and now again under Windows 10 is, that no matter if you disable the devices, certain updates seem to reset that behaviour. I normally notice that the settings have changed again when I hibernate my computer, and accidentally moving the mouse wakes it up.

    I hate that behaviour, so how can I permanently switch it off, and why is Microsoft not capable of remembering these settings permanently, even when updates are installed? Does anybody know which updates exactly reset that behaviour? Just for your interest, after the November 2015 Windows 10 update, my Realtek network card, as well as my Logitech cordless mouse and my Microsoft Wired Desktop keyboard were wake-armed again, which is definitely unwanted :(
    Thursday, November 19, 2015 5:34 AM

All replies

  • The November update is essentially a new install and the wake states are by default enabled.  You are just going to have to disable them again.

    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    • Proposed as answer by Michael_LS Friday, November 20, 2015 7:37 AM
    • Marked as answer by Kate LiMicrosoft employee Wednesday, December 9, 2015 2:22 PM
    • Unmarked as answer by Erik78 Thursday, December 10, 2015 8:29 PM
    Thursday, November 19, 2015 10:57 AM
  • The November update is essentially a new install and the wake states are by default enabled.  You are just going to have to disable them again.

    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    I also used to have these kinds of problems after updates that were no complete re-installs (as far as I remember, there were no updates requiring reinstallation under Windows 7, and the problem occurred there as well).

    Finally, this is just a user setting, like for example, a desktop wallpaper, which Windows is obviously capable of remembering - why not essential settings like the wake-armed settings? They are user settings as well, and should be remembered just like eerything else! Everything else is a bad design in my eyes

    Thursday, November 19, 2015 11:11 AM
  • Hi Erik78,

    Thank you for your voice.

    I would agree with you that the settings should be considered as the user settings.

    What I would mention is that, just as Team Zigzag suggested, The November update is just like the upgrade install, which would have the related device Driver re-installed, this would make the configured settings back to default.

    We may submit feedback on this topic, there should be settings available to remember those settings, and the next time after driver changes, those settings could be restored, or re-configured.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, November 20, 2015 7:46 AM