none
Found a bug already? - Unable to set time zone RRS feed

  • Question

  • Hi.

    I have just installed Build 17713, and noticed I cannot change the time zone.

    I right click on the time/date, select Adjust Date/Time, then use the pulldown menu to set where I actually am.

    This machine is a domain member. Time zone automatically set itself to (UTC + 10:00) Canberra, Melbourne, Sydney, however the actual zone I am in is (UTC + 08:00) Perth.

    The Server 2016 machine I have configured identically works as expected, changing the time zone takes effect as soon as a new one is selected from the drop down. I am of course an admin on both machines.
    Tuesday, July 24, 2018 4:15 AM

All replies

  • OK, I tried going via Control Panel, Date and Time, Change Time Zone. This does not work either, but I get some more information. (see pic). I am definitely an admin on this system, and a 2016 server configured pretty much identically does not have this issue. No problems change the time, I am only unable to change the zone.

    Pic not included, as my account here is not yet verified. It says "Unable to continue You do not have the permission to perform this task. Please contact your computer administrator for help"   




    Tuesday, July 24, 2018 4:33 AM
  • Error for me in Control Panel, Time is access denied, so an oddity in this build. Report via the Feedback app.

    Work around seems to work for me (turn off auto update if it reverts), from an Admin PowerShell prompt;

    Set-TimeZone -Name "W. Australia Standard Time"

    Tuesday, July 24, 2018 9:46 PM
  • Hi Mal Osborne,

    Thank you for your question.

    I have built a test environment with the latest version of Windows Server 2019 build 17713. I changed the time zone as local administrator and domain administrator via control panel. The time zone changed normally.

    Here is a link that post announcement about Windows Server 2019, please focus on it.

    https://techcommunity.microsoft.com/t5/Windows-Server-Insiders/Announcing-Windows-Server-2019-Preview-Build-17713/m-p/216470#M534

    Appreciate your patience and support. 

    Best regards,

    Frank


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Proposed as answer by That Tall Guy Wednesday, June 5, 2019 8:54 PM
    Wednesday, July 25, 2018 7:36 AM
    Moderator
  • Hi,
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Frank

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, July 26, 2018 9:50 AM
    Moderator
  • Hi,

    Was your issue resolved? 

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.


    Best Regards,
    Frank

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, July 30, 2018 7:41 AM
    Moderator
  • Fixed in 17723
    Thursday, August 2, 2018 6:59 PM
  • Fixed in 17723

    Server 2019 RTM and the bug is still present when I try to change the time zone from a domain account that is local admin on the server.
    Thursday, October 4, 2018 6:43 PM
  • Fixed in 17723


    Server 2019 RTM and the bug is still present when I try to change the time zone from a domain account that is local admin on the server.

    Well was fixed in the that build, one of the things I tested with each new release. But as you say back in the release (at least in the Eval version I am trying on).
    Thursday, October 4, 2018 7:16 PM
  • Confirm. The problem is the same at my side after the "re-relesed" RTM is installed.

    Time zone doesn't change using the Settings menu and I get Access Denied if I try to set from Control Panel.

    I am Domain Admin and local Admin the server is a domain member. Build number: 1809

    Edit: Set-TimeZone PS command works.


    I'm not a developer! I'm an infrastructure engineer! Please be patient on the development forums! :)



    • Edited by Homecsiga Tuesday, November 20, 2018 3:34 PM grammatical update
    Tuesday, November 20, 2018 3:32 PM
  • tzutil /s "Timezone"
    That also no longer works without an elevated command prompt window.






    • Edited by ssh-pvi Monday, November 26, 2018 9:46 PM
    • Proposed as answer by coinservices Tuesday, January 15, 2019 2:57 PM
    Monday, November 26, 2018 9:43 PM
  • It works for me if I turn off UAC
    Friday, November 30, 2018 10:41 PM
  • Version 1809 17763.134 - changing the timezone did not work logged in as a domain admin.  No error.  

    Disabled UAC - no help.

    I had to log in as local administrator to change the timezone.

    Monday, December 3, 2018 3:56 PM
  • Hi, same thing here with version 1809 - 17763.134.  Domain admin user with local admin right.

    Changing TZ with the GUI doest not work.

    I was able to  change it using the set-timezone cmdlet 

     set-TimeZone -Name "Romance Standard Time"

    Wednesday, December 5, 2018 12:47 PM
  • UAC is enabled and is blocking it. turn off UAC and it will work fine
    Thursday, December 20, 2018 5:23 PM
  • Launch cmd prompt as administrator, run timedate.cpl, change timezone as needed.
    Thursday, December 20, 2018 8:42 PM
  • I concur that this is the correct work around.  Log in as local admin not domain account with local admin rights.

    I'm running 17763.253

    Tuesday, January 22, 2019 4:25 PM
  • Still present in 10.0.17763.107

    Used Commandlet to set.... Very annoying though...

    Wednesday, January 23, 2019 3:05 PM
  • I've just installed two instances, one as an upgrade over existing OS.  No problem.

    One as a fresh install.  Same problem as described.


    This solution 

    tzutil /l

    tzutil /s "Select Your Timezone"

    worked for me.

    Version 1809

    Build 17763


    • Edited by AW_UK Thursday, February 7, 2019 8:14 AM
    • Proposed as answer by Victor Radchenko Monday, February 11, 2019 7:10 AM
    • Unproposed as answer by Victor Radchenko Monday, February 11, 2019 7:11 AM
    • Proposed as answer by Mahesh Dasari Saturday, June 15, 2019 7:00 AM
    Thursday, February 7, 2019 8:12 AM
  • Worked like a charm.

    Ravi Srivastava

    Tuesday, February 19, 2019 6:16 AM
  • This fixed my problem on win Server 2019 Essentials  1809 Build 17763.348

    Had the same issue with the server being stuck on Pacific Time Zone. Domain Admin account was unable to modify, but running timedate.cpl as administrator allowed the zone to be modified.

    thx

    Wednesday, March 13, 2019 5:52 AM
  • Launch cmd prompt as administrator, run timedate.cpl, change timezone as needed.

    This worked for me..

    But it's pretty scary that something so simple is broken..


    Rob

    Friday, March 15, 2019 9:49 PM
  • Using the Dell production released version.  Same issues exists with time, as well as GUI licensing fails but slmgr from Admin CMD did work....GRRRR

    Sunday, March 31, 2019 4:57 PM
  • Can confirm is still an issue on 17763. Powershell command worked.
    Friday, April 12, 2019 12:56 PM
  • Yes, it continues. Version:17763.437 

    Commands that work in CMD(elevated):
    timedate.cpl
    tzutil /s "TIMEZONE"

    PowerShell:
    Set-TimeZone -Name "TIMEZONE"

    Wednesday, April 24, 2019 7:33 PM
  • Change the value of the following Local Security settings to 'Disabled'

    Local Computer Policy > Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options
    User Account Control: Admin Approval Mode for the Built-in Administrator account

    Then reboot the machine and check if the issue still occurs.


    • Edited by Alon08 Sunday, April 28, 2019 3:25 PM
    Sunday, April 28, 2019 3:25 PM
  • Launch cmd prompt as administrator, run timedate.cpl, change timezone as needed.

    Windows Server 2019 Datacenter, timezone stuck in Pacific, this worked in admin powershell session like a charm.
    Sunday, May 5, 2019 3:38 AM
  • I was able to update the time zone in the Server Manager under the Local Server properties. I clicked one the incorrect time zone to the right of the timezone. The "Date and Time" window popped up. then I was able to click change time zone and select the correct time zone. I was able to navigate to the "Date and Time" window before I figured out this fix but was not able to change the time zone. The way above was the only way I was able to change the time zone and make it stick. 
    Wednesday, June 5, 2019 9:01 PM
  • So, have you tested in this GPO setting works before posting the suggestion?
    Monday, June 17, 2019 1:01 AM
  • Stefano, He did not answer because it does not work. TZutil is the solution as already mentioned above.
    Thursday, July 18, 2019 9:22 AM