IIS Installed, Not Listed in Server Roles RRS feed

  • Question

  • I have Exchange 2010 SP1 with Mailbox, CAS and Hub all on one server.  For some reason, in Server Roles it shows that IIS is not installed, but is.  For one thing, OWA works.  The real problem is that when I tried to install Service Pack 2, it failed on the Mailbox role part, so I was left with a partially installed Exchange.  (BPA showed both "MailboxRole configured partially" and "MailboxRole not configured".)  Interestingly, users could still get messages, including new ones, but OWA, ActiveSync and RPC/HTTP stopped working.

    I ended up restoring the entire server from a bare metal backup.  I get the feeling that I need to fix the IIS issue before making a second attempt to install SP2.  Any ideas as to how to fix this?


    Saturday, September 22, 2012 5:32 AM


All replies

  • Not sure if IIS is the cause of SP2 installation issue, could you provide the ExchangeSetupLog for more information on SP2 installation fail?

    Regarding the IIS, generally we reinstall IIS component and then reset all virtual directories:

    Refer to:


    Fiona Liao

    TechNet Community Support

    Monday, September 24, 2012 2:16 AM
  • Thanks, I'll try that when I have a chance.

    I don't have the setup logs because I restored the server to a point in time before that.  I thought I had copied the error message somewhere, but I can't find it.

    I'm willing to try the SP install again once IIS looks right.

    Tuesday, September 25, 2012 12:43 AM
  • Thanks. Let me know if there is anything I can do for you.

    Fiona Liao

    TechNet Community Support

    Tuesday, September 25, 2012 1:13 AM
  • I installed the IIS components and reset the virtual directories.  That got everything looking right, but it had nothing to do with the service pack install failure as it turns out.  This is where it failed on installing the Mailbox role:

    ErrorRecord: Couldn't resolve the user or group "blahblah.com/Microsoft Exchange Security Groups/Discovery Management." If the user or group is a foreign forest principal, you must have either a two-way trust or an outgoing trust.

    I followed the instructions here to resolve it:


    It was just a matter of deleting the "DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}" user account, which allowed the SP install.  Then I ran "setup.com /prepareAD" to bring back that account and then I mail-enabled it.

    So now both problems are solved.


    Friday, September 28, 2012 4:04 AM