locked
Outlook not showing attachment, OWA does RRS feed

  • Question

  • Environment:  Single Exchange 2007 8.01.0436.000  (SP1?), Outlook 2003/2007/2010, Anti-Spam handled by Barracuda Anti-Spam

    Basically, an email (EM1) with an attachment (JPG, XLS, DOC, PDF, etc) comes in from an external person, typically a government type email (.gov, .mil).  Outlook 2003, 2007, and 2010 show that the email size is well over 100 KB.  No attachments visible.  Can't save attachments via File, nothing.

    EM1 forwarded from Outlook version XX to any other Outlook version including back to self = no visible attachment

    EM1 forwarded via Outlook to Yahoo, Gmail, Hotmail, etc = attachment visible

    EM1 viewed in Mozilla Thunderbird, OWA, iPhone, Droid = attachment visible

    EM1 forward to self from OWA = attachment visible

     

    The only common item that I can tell is, when it isn't visible, Outlook is showing TNEF/winmail.dat.

    Non-visible attachment email header (this one is from me to me, but it looks the same from an external sender to me):

    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: "Me" <user@internal.com>
    To: "Me" <user@internal.com>
    Date: Mon, 29 Nov 2010 13:18:35 -0600
    Subject: FW: An email
    Thread-Topic: An email
    Thread-Index: AcuKI6bUAp0jCVWZRaGCo0RUr/A+QgAKMwywAAJSo0IABPwAwAFkGHyQAAAJryA=
    Message-ID: <9570FCB2DD870B4692083A08D14B9C7EF237C3DD66@my.internal.com>
    References: <9570FCB2DD870B4692083A08D14B9C7EF237C3D352@my.internal.com>
     <9570FCB2DD870B4692083A08D14B9C7EF237C3DD62@my.internal.com>
    In-Reply-To: <9570FCB2DD870B4692083A08D14B9C7EF237C3DD62@my.internal.com>
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach: yes
    X-MS-Exchange-Organization-SCL: -1
    X-MS-TNEF-Correlator: <9570FCB2DD870B4692083A08D14B9C7EF237C3DD66@my.internal.com>
    MIME-Version: 1.0

     

    I saw a previous 'answer' that suggested forcing the header type using a Transport Rule.  That didn't work either.  That just gives me a wierd header:


    Content-Type: multipart/mixed; name="winmail.dat";
        boundary="_8b394793-76c3-421b-a605-a884461a88df_"
    Content-Transfer-Encoding: binary
    From: "Me" <user@internal.com>
    To: "Me" <user@internal.com>
    Date: Mon, 29 Nov 2010 13:18:29 -0600
    Subject: testing pattern
    Thread-Topic: testing pattern
    Thread-Index: AcuP+jLrpwXixwbMT7+TWXPEmEigZw==
    Message-ID: <9570FCB2DD870B4692083A08D14B9C7EF237C3DD65@my.internal.com>
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach: yes
    X-MS-Exchange-Organization-SCL: -1
    X-MS-TNEF-Correlator: <9570FCB2DD870B4692083A08D14B9C7EF237C3DD65@my.internal.com>
    MIME-Version: 1.0

    I can't even recreate the issue sending myself and RTF message with attachment from Yahoo.  Though I'm open to ideas or suggestions of how to recreate it.

    I spoke with an admin for a .mil a few years ago who told me that their clients are defaulted to sending in HTML, but aren't allowed to by the server so everything is 'downgraded' to RTF.  No clue if that's true still, but maybe one of you whizzes out there can help me put the pieces together.  :-)

     

    Thank you in advance,

    John

    Monday, November 29, 2010 8:12 PM

All replies

  • Quote: “an email (EM1) with an attachment (JPG, XLS, DOC, PDF, etc) comes in from an external person, typically a government type email … I can't even recreate the issue sending myself and RTF message with attachment from Yahoo”

    So, does the issue only happen when the mails come from specific persons/domains?

    Have the attachments visible ever before from these specific persons/domains?

    Does the sender put the attachment in the message body as Inline Attachment? If yes, please confirm if the issue still appears if the sender just attaches the files

    Quote: “EM1 forward to self from OWA = attachment visible”

    Does the mail must be forwarded before visible on OWA?

    Resources:

    Inline attachments are not displayed in Outlook 2007 e-mail messages


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, December 1, 2010 5:35 AM
  • So, does the issue only happen when the mails come from specific persons/domains?

    Not that I've been able to discern other than 'government'.  .mil and .gov accounts are good at reproducing it.

    Have the attachments visible ever before from these specific persons/domains?

    Sometimes, yes.  It's not consistent.

    Does the sender put the attachment in the message body as Inline Attachment? If yes, please confirm if the issue still appears if the sender just attaches the files

    In this case, no, the file was attached.  However, inline pictures often produce the same result.

    Does the mail must be forwarded before visible on OWA?

    No, it's always visible in OWA.  It is not visible in Outlook 2003, 2007, or 2010.

    Friday, December 3, 2010 7:33 PM
  • Please enable the pipeline tracing and send the test mail again. Pipeline tracing can save the copy of the message whenever the message is being changed during the transport pipeline on the HT server. By open the Original.EML copy in the outlook, you can determine if the issue is caused on your side or not

    Using Pipeline Tracing to Diagnose Transport Agent Problems


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, December 6, 2010 2:56 AM
  • How's the issue currently?
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, December 8, 2010 1:43 AM
  • I am having what appears to be the identical issue - only started after our gateways were upgraded from exch2003 to exch2010...  Is there anything different about how 2010 handles this vs 2003?    (as a gateway only in my case....  the client is actually behind a sendmail server that is behind exch....)
    Thursday, December 9, 2010 6:23 PM
  • I'm working on getting someone to send me an email that will reproduce the results with pipeline tracing on.  Do you think we'd get useful information if it's an email that it is already bad being sent between to exchange users? 
    Friday, December 17, 2010 3:50 PM
  • James,

    I enabled Pipeling Tracing and got the incoming message captured.  All of the previously stated criteria still apply for where and how it is visibile.  Opening the captured Original.EML file does show the attachment both on Outlook 2003 and Outlook 2010.

    So what the heck is going on?  ;-)

    Thanks for all the help so far.

    John

     

    Monday, January 3, 2011 6:36 PM
  • Still looking for an answer if anyone else has any ideas.
    Monday, January 24, 2011 5:00 PM
  • I have the exact same problem, and hope for a solutiuon for this as well.

    So far, this happens when someone sends me email from a Lotus Notes server

     

    I can view it it OWA, but not in outlook2010

    (running Exchange2010, no antispam)

     

    btw: Read this

    http://support.microsoft.com/default.aspx?scid=kb;en-us;961940

    Monday, February 7, 2011 7:39 AM
  • Sitec-Kris,

    That KB actually fits it perfectly other than the client restriction.  I can reproduce it in Outlook 2003, 2007, and 2010.  Wonder if we can petition for a check box to allow malformed MIME types through...

    Thanks.

    Thursday, March 10, 2011 4:09 PM
  • did you have any luck in finding an answer ....... its infuriating i have the same thing !!!!!!
    Friday, June 3, 2011 11:51 AM
  • No, after having done the requested pipeline tracing, I've received no further ideas.  I have created more data points, but it boils down to:  If I use Outlook, the attachments won't always show.  If I use ANY other email client, including OWA, it will.
    Friday, June 3, 2011 2:57 PM
  • I had this problem, either not displaying attachments or recipients not being able to open them.

    I changed my email format from html to plain text and it seems to have solved the problem. Give it a try, fingers crossed it works for you too :)

    • Proposed as answer by dustandbullets Tuesday, August 30, 2011 10:25 AM
    • Unproposed as answer by John V_ Friday, September 9, 2011 8:12 PM
    Tuesday, August 30, 2011 10:14 AM
  • Thanks for the suggestion.  If the sender changes their format to plain text, it does indeed work.  I can't control/influence senders outside of my organization though so the 'problem children' keep sending RTFs with TNEF encoded attachments that Outlook fails to read. 

    Can't believe it's almost been a year on this with no change or help.

    Thanks again though, Dustandbullets.

     

    Tuesday, August 30, 2011 4:06 PM
  • I just had this issue and was able to resolve with the MS Outlook Engineering team as well as the Exchang Connectors Team.


    Environment

    Active Directory : 08R2 Std 

    Exchange: Exchange 2010 SP1RU4 Standard on 08R2 Standard

    1 DC, 1 EXC, 80 Users

     

    Symptoms

    Users report that some attachments from some external senders are not displayed on Microsoft Outlook 2010

    Users report that when they go into OWA the attachment not displayed in Outlook shows in the preview pane and in the message window. However no paperclip is displayed in the navigation pane

    Users report attachments not displayed in Outlook are displayed in BLackberry devices.

    Users report that when forwarding messages to external users, external users are able to see attachments.

    Users report that when forwarding messages to other internal users, attachments are still not displayed.

    Users report than when the attachment is stripped off and re-attached, they are able to view attachments correctly.

     

    Microsoft resolution steps. (Non-4-Hour version)

    Viewed header information

    Put pipeline tracing on affected sender

     

    Resolution Attempt #1

    http://support.microsoft.com/kb/954684

    Stop Exchange Transport service

    Navigate to C:\program files\exchange\v14\bin

    Edit the EdgeTransport.exe.Config file

    Add <add key="TreatInlineDispositionAsAttachment" value="true" /> between the <appsettings> and </appsettings>

    restart transport service

    HAve affected external user re-send email

    Attachment showed in Outlook as it does in OWA, however the paperclip icon was not displayed....

     

    OK... Half way there...

     

    Resolution 2

    Compared Content-Type headers of message that Microsoft forwarded back to me, vs the message they stripped and reattached and then re-sent.

    Good Message

    Content-Type: multipart/mixed;

    boundary="----_=_NextPart_001_01CC6EF9.4623A432"

    Bad Message

    Content-Type: multipart/related;

    boundary="----_=_NextPart_001_01CC6EFB.25D12830";

    type="multipart/alternative"

    The "multipart/mixed" and "multipart/alternate" showing in the content-type were the issue.

    Setup a transport rule to change these back to multipart/mixed as per the below

    1. Launch Exchange Management Console

    2. Expand Organization Configuration, and select Hub Transport

    3. On the right-hand Action Pane, select New Transport Rule …

    4. Give the rule a name (Ex:- Paperclip icon not showing)

    5. Select when the message header contains text patterns, click the highlighted “message header”, Type "Content-Type" click OK, and then click the highlighted “text patterns”, Type "multipart/related" click Add, click OK, and then click Next

    6. Select “set header with value,” click the highlighted “header” text, type “Content-Type”, click OK

    8. Click the highlighted “value” text, type multipart/mixed, click OK, and then click

    9. Next

    10. On the “Exceptions” page, simply click next

    11. At the final “Create Rule” page, click New, and then click Finish

     

    Restart the transport service

    Had user re-send message. Message delivered successfully.

     

    Hope this helps and perhaps saves a 4+ hour call to Microsoft...

     

    Dave Wilde -MCITP:EA, MCSE, CCNA, CCA

     


    Dave Wilde
    • Proposed as answer by Dannyss11 Friday, November 18, 2011 7:49 AM
    Friday, September 9, 2011 7:18 PM
  • Good stuff.  I'm working through this now.  Had to read the KB and use the Ex2007 option.  After doing that, I've got the attachments and no paperclip, but, the message header is already showing as Multipart/Mixed without setting up the transport rule.

    Much better than it was, as long as the users don't try to sort by paperclip, they can at least see something attached.  I'm sure they'll want it fixed and working 100% though.

    Thanks!

    John
    Monday, September 12, 2011 4:39 PM