none
"DPM is unable to enumerate Virtual SSP Writer" when trying to add SharePoint Services 3.0 to a protection group RRS feed

  • Question

  • Hi

    I am trying to protect SharePoint Services 3.0 with DPM 2012 R2 having checked the DPM support matrix and seen that it is possible.  I have reviewed and followed the steps in the following link:

    https://technet.microsoft.com/en-us/library/hh757889.aspx

    I have then configured SharePoint protection on the SharePoint server using the ConfigureSharePoint -EnableSharePointProtection (one server which has the SQL DB, WFE and SharePoint installed) and tried to create a new Protection Group on the DPM server with the SharePoint farm in it.  

    I have refreshed the server in the "Select group members" window but keep getting the "DPM is unable to enumerate Virtual SSP Writer on computer <servername> (ID: 3055)" error.  The recommended action is "Please ensure that Virtual SSP Writer is accessible to protection agent.

    I have tried with the firewall switched off and checked permissions in SQL for the NTAUTHORITY\SYSTEM account and everything seems to be in order but the problem still remains.

    The DPM server is in a different domain to the SharepPoint server but there is a trust and the DPM server has been successfully protecting other clients in this domain.

    I would also like to point out that the server was previously backed up successfully using DPM 2010 (both DPM server and SP server in the same domain in this previous setup).

    If anyone has any advice it would be much appreciated,

    Thanks

    Chris

    Tuesday, May 19, 2015 11:52 AM

All replies

  • Hi Chris,

    Please check if following steps could help:

    1. On SharePoint Server, open Regedit. Make a backup of the key we are going to edit first.
    2. In the registry go to HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent\2.0\
    3. Locate SharePointSearchEnumerationEnabled 
    4. Delete it. Reboot to see if issue still exists. 


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, May 21, 2015 2:17 AM
    Moderator
  • Thanks Shaon,

    I have tried this but it still does not work.  I don't get the error message but I only get the spsconfigdb available for backup.

    I then reran the configureSharePoint -EnableSharePointProtection and this didn't help so I ran the configureSharePoint -EnableSPSearchProtection which replicated the original error message and recreated the deleted registry key.

    I'm still only getting the servername\spsconfigdb and the SPSearchComponent_servername appearing under the SharePoint icon in the selection list.

    Could it be a permissions issue - the DPM server sits in another domain to the SharePoint server?

    Chris

    Thursday, May 21, 2015 7:38 AM