none
Enter-PSSession failing for some servers wsmanfault" Code="2147749907 RRS feed

  • Question

  • Hi Folks,

    I am facing issues in enabling PSRemoting on some servers.

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Enter-PSSession : Connecting to remote server failed with the following error message : <f:WSManFault xmlns:f="http://s
    chemas.microsoft.com/wbem/wsman/1/wsmanfault" Code="2147749907" Machine="ABC.domain.local"><f:Message></f:Message></f:WSManFault> For more information, see the about_Remote_Troubleshooting Help topic.
    At line:1 char:16
    + Enter-PSSession <<<<  ABC.domain.local
        + CategoryInfo          : InvalidArgument: (ABC.domain.local:String) [Enter-PSSession], PSRemotingTranspor
       tException
        + FullyQualifiedErrorId : CreateRemoteRunspaceFaile

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Name                               Value
    ----                                     -----
    CLRVersion                     2.0.50727.1891
    BuildVersion                   6.0.6002.18111
    PSVersion                      2.0
    WSManStackVersion              2.0
    PSCompatibleVersions           {1.0, 2.0}
    SerializationVersion           1.1.0.1
    PSRemotingProtocolVersion      2.1

    Any help would be greatly appreciated.

    Wednesday, July 27, 2016 8:49 AM

Answers

All replies

  • Hi Gasah,

    >>Enter-PSSession : Connecting to remote server failed with the following error message : <f:WSManFault xmlns:f="http://schemas.microsoft.com/wbem/wsman/1/wsmanfault" Code="2147749907"

    Please  try the following command to see if it helps:

    Enter-PSSession -computername -SessionOption(New-PSSessionOption -NoMachineProfile)

    Besides, please follow the below blog to check related settings:

    https://blogs.msdn.microsoft.com/wmi/2009/07/22/new-default-ports-for-ws-management-and-powershell-remoting/

    Best regards,


    Andy_Pan

    • Marked as answer by Gasah Thursday, July 28, 2016 10:12 AM
    Thursday, July 28, 2016 5:28 AM
    Moderator
  • Hi Andy,

    Thank you! Yes, it worked.

    Do you know the reason why its working with NoMachineProfile.

    Is there any way we can resolve this?

    Thursday, July 28, 2016 10:11 AM
  • Hi Gasah,

    >>Do you know the reason why its working with NoMachineProfile.

    -NoMachineProfile

    Prevents loading the user's Windows user profile. As a result, the session might be created faster, but user-specific registry settings, items such as environment variables, and certificates are not available in the session.

    >>Is there any way we can resolve this?

    As far as I know, NO.

    Best regards,


    Andy_Pan

    Thursday, July 28, 2016 10:20 AM
    Moderator