locked
Windows 7 Slow logon using cached credentials off domain RRS feed

  • Question

  • Windows 7 laptop with SSHD takes 2-4 minutes when loggin on using cached credentials when not on the domain. Local user logs on under 30 seconds. I've ran xperf and it appears that the GPClient and Profiles is taking the most time. I've played with the group policies and at some point got the login time down to 4 seconds. I tested multiple times and then all of a sudden it went back up to around 2 minutes. In the Group Policy event log its writing eventid's 7004, 7017, 7320. Any help would be great. I'd like to get down to at least 30 seconds.
    Saturday, February 1, 2014 1:00 AM

Answers

  • Hi,

    Sorry for the delay, my understanding is that when trying to login with domain credential offsite, your pc will first try to contact the DC through the internet, then after some time, it "found" that DC is unavailable, then it will turn to use cached credentials , that's why it take more time when not on the domain. On most computer systems, localhost resolves to the address 127.0.0.1, since you changed it to automatically detect localhost directly, then the time will be shorter now.

    Regards


    Yolanda
    TechNet Community Support

    • Marked as answer by Roger Lu Monday, February 17, 2014 1:16 AM
    Tuesday, February 11, 2014 9:36 AM

All replies

  • Windows 7 laptop with SSHD takes 2-4 minutes when loggin on using cached credentials when not on the domain. Local user logs on under 30 seconds. I've ran xperf and it appears that the GPClient and Profiles is taking the most time. I've played with the group policies and at some point got the login time down to 4 seconds. I tested multiple times and then all of a sudden it went back up to around 2 minutes. In the Group Policy event log its writing eventid's 7004, 7017, 7320. Any help would be great. I'd like to get down to at least 30 seconds.
    More info. When I change the DNS servers from automatically detect to 127.0.0.1, login only takes 30 seconds and verbose says that its "Please wait for user profile service". Any ideas?
    Sunday, February 2, 2014 9:36 PM
  • Hi,

    Sorry for the delay, my understanding is that when trying to login with domain credential offsite, your pc will first try to contact the DC through the internet, then after some time, it "found" that DC is unavailable, then it will turn to use cached credentials , that's why it take more time when not on the domain. On most computer systems, localhost resolves to the address 127.0.0.1, since you changed it to automatically detect localhost directly, then the time will be shorter now.

    Regards


    Yolanda
    TechNet Community Support

    • Marked as answer by Roger Lu Monday, February 17, 2014 1:16 AM
    Tuesday, February 11, 2014 9:36 AM
  • Hi,

    Sorry for the delay, my understanding is that when trying to login with domain credential offsite, your pc will first try to contact the DC through the internet, then after some time, it "found" that DC is unavailable, then it will turn to use cached credentials , that's why it take more time when not on the domain. On most computer systems, localhost resolves to the address 127.0.0.1, since you changed it to automatically detect localhost directly, then the time will be shorter now.

    Regards


    Yolanda
    TechNet Community Support


    Is there any way to "shorten" the time it looks for the DC? 2-4 minute logins using cached credentials is terrible.
    Monday, February 17, 2014 5:37 PM
  • Hi,

    Unplugging a network cable to bypass looking for a DC.

    Set this GPO to reduce the timeout to 0 and automatically log in before a connection to a DC is established

    "Computer Configuration\Administrative
    Templates\System\User Profiles\Set maximum wait time for the network if the
    user has a roaming user profile or remote home directory." 
    "Enable this and set the value to 0 to work around this timeout."

    And this tool in the following link can help you findout  exactly what is holding up the login process.

    http://blogs.technet.com/b/askpfeplat/archive/2012/06/09/slow-boot-slow-logon-sbsl-a-tool-called-xperf-and-links-you-need-to-read.aspx

    Regards


    Yolanda
    TechNet Community Support

    Tuesday, February 18, 2014 1:56 AM
  • Hi,

    Unplugging a network cable to bypass looking for a DC.

    Set this GPO to reduce the timeout to 0 and automatically log in before a connection to a DC is established

    "Computer Configuration\Administrative
    Templates\System\User Profiles\Set maximum wait time for the network if the
    user has a roaming user profile or remote home directory." 
    "Enable this and set the value to 0 to work around this timeout."

    And this tool in the following link can help you findout  exactly what is holding up the login process.

    http://blogs.technet.com/b/askpfeplat/archive/2012/06/09/slow-boot-slow-logon-sbsl-a-tool-called-xperf-and-links-you-need-to-read.aspx

    Regards


    Yolanda
    TechNet Community Support


    Below is a link for the 2 xperf files. One is on network and one is off network. http://1drv.ms/1cXd3pX
    Wednesday, February 19, 2014 1:15 AM
  • Hi,

    Unplugging a network cable to bypass looking for a DC.

    Set this GPO to reduce the timeout to 0 and automatically log in before a connection to a DC is established

    "Computer Configuration\Administrative
    Templates\System\User Profiles\Set maximum wait time for the network if the
    user has a roaming user profile or remote home directory." 
    "Enable this and set the value to 0 to work around this timeout."

    And this tool in the following link can help you findout  exactly what is holding up the login process.

    http://blogs.technet.com/b/askpfeplat/archive/2012/06/09/slow-boot-slow-logon-sbsl-a-tool-called-xperf-and-links-you-need-to-read.aspx

    Regards


    Yolanda
    TechNet Community Support


    I enabled the policy that you suggested and it still took 2 minutes to login into desktop. It took 30 seconds at the Welcome screen and 1.5 minutes at "Waiting for User Profile Service"
    Wednesday, February 19, 2014 1:29 PM