none
Photo Gallery won't open. GPO is stopping it, but can't find out which one it would be.

    Question

  • Photo Gallery won't open for staff members. Works fine for local administrators that aren't aren't getting group policy settings.

    Have tested giving a staff member admin rights, extra access to program files etc, but still doesn't work. But if I disable the staff GPO, it works fine. 

    I've set up a virtual network on my PC and exported the GPO object that is causing issues and imported it into the virtual server so I could get the same error so I can test a fix. Changed a lot of group policy settings to try and get it working, but still no hope.

    I just need to know what setting it would be to get it working. Movie Maker loads fine. Below is the error I'm getting.

    Photo Gallery can't encountered a error and can't start.

    Error Code: 0x800704ec

    Thanks,

    Mark.


    Wednesday, November 25, 2015 1:53 PM

Answers

  • For me, this was caused by enabling "User Configuration/Policies/Administrative Templates/Windows Components/File Explorer/Disable Known Folders" to block a few public folders.
    • Marked as answer by MTye Thursday, November 26, 2015 2:10 PM
    Thursday, November 26, 2015 8:59 AM
  • There's two that I had to remove to fix the problem. See below

    {491E922F-5643-4af4-A7EB-4E7A138D8174} - FOLDERID_VideosLibrary

    {A990AE9F-A03B-4e80-94BC-9912D7504104}  - FOLDERID_PicturesLibrary

    Info on the link below

    https://msdn.microsoft.com/en-us/library/windows/desktop/dd378457(v=vs.85).aspx




    • Marked as answer by MTye Friday, November 27, 2015 8:17 AM
    Friday, November 27, 2015 8:17 AM

All replies

  • For me, this was caused by enabling "User Configuration/Policies/Administrative Templates/Windows Components/File Explorer/Disable Known Folders" to block a few public folders.
    • Marked as answer by MTye Thursday, November 26, 2015 2:10 PM
    Thursday, November 26, 2015 8:59 AM
  • Thanks. Only just seen your reply, but I've just gone through all the settings one by one to find out which one it is, and just found out that it is this one.

    Is there anyway to change which folders are being blocked to allow Photo Gallery to work, instead of changing it to not configured?

    Thanks,

    Mark.

    Thursday, November 26, 2015 2:10 PM
  • There's two that I had to remove to fix the problem. See below

    {491E922F-5643-4af4-A7EB-4E7A138D8174} - FOLDERID_VideosLibrary

    {A990AE9F-A03B-4e80-94BC-9912D7504104}  - FOLDERID_PicturesLibrary

    Info on the link below

    https://msdn.microsoft.com/en-us/library/windows/desktop/dd378457(v=vs.85).aspx




    • Marked as answer by MTye Friday, November 27, 2015 8:17 AM
    Friday, November 27, 2015 8:17 AM