none
Changed IP address on DPM client, now DPM can no longer see it. RRS feed

  • Question

  • One of our servers had its IP address changed for reasons outside my control. After that, DPM couldn't see it anymore; it shows as Unavailable under Agent Management. 

    I ran "SetDpmServer.exe -dpmServerName DP1" on the client, and it was successful. 

    It still showed unavailable, so I tried attaching it on the DPM server, and got the following error:

    PS C:\Program Files\Microsoft DPM\DPM\bin> Attach-ProductionServer.ps1 dp1 srv5
    UserName:: pserver1
    Password:: *********
    Domain:: domainname
    There is failure while attaching production server
    C:\Program Files\Microsoft DPM\DPM\bin\Attach-ProductionServer.ps1 : The server
     srv5.domainname.local could not be found in Active Directory.
    At line:1 char:28
    + Attach-ProductionServer.ps1 <<<<  dp1 srv5
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorExcep
       tion
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
       n,Attach-ProductionServer.ps1

    I checked in AD, and the client computer is there, as it should be.

    Is there a simple procedure I am missing when a client changes its IP address? Thank you!

    Thursday, April 4, 2013 4:47 PM

All replies

  • Morning!

    Have you tried uninstalling the agent completely and re installing it?

    Is this server that was moved in a more secure VLAN that doesn't have ports open for DPM, quick way to test. Just see if you can ping the DPM server from the server you moved.

    Normally you do not have to run the SetDpmServer command for a server in the same domain, that is mostly for firewalled servers or workgroup servers.

    Monday, April 8, 2013 3:48 PM