locked
outlook cannot connect to exchange 2013 enterprise RRS feed

  • Question

  • Dears,

    I have an issue while I am in process of migration from exchange 2010 to exchange 2013 server, everything works fine during the coexistence except outlook cannot connect to exchange 2013, but still connect to exchange 2010 CAS server

    I have an exchange 2010 CAS array (excharray 172.20.0.95) and exchange 2013 Round Robin ( 172.20.0.26 and 172.20.0.27)

    the DNS configuration is as follow:

    excharray.mydomain.com     A      172.20.0.95   ( exchange2010)

    exch1.mydomain.com      A    172.20.0.26         (exchange 2013)

    exch2.mydomain.com    A      172.20.0.27         (exchange 2013)

    mail.mydomain.com      A      172.20.0.95, 172.20.0.26, 172.20.0.27

    autodiscover.mydomain.com    A     172.20.0.95, 172.20.0.26, 172.20.0.27

    can anyone help me to solve this issue?

    thank you


    Mohammad Naji senior exchange administartor

    Wednesday, December 2, 2015 5:15 AM

Answers

  • Hi,

    I understand outlook clients work fine . Now you have a issue about autodiscover service.

    In order to avoid confusion and keep track of troubleshooting steps, we usually troubleshoot one issue per thread in order to find a resolution efficiently. Concerning your other question, I suggest we an open a new case in the forum. Thank you for your understanding.

    Thanks,

    David

    • Marked as answer by mnaji Sunday, December 20, 2015 6:17 AM
    Wednesday, December 9, 2015 9:54 AM

All replies

  • Telling us the IP addresses doesn't help a bit.

    The names mail and autodiscover should point to Exchange 2013 only.

    Check the ExternalHostname and InternalHostname settings for Outlook Anywhere and the InternalUrl and ExternalUrl configuration of all virtual directories to ensure that they are pointed to the right place.

    http://blogs.technet.com/b/exchange/archive/2013/01/25/exchange-2013-client-access-server-role.aspx


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, December 2, 2015 6:52 AM
  • thanks for the response, and thank you for giving me the starting point in whick I have to look

    I ran this command from the power shell to know the Outlook AnyWhere configuration

    get-outlookanywhere | select server , externalhostname , internalhostname , internalclientauthenticationmethod | ft 

    and this is the output:

    exch1         mail.mydomain.com      mail.mydomain.com     ntlm

    exch2         mail.mydomain.com      mail.mydomain.com     ntlm

    both servers are having exchange 2013

    I checked the virtual directories, all virtual directories are configured correctly, but still I have the same issue

    hope that informations that I gave are useful for solving my issue


    Mohammad Naji senior exchange administartor

    Wednesday, December 2, 2015 7:35 AM
  • Make sure that all clients point to Exchange 2013 and not 2010 as I instructed you earlier.  If clients look to Exchange 2010 for Autodiscover or other web services when their mailbox is on 2013, it simply won't work.  Everyone should be pointed to Exchange 2013 CAS, and it'll proxy requests for mailboxes on Exchange 2010.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    • Proposed as answer by David Wang_ Thursday, December 3, 2015 2:22 AM
    Wednesday, December 2, 2015 7:40 AM
  • yes, and here is my issue, when clients try to configure their outlook, and type the exchange 2013 server name or IP (in server name), they will automatically redirecrted to exchange 2010 CAS Array

    I figured out that when running this command:

    get-mailboxdatabase | select name , rpcclientaccessserver , ft -auto

    the output is:

    DB1         EXCHARRAY.MYDOMAIN.COM

    DB2         EXCHARRAY.MYDOMAIN.COM

    DB3         EXCHARRAY.MYDOMAIN.COM

    DB1, DB2, DB3  are exchange 2013 databases, and EXCHARRAY.MYDOMAIN.COM is an exchange 2010 CAS Array


    Mohammad Naji senior exchange administartor

    Wednesday, December 2, 2015 8:12 AM
  • Hi,

    You cannot use the Exchange 2013 Management Shell to set the RpcClientAccessServer property on Exchange 2013 mailbox databases. Please confirm that these are in fact Exchange 2013 mailboxes mounted on your Exchange 2013 server by running this command:

    Get-MailboxDatabase | ft Name,RpcClientAccessServer,Server -AutoSize

    Also, for one of these problem clients, find out which database they are in and therefore whether they are on Exchange 2010 or 2013: 

    Get-Mailbox "James Lukes" | ft Name,Database -AutoSize

    You need to configure your client access URLs to direct clients to Exchange 2013 and only when you move mailboxes to Exchange 2013 databases will the Outlook client profile update to reference Exchange 2013. The server address in the Outlook profile should be a GUID followed by a domain name like this: b0331733-d0d1-48bc-b85d-bcaa06c93fb4@litwareinc.com.

    Thanks.


    Please mark as an answer if this answers your question

    Mark Gossa

    MCSE 2003, MCITP Enterprise Administrator 2008 R2, MCSA 2012 R2, MCTS Exchange 2010, MCTS SQL 2012, MCTS SharePoint 2007, VCP4, VCP5, CCNA

    Blog: http://markgossa.blogspot.com   LinkedIn:

    Posts are provided “AS IS” without warranty of any kind, either expressed or implied.


    • Edited by Mark Gossa Wednesday, December 2, 2015 1:33 PM corrected GUID
    Wednesday, December 2, 2015 1:32 PM
  • The RpcClientAccessServer property doesn't apply to Exchange 2013 databases since there are no RPC over TCP connections anymore, i.e., no CAS array.  So that's a red herring.

    Have you done what I've advised you earlier?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, December 2, 2015 4:39 PM
  • Hi,

    Please run the following command to check the autodiscover service setting:

    Get-ClientAccessServer | FL Identity,AutodiscoverServiceInternalUri

    As is above mentioned, make sure you have configured the URL to point to exchange 2013.

    More detailed information about Client Connectivity in an Exchange 2013 Coexistence Environment, please refer to the below link:

    http://blogs.technet.com/b/exchange/archive/2014/03/12/client-connectivity-in-an-exchange-2013-coexistence-environment.aspx

    Regards,

    David 


    Thursday, December 3, 2015 2:31 AM
  • hello everyone and thanks a lot for your responds

    now outlook client works fine for all clients after doing the following:

    ADSIEDIT.MSC-->Configuration-->cn=configuration-->cn=services-->cn=Microsoft exchange-->cn= [my domain]-->cn=administrative groups-->cn=exchange administrative group (GUID)-->cn=databases

    right click on each exchange 2013 database name--> properties

    modify the value of the attribute name " legacyexchangedn" to the new client access server

    after that everything works fine

    BUT, when I test the autodiscover from "test autoconfiguration" in outlook it says" autoconfiguration was unable to determine your settings" and the httpstatus=302

    and also when running

    get-mailboxdatabase | ft name , rpcclientaccessserver

    the rpcclientaccessserver field is empty


    Mohammad Naji senior exchange administartor

    Thursday, December 3, 2015 5:24 AM
  • Hi,

    I understand outlook clients work fine . Now you have a issue about autodiscover service.

    In order to avoid confusion and keep track of troubleshooting steps, we usually troubleshoot one issue per thread in order to find a resolution efficiently. Concerning your other question, I suggest we an open a new case in the forum. Thank you for your understanding.

    Thanks,

    David

    • Marked as answer by mnaji Sunday, December 20, 2015 6:17 AM
    Wednesday, December 9, 2015 9:54 AM