locked
Deployment Share Always ask to enter the Deployment Share Manually RRS feed

  • Question

  • Hi All 

    Recently, I have installed MDT 2013 Update 1 on a Windows 2012 R2 WDS Server. 

    I have edited my bootstap.ini file and boot sequence is working fine without any issues. the only problem that I have is, always it prompts me to enter the deployment share manually. Once I enter it manually it continues the rest of the tasks without an issue.

    I can confirm that \\<Server>\DeploymentShare$ has "Everyone" full control permissions. Also I have added the DeployRoot=\\<Servername>\DeploymentShare$ in to my bootstrap.ini file.

    Is there anyway to fix this issue? 



    Sunday, February 7, 2016 2:47 PM

All replies

  • Hi

    what exactly is in your bootstrap.ini??

    can you please provide the log files

    Kind regards
    Per Larsen
    Twitter: @PerLarsen1975 | Blog: osddeployment.wordpress.com
    If this post is helpful please vote it as Helpful or click Mark for answer.

    Sunday, February 7, 2016 4:17 PM
  • Here is the bootstrap

    I have changed the company name and the server names.

    -------------------------------------------------------------------------

    [Settings]
    Priority=Default
    Properties=MyCustomProperty

    [Default]
    _SMSTSOrgName=company name Ltd
    DeployRoot=\\server\DeploymentShare$
    OSInstall=YES
    SkipAdminPassword=YES
    SkipApplications=YES
    SkipAppsOnUpgrade=YES
    SkipBDDWelcome=YES
    SkipBitLocker=YES
    SkipCapture=YES
    SkipComputerName=NO
    OSDComputerName=RO-%SerialNumber%
    SkipComputerBackup=YES

    SkipDeploymentType=YES
    DeploymentType=NEWCOMPUTER

    SkipDomainMembership=YES
    JoinDomain=Domain
    DomainAdmin=MDTAdmin
    DomainAdminDomain=Domain
    DomainAdminPassword=***********
    MachineObjectOU=OU=XX Computers,OU=XX Regional Office,OU=Domain,DC=XXXX,DC=XX,DC=XX
    WsusServer=http://WSUSserver:8530 

    SkipFinalSummary=YES

    SkipLocaleSelection=YES
    KeyboardLocale=en-AU
    UserLocale=en-AU
    UILanguage=en-AU

    SkipPackageDisplay=YES

    SkipProductKey=YES

    SkipSummary=YES

    SkipTaskSequence=YES
    TaskSequenceID=XX_DEPL

    SkipTimeZone=YES
    TimeZoneName=XXXXX Standard Time 

    SkipUserData=Yes
    [Default]
    EventService=http://MDTserver:9800

    Sunday, February 7, 2016 4:39 PM
  • You have two [Default] sections, possibly its parsing the second one and missing the first one.

    A word of advice. While there's nothing technically wrong with having all this information set in bootstrap.ini,  its usually set in Customsettings.ini. You shouldn't have anything in bootstrap.ini except things you need to get the MDT process started and find a share.

    If you want to make changes to any of those settings, you will need to rebuild and redistribute your boot images in order to write a new bootstrap.ini. If you set it in Customsettings.ini, all you need do is edit the file and the changes are instant.

    • Proposed as answer by JoeZeppy Monday, February 8, 2016 1:34 AM
    Monday, February 8, 2016 1:34 AM
  • First of all, I would like to thank you for sharing your thoughts and advises..

    Just to confirm, according to your suggestions , if I add only the below partial script in bootstap.ini and rest of the settings in customsettings.ini, will this fix the issue?

    [Settings]
    Priority=Default
    Properties=MyCustomProperty

    [Default]
    _SMSTSOrgName=company name Ltd
    DeployRoot=\\server\DeploymentShare$

    Still I did not try it. If you can provide me some guidance I can test it in my environment. I need to fix this anyhow.

    Please share your thoughts and more details.

    Thanks. 

    Monday, February 8, 2016 3:00 AM
  • I can't guarantee it without testing, but it seems likely that having two sections named [Default] would cause problems.

    Best practice is that you should have as little as possible in your bootstrap.ini, only what is necessary.

    • Proposed as answer by JoeZeppy Tuesday, February 9, 2016 6:36 PM
    Monday, February 8, 2016 2:09 PM
  • Joe is right, keep the bootstrap file very basic. Such as:

    [Settings]
    Priority=Default
    
    [Default]
    DeployRoot=\\SERVER\DeploymentShare$
    UserID=DEPLOYMENTACCOUNT
    UserDomain=DOMAIN
    SkipBDDWelcome=YES

    You can add the password, or leave it out like above so that not just anyone can run MDT. The rest of the settings should be in CustomSettings.ini and only have one default section in it. You can always override a setting in your customsettings file by adding it to your task sequence.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Monday, February 8, 2016 2:33 PM
  • Hi All

    Sorry Guys, Made a mistake above output is My CustomSettings.ini and my BootStrap.ini settings as below. 

    [Settings]
    Priority=Default

    [Default]
    DeployRoot=\\SERVER\DeploymentShare$
    UserID=MDTAdmin
    UserDomain=XXXXXX

    UserPassword=XXXXXXX

    SkipBDDWelcome=YES

    Any Idea??

    Sunday, February 14, 2016 5:43 AM
  • Hi All 

    Finally I fixed the issue. 

    These are the steps that I have followed: 

    * Removed MDT Share and re-added 

    * Regenerate the Boot Image in MDT

    * Removed the Boot Image from WDS 

    * Re-added the Boot image 

    * Restarted the WDS server 

    Now everything is working fine and Thank You all for your Support. 

    • Proposed as answer by Dan_Vega Thursday, March 7, 2019 3:16 PM
    Sunday, February 14, 2016 6:21 AM
  • Hi,

    I had the same issues and just made replacing boot images in WDS.

    MDT generates boot images but doesn't upload them to WDS.

    So if you make changes in .ini files you have to replace images in WDS.

    Thursday, March 7, 2019 2:53 PM