locked
SBS 2008 Changed ISP Email Flow Stopped RRS feed

  • Question

  • We changed our isp a few weeks ago and our Exchange server stopped sending and receiving email.  We use to DNS to route our outbound email.  Inbound email is forwarded directly to our server via our dns hosting service.

    1.  We updated the PTR record on the new isp. 

    2. Changed DNS settings at our host to point to new static ip address and A records. 

    3.  Ran Fix my network.

    4. Updated all our internal router settings.  ISP assures me their modem has no firewall on and is in bridge mode.

    5 Ran Internet Connection Wizard.

    6 RWW works fine.  Internet works fine.

    7  Mail just sits in Queue and no incoming email is received.  Tried all of this several times and even waited 72 hours for DNS updates.  When we switch back to old ISP everything works fine.

    What am I missing?

    Wednesday, July 11, 2012 1:00 PM

Answers

  • Hi,

    Since the mail flow works properly after switching back to the old ISP, I think you need to verify the settings on your server.

    Ipconfig /all

    And you need to verify the internal mail flow by running the commands in the EMS:

    Test-Mailflow -TargetEmailAddress <Internal_Email_Address> -Verbose

    Anything unclear about the command above, you could run “Get-Help Test-Mailflow -Detailed”.

    Towards the Internal email test, you could use the Microsoft Remote Connectivity Analyzer to do the test.

    Regards,
    James


    James Xiong

    TechNet Community Support

    • Proposed as answer by James Xiong Friday, July 20, 2012 1:14 AM
    • Marked as answer by James Xiong Monday, July 23, 2012 5:26 AM
    Thursday, July 12, 2012 7:25 AM
  • We are switching again tonight and will try these ideas.  Thanks.

    Michael Milan Effective Technology

    • Marked as answer by mikemilan Tuesday, June 4, 2013 10:03 PM
    Friday, July 13, 2012 6:45 PM
  • If you have Internet connectivity from the server on the new ISP, but cannot send or receive mail then I suspect your firewall or the new ISP.

    I'd test the following:

    • Can you telnet out from your email server to another server. If not, this confirms a connectiivty problem which is likely the firewall or the ISP.
    • Can you telnet from an outside computer to your server on port 25. If not, this also confirms a connectivity problem which is likely the firewall or the ISP.
    • Does port forwarding to 443 work properly after the switch? If so, then I'd say your firewall work is fine and the ISP is your issue.

    Some firewalls are picky about ports being forwarded internally when the external IP changes. They seem to keep the external IP instead of generically allowing traffic in from the external port. The same can apply for outbound traffic.

    Some ISPs block port 25 for all but static IP addresses. Make sure that the new ISP is not accidentally blocking port 25 on your new IP. That would explain all of your issues. However, it might be hard to find someone at the ISP that will actually verify this. You can test this by telneting to port 25 on the ISP mail server. If that is allowed and you can't do the same to other mail servers, then I think filtering at the ISP is the culprit.

    For the MX records, during your testing process, I'd suggest that you have two MX records, one pointing at the new IP and another pointing at the old IP (technically hosts that resolve to corresponding IP addresses). That way you can flip back and forth without worrying about caching of DNS records interfering with the process. External mail servers will try both MX records. So, you can have either one alive for email with no issues.


    Byron Wright (http://byronwright.blogspot.com)

    • Proposed as answer by James Xiong Friday, July 20, 2012 1:14 AM
    • Marked as answer by James Xiong Monday, July 23, 2012 5:26 AM
    Friday, July 13, 2012 8:39 PM

All replies

  • try using https://www.testexchangeconnectivity.com/  to  test your exchange

    "mikemilan" wrote in message news:5eb143d1-30e7-4a67-b763-cbf40538fb6f@communitybridge.codeplex.com...

    We changed our isp a few weeks ago and our Exchange server stopped sending and receiving email.  We use to DNS to route our outbound email.  Inbound email is forwarded directly to our server via our dns hosting service.

    1.  We updated the PTR record on the new isp.

    2. Changed DNS settings at our host to point to new static ip address and A records.

    3.  Ran Fix my network.

    4. Updated all our internal router settings.  ISP assures me their modem has no firewall on and is in bridge mode.

    5 Ran Internet Connection Wizard.

    6 RWW works fine.  Internet works fine.

    7  Mail just sits in Queue and no incoming email is received.  Tried all of this several times and even waited 72 hours for DNS updates.  When we switch back to old ISP everything works fine.

    What am I missing?

    Wednesday, July 11, 2012 2:20 PM
  • No mention what so ever of updating your MX record!?

    Ben Weinberg
    Prime-Networks
    www.prime-networks.co.uk

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, July 11, 2012 2:50 PM
  • We did update the MX record.  Sorry meant to add that in.  Been using mxtoolbox.com to test when changes were made.  It showed correct ip address.  However, connection to server could not be established. 

    Michael Milan Effective Technology

    Wednesday, July 11, 2012 3:52 PM
  • are you able to telnet from a remote location to your servers public IP on port 25? Can i ask the public domain name? 


    Ben Weinberg
    Prime-Networks
    www.prime-networks.co.uk

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, July 11, 2012 4:12 PM
  • Are you willing to post your domain name? This will help us narrow down the issue very quickly. 


    Jeremy

    Wednesday, July 11, 2012 5:22 PM
  • We are switched back to our old isp at this time.  I can only switch at night when the users are out.  I would be more than happy to give you the domain name via email.  Just send me an email to msmilan@effective-technology.com (that is not the domain)  I have tried switching three times.  I am going to try again this evening.  Any info you can provide would be appreciated.

    Michael Milan Effective Technology

    Wednesday, July 11, 2012 7:33 PM
  • Hi,

    Since the mail flow works properly after switching back to the old ISP, I think you need to verify the settings on your server.

    Ipconfig /all

    And you need to verify the internal mail flow by running the commands in the EMS:

    Test-Mailflow -TargetEmailAddress <Internal_Email_Address> -Verbose

    Anything unclear about the command above, you could run “Get-Help Test-Mailflow -Detailed”.

    Towards the Internal email test, you could use the Microsoft Remote Connectivity Analyzer to do the test.

    Regards,
    James


    James Xiong

    TechNet Community Support

    • Proposed as answer by James Xiong Friday, July 20, 2012 1:14 AM
    • Marked as answer by James Xiong Monday, July 23, 2012 5:26 AM
    Thursday, July 12, 2012 7:25 AM
  • Email sent buddy!

    Ben Weinberg
    Prime-Networks
    www.prime-networks.co.uk

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, July 12, 2012 9:49 AM
  • We are switching again tonight and will try these ideas.  Thanks.

    Michael Milan Effective Technology

    • Marked as answer by mikemilan Tuesday, June 4, 2013 10:03 PM
    Friday, July 13, 2012 6:45 PM
  • If you have Internet connectivity from the server on the new ISP, but cannot send or receive mail then I suspect your firewall or the new ISP.

    I'd test the following:

    • Can you telnet out from your email server to another server. If not, this confirms a connectiivty problem which is likely the firewall or the ISP.
    • Can you telnet from an outside computer to your server on port 25. If not, this also confirms a connectivity problem which is likely the firewall or the ISP.
    • Does port forwarding to 443 work properly after the switch? If so, then I'd say your firewall work is fine and the ISP is your issue.

    Some firewalls are picky about ports being forwarded internally when the external IP changes. They seem to keep the external IP instead of generically allowing traffic in from the external port. The same can apply for outbound traffic.

    Some ISPs block port 25 for all but static IP addresses. Make sure that the new ISP is not accidentally blocking port 25 on your new IP. That would explain all of your issues. However, it might be hard to find someone at the ISP that will actually verify this. You can test this by telneting to port 25 on the ISP mail server. If that is allowed and you can't do the same to other mail servers, then I think filtering at the ISP is the culprit.

    For the MX records, during your testing process, I'd suggest that you have two MX records, one pointing at the new IP and another pointing at the old IP (technically hosts that resolve to corresponding IP addresses). That way you can flip back and forth without worrying about caching of DNS records interfering with the process. External mail servers will try both MX records. So, you can have either one alive for email with no issues.


    Byron Wright (http://byronwright.blogspot.com)

    • Proposed as answer by James Xiong Friday, July 20, 2012 1:14 AM
    • Marked as answer by James Xiong Monday, July 23, 2012 5:26 AM
    Friday, July 13, 2012 8:39 PM