locked
Attachments not showing in Outlook 2007 RRS feed

  • Question

  •  

    When a certain domain sends emails to us (meaning anyone in the company), DOC files do not apear in the attachement list.  PDF's show up fine.  When I open the message in OWA, the DOC attachments show.  If I forward the message to myself from Outlook 2007 the DOC files still do not show.  However, when I forward the message from OWA to myself, the DOC files show up in Outlook 2007.  When I forward from Outlook 2007 to myself, the doc files show up in OWA.  We use exchange server 2007, and the messages are not affected by the spam filter.  I have tried turning off/uninstalling symantec anti-virus and attachments are the same.

     

    I have found that the sender uses Exchange 2003 and outlook 2003.  I've searched a lot and have found similar problems but no solutions that will fix this problem.  Does anyone have ideas as to what the problem could be?  Below are the message headers.

     

    Message Header from the remote Domain sender (replaced domain names and ip address to fake)

     

    Received: from aDomain.remote.local (00.000.000.00) by server.arg.NET

     (192.168.5.xx) with Microsoft SMTP Server id 8.1.291.1; Mon, 3 Nov 2008

     10:24:38 -0600

    Content-Class: urn:content-classes:message

    MIME-Version: 1.0

    Content-Type: multipart/related; type="multipart/alternative";

                    boundary="----_=_NextPart_001_01C93DD0.F83D62A8"

    Subject: FW: OverSeas Exposure

    X-MimeOLE: Produced By Microsoft Exchange V6.5

    Date: Mon, 3 Nov 2008 10:26:48 -0600

    Message-ID: 74D6FAA6FDA21C46BD0D0C6F4FC963310184BC1C@aDomain.remote.local

    X-MS-Has-Attach: yes

    X-MS-TNEF-Correlator:

    Thread-Topic: Exposure

    Thread-Index: AckSsDbRok4ZEisqT7eg+1oe5hXkIgNRejZwBuQYD6AAkontEAAADgog

    From: a Person<aPerson@aDomain.com>

    To: <myself@apei.net>

    CC: <anotherUser@arg.net>

    Return-Path: aPerson@aDomain.com

    X-MS-Exchange-Organization-Antispam-Report: IPOnAllowList

    X-MS-Exchange-Organization-SCL: -1

     

    Message Header from OWA to myself

     

    Received: from server.arg.NET ([fe80::512c:7b8e:f0d:e355]) by
     server.arg.NET ([fe80::512c:7b8e:f0d:e355%12]) with mapi; Mon, 3 Nov
     2008 10:36:11 -0600
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: myselft <myselft@arg.NET>
    To: myself<myself@arg.NET>
    Date: Mon, 3 Nov 2008 10:36:01 -0600
    Subject: FW: Exposure
    Thread-Topic: Exposure
    Thread-Index: AckSsDbRok4ZEisqT7eg+1oe5hXkIgNRejZwBuQYD6AAkontEAAADgogAABYgRo=
    Message-ID: <FF1B3704737CF047B92904A9241C2047B982B87F@server.arg.NET>
    References: <74D6FAA6FDA21C46BD0D0C6F4FC963310184BC1C@aDomain.remote.local>
    In-Reply-To: <74D6FAA6FDA21C46BD0D0C6F4FC963310184BC1C@aDomain.remote.local>
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach: yes
    X-MS-Exchange-Organization-SCL: -1
    X-MS-TNEF-Correlator: <FF1B3704737CF047B92904A9241C2047B982B87F@server.arg.NET >
    MIME-Version: 1.0

     

    Message Header forwared from Outlook 2007 to myself

     

    Received: from server.arg.NET ([fe80::512c:7b8e:f0d:e355]) by
     server.arg.NET ([fe80::512c:7b8e:f0d:e355%12]) with mapi; Mon, 3 Nov
     2008 10:44:59 -0600
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: myself <myselft@arg.NET>
    To: myself <myselft@arg.NET>
    Date: Mon, 3 Nov 2008 10:44:58 -0600
    Subject: FW: Exposure
    Thread-Topic: Exposure
    Thread-Index: AckSsDbRok4ZEisqT7eg+1oe5hXkIgNRejZwBuQYD6AAkontEAAADgogAACnGQA=
    Message-ID: <FF1B3704737CF047B92904A9241C2047B97A309E@server.arg.NET >
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach: yes
    X-MS-Exchange-Organization-SCL: -1
    X-MS-TNEF-Correlator: <FF1B3704737CF047B92904A9241C2047B97A309E@server.arg.NET >
    MIME-Version: 1.0


     

    Monday, November 3, 2008 5:13 PM

Answers

  • Hi,

     

    I think the issue related to malformed MIME. The content type of the email is not correct; it is multipart/related, and should be multipart/mixed:

     

    RFC 2387 describes the intended use of multipart/related:

     

    "The Multipart/Related media type is intended for compound objects consisting of several inter-related body parts. For a Multipart/Related object, proper display cannot be achieved by individually displaying the constituent body parts."  

     

    Exchange handles multipart/related specially - i.e. it considers all attachment parts inside multipart/related as “inline”. Such attachments are normally hidden from the attachment list and supposed to be accessible from the body itself, like inline images. Some clients, like OWA, can determine whether attachments are really “inline” by analyzing a message body - if they don’t find any reference to such attachment in a body they fix it by displaying it in attachment list. Other clients like Outlook will trust how attachments are marked by Exchange and hide them.

     

    A “correct” way to structure message would look like this:

    Multipart/mixed

    Multipart/related

    Text/html - message body

    Any inline attachments referenced from the body

    Any normal attachments, like application/msword

     

    Suggestion:

    We can add a Transport Rule to simply "force" us to use multipart/mixed (Only when the mail is coming from the specific domain) and that will make the attachment visible in Outlook.

     

    1. Launch Exchange Management Console

    2. Expand Organization Configuration, and select Hub Transport

    3. On the right-hand Action Pane, select New Transport Rule …

    4. Give the rule a name (Attachment issue from kids.wustl.edu)

    5. Select when the From Address contains Specific Word click the highlighted

    Specific words”, Type "domain.com" click Add, click OK, and then click Next

    6. Select “set header with value,” click the highlighted “header” text, type

    7. Content-Type, click OK

    8. Click the highlighted “value” text, type multipart/mixed, click OK, and then click

    9. Next

    10. On the “Exceptions” page, simply click next

    11. At the final “Create Rule” page, click New, and then click Finish

     

    Please check whether the issue can be solved.

     

    Mike

     

     

    • Edited by Sophia Xu Friday, April 15, 2011 6:29 AM reference
    Wednesday, November 5, 2008 6:00 AM

All replies

  • Hi,

     

    I think the issue related to malformed MIME. The content type of the email is not correct; it is multipart/related, and should be multipart/mixed:

     

    RFC 2387 describes the intended use of multipart/related:

     

    "The Multipart/Related media type is intended for compound objects consisting of several inter-related body parts. For a Multipart/Related object, proper display cannot be achieved by individually displaying the constituent body parts."  

     

    Exchange handles multipart/related specially - i.e. it considers all attachment parts inside multipart/related as “inline”. Such attachments are normally hidden from the attachment list and supposed to be accessible from the body itself, like inline images. Some clients, like OWA, can determine whether attachments are really “inline” by analyzing a message body - if they don’t find any reference to such attachment in a body they fix it by displaying it in attachment list. Other clients like Outlook will trust how attachments are marked by Exchange and hide them.

     

    A “correct” way to structure message would look like this:

    Multipart/mixed

    Multipart/related

    Text/html - message body

    Any inline attachments referenced from the body

    Any normal attachments, like application/msword

     

    Suggestion:

    We can add a Transport Rule to simply "force" us to use multipart/mixed (Only when the mail is coming from the specific domain) and that will make the attachment visible in Outlook.

     

    1. Launch Exchange Management Console

    2. Expand Organization Configuration, and select Hub Transport

    3. On the right-hand Action Pane, select New Transport Rule …

    4. Give the rule a name (Attachment issue from kids.wustl.edu)

    5. Select when the From Address contains Specific Word click the highlighted

    Specific words”, Type "domain.com" click Add, click OK, and then click Next

    6. Select “set header with value,” click the highlighted “header” text, type

    7. Content-Type, click OK

    8. Click the highlighted “value” text, type multipart/mixed, click OK, and then click

    9. Next

    10. On the “Exceptions” page, simply click next

    11. At the final “Create Rule” page, click New, and then click Finish

     

    Please check whether the issue can be solved.

     

    Mike

     

     

    • Edited by Sophia Xu Friday, April 15, 2011 6:29 AM reference
    Wednesday, November 5, 2008 6:00 AM
  • I asked the remote domain to send me another message with attachments after I applied the rule.  Now I'm just waiting for them to send a message.  I'm also wondering, is the message header generated by the sending server or the recieving server?  What I mean by that is the problem because my exchange server is generating the Multipart/Related line?  When I forward the remote domain's message to my hotmail account, which I am also using Outlook with, the attachments show just fine and the Message header is completely different.

     

    Thanks,

    Jeremy

    Wednesday, November 5, 2008 5:33 PM
  • Hi Jeremy,

     

    The sending server generates the message header. Nevertheless, the header can be changed by other SMTP servers when the message goes through the servers.

     

    To check whether the message header is changed on your server, I suggest you can enable Pipeline Tracing to help you troubleshoot the issue:

     

    Pipeline tracing is a diagnostic feature in Microsoft Exchange Server 2007 that enables you to capture diagnostic information about e-mail messages as they encounter transport agents registered on Simple Mail Transfer Protocol (SMTP) events in the transport pipeline.

     

    For detailed information:

     

    http://technet.microsoft.com/en-us/library/bb125198.aspx

    http://technet.microsoft.com/en-us/library/bb125018.aspx

     

    Mike

     

     

    Thursday, November 6, 2008 9:41 AM
  • The transport rule solved the problem.  Now the attachments show.  Thanks a bunch!

    Monday, November 10, 2008 4:20 PM
  • Hi Lugies,

         Even i had the same issue and tried creating a HT rule to change Content-Type:Multipart/Related to Multipart/mixed. But this is not getting changed.
    Please describe the rule you have created.

    I have checked with 2 rules.

             1.  "When Message Header Contains words" and then "Set  Header with Value" as the action.
             2.  "When Message Header Contains text patterns" and then "Set  Header with Value" as the action.



    Thanks
    Suhas
    Monday, January 25, 2010 8:07 AM
  • Well, it helped out, but not for long ! Just a week ago the problem emerged again, but this time Content-Type is multipart/mixed, as it should be. So we are back from where we began: attaches are not visible in Outlook and visible in OWA.

    Any suggestions ?

    Tuesday, December 7, 2010 12:45 PM
  • Hi,

    I meet the same issue with a user. The attachments she receives from a specific sender (outside of the organization) are not appearing in the messages. The type of document is a doc file.

    By chance, I was playing with MfcMapi and found an article where it was stating that the propertie "PR_ATTACHMENT_HIDDEN" of this message could be set to "True". And that's it! I modified true to false and the attachment appeared.

    Now, I'd like to understand why this behavior only occurs with this specific sender and how to solve the issue, probably with mfcmapi.

    Tuesday, December 14, 2010 3:08 PM
  • Hi Tigger

    Have you been able to solve this issue because I have the same problem.

    Thanks

    Wednesday, April 13, 2011 7:34 PM
  • This worked perfectly for me. Thanks Mike! The only challenge now is to get all the outside domains that have been troublesome added to the policy.

     

    Kind Regards

    DN

    Monday, May 23, 2011 8:09 PM
  • Thanks Mike!!

     

    Your solution has worked for me.

    Found this after googling.

     

    We never used to have this problem but all of a sudden starting to get it with several different clients on different domains.

     

    Is there a more perminent fix i.e. allowing attachements for all "Content-Type" ??

     

    As although this has worked i can see me adding lots of addresses to this rule to allow the attachments through.

     

    You can also setup a transport rule for any email with "Content-Type Multitype/Alternative" rather than just changing the headers from certain senders if it's a odd Content-Type. Is that a good idea? this way it will allow and change all headers and allow attachements without having to add each sender each times this happens.

    Wednesday, June 1, 2011 11:43 AM
  • Hi Everyone,

    Im currently having this issue with a costumer. So far all i have tried is in vain. We are running Exchange 2007 with latest service pack 3 and Update Rollup 3 and a mixture of Office 2007 and Office 2003.

    So far i have tested:

    1. Installed Update Rollup 3 which is supposed to fix this issue

    2. applied Set-OrganizationConfig –ShowInlineAttachments $True in console

    I haven tried the transport rule suggested by mike on this post becasue this issue is not with one particular sender/domain, is with different senders from different domains that also includes google address. So creating a transport rule of all this various domains will be a nightmare, not considering that google is included which is odd.

    Im wondering if any has an alternate solution that it can also apply to already received emails.

    Thanks.

    Francisco

     


    Tuesday, July 12, 2011 2:17 AM
  • See MS KB - http://support.microsoft.com/kb/954684

    We have Rollup 3 but the last MS update was not clean so maybe we didn't get all of the adjustments from it, I did the manual command Francisco mentioned as well:

    set-OrganizationConfig -ShowInlineAttachments:$true

    Friday, July 15, 2011 7:57 PM
  • We have the same problem that the PDF attachment in the email from Mac users. Exchange 2007 SP3 RU4 should fix our problem

    http://support.microsoft.com/?kbid=2509911

    http://support.microsoft.com/kb/2543879

     

     


    Dean Chen
    Friday, July 15, 2011 8:57 PM
  • We installed Service Pack 3 and Update Rollup 3 on our Exchange 2007 servers last week and a few users started reporting this problem a few days ago.  The set-OrganizationConfig -ShowInlineAttachments:$true Powershell command seems to have resolved it for us as well.  Thanks for the tip.
    • Proposed as answer by Tom Services Wednesday, July 20, 2011 7:16 PM
    Monday, July 18, 2011 10:11 PM
  • We have the same issue with multiple domains. Running a mix of Outlook 2007/2010 and Exchange 2007 w/ SP3 Update Rollup 3. I ran the set-Organization...  command but this issue was not resolve. Any other suggestions?
    Friday, July 29, 2011 9:55 PM
  • We are having the same issues.   I read an article about disabling Silverlight in OWA using the console command:  Set-OwaVirtualDirectory -Identity “Servername\Owa (Default Web Site)” -SilverLightEnabled $False    

    We are in a mixed environment of Exchange 2010 and Exchange 2003 so my hunch is that once we migrated everyone to Exchange 2010, the problem will go away.   This smells like a an incompatibility between versions.

    Maybe someone from Microsoft can lend a hand?

    Tuesday, October 25, 2011 6:31 PM
  • We have the similar problem, we only have exchange 2010.

    Sometimes email with attachments are fine but sometimes missing attachments both in outlook 2007 and owa.

    At the moment it is only happening with the one employee and sender is also from our organization not sure what exactly is the issue.

    Wearied thing is sender sent the email first time it was infact a fwd email attachment didnt come through but he forwarded again same email all attachment came second time not sure what the problem is.

    Any help will be highly appreciated.

    Thursday, April 19, 2012 11:17 AM