none
Problem with group policy

    Question

  • Software Installation did not complete policy processing because a system restart is required for the settings to be applied. Group Policy will attempt to apply the settings the next time the computer is restarted.

    after restarted the client i still have the same issue

    Tuesday, December 13, 2016 1:12 PM

Answers

  • Solved.
    I had to add the Domain Computers to the Security Filtering  of the GPOs.
    • Marked as answer by fshamasneh Friday, December 23, 2016 11:42 AM
    Friday, December 23, 2016 11:42 AM

All replies

  • Hi,

    Does this issue happen to all clients in the list or just this client?

    Have you tried running gpupdate command?

    Based on my experience, you could try the following suggestions:

    1. If you logged in as a user that was not an administrator, please change an administrator account to have a test.

    2. In a GPO which applies to that specific computer, add the following setting:

    Computer Settings -> Administrative Templates -> System -> Logon -> Always wait for the network at computer startup and logon - > Enabled

    3. Try disabling UAC and see if application installs properly.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 14, 2016 2:59 AM
    Moderator
  • Thank you for your response
    all clients have this problem
    i put all the msi packages in a public folder that accessible by everyone in the domain and i tried to log to a computer using domain administrator account.
    also i enabled this Always wait for the network at computer startup and logon and disabled UAC
    but i still have the same problems.
    please note, that all GPO was running before.

    Wednesday, December 14, 2016 7:30 AM
  • Hi,

    So before this issue happened, did you do any modifications?

    In addition. we recommend specifying the following settings in the GPO (Group Policy) to ensure that the MSI distribution process is smooth and seamless:

    Computer Configuration > Policies > Administrative Templates > Windows Components> Window Installer > Always install with elevated privileges

    Computer Configuration > Policies > Administrative Templates > System > Group Policy > Software Installation policy processing (check "Allow processing across a slow network connection") 

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, December 16, 2016 2:37 AM
    Moderator
  • Hi Alvwan,

    We did not do any new modification on the DC.
    I enabled the mentioned above but i still have the same results. it keeps asking for restart when i call gpupdate /force.
    I deleted all the GPO and created a new simple one that contains an MSI for firefox but the same issue still exist !!

    Regards,
    Firas
    Sunday, December 18, 2016 7:21 AM
  • Hi Firas,

    Thanks for your update and all efforts on this case.

    Maybe try to temporary disable UAC for a test.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 20, 2016 1:16 AM
    Moderator
  • Solved.
    I had to add the Domain Computers to the Security Filtering  of the GPOs.
    • Marked as answer by fshamasneh Friday, December 23, 2016 11:42 AM
    Friday, December 23, 2016 11:42 AM