locked
Windows 7 network file performance issues RRS feed

  • Question

  • We are having a problem on several of the Windows 7 machines in our office. The 2008 servers copy files to each other at expected rates considering other traffic at the time - about 50Mbps. XP machines copy as quickly as ever too. I've even physically swapped XP and Win7 machines and the problem moves with the machines. Formatting a Win7 machine and installing XP has shown that the hardware is not the issue. The problem machines include my desktop which up to this week had excellent copy performance, but now is down to sub-170K speeds.

    Our network is all CAT 5e with gigabit cards in all the machines and gigabit switches. All Windows client computers are 32-bit. The affected machines will sometimes copy at "normal" speeds, but when they are having issues, they copy at 170K or less. One of our attorneys tried to open a 10 meg spreadsheet yesterday and after taking lunch it was still not open. This is on a quad-core Intel machine, SATA, Intel gigabit LAN, etc.

    I've tried "all" the fixes I could find that are posted here (and there are a LOT of threads on this subject), but no solution yet.

    I really don't want to have to go back and wipe all the Windows 7 machines and reinstall XP but this is crippling our business and I need a solution. If you work with attorneys, you know where I'm at.

    Wednesday, January 26, 2011 12:53 AM

Answers

  • Hi,

    Please read this:

    Best practices for NTFS compression in Windows

    You can try robocopy which is builded-in windows 7:

    Get to Know Robocopy for More Powerful File Management

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    This is a PURELY Windows 7 NETWORKING issue. We do not have any compressed drives here. Having 50+ attorneys and paralegals trying to use robocopy to move data from file servers to local machines just so they can open the files is absolutely unacceptable.

    The most useful thing I've found so far was this:

    http://social.technet.microsoft.com/Forums/en/w7itproperf/thread/4537c7b6-9761-41c5-8b47-0ecb831c8575

    post from Noel Carboni at Thursday, April 22, 2010 9:24 PM
    and also from him at Sunday, May 30, 2010 3:31 PM

    Which I'll add here just to have the info in this thread if someone finds it:

    I ran across a setting in a Windows server tuning document that sounds suspiciously like it could be involved with this problem...

    Found in this document:  http://www.microsoft.com/whdc/system/sysperf/Perf_tun_srv.mspx

    General Tuning Parameters for Client Computers

    ·         DisableBandwidthThrottling

            

    HKLM\system\CurrentControlSet\Services\lanmanworkstation\parameters
    \(REG_DWORD)

     

    The default is 0. This setting is available starting with Windows Server 2008 SP2. By default, the SMB redirector throttles throughput across high-latency network connections in some cases to avoid network-related timeouts. Setting this registry value to 1 disables this throttling, enabling higher file transfer throughput over high-latency network connections.

     -Noel

    In the registry.  HKLM == HKEY_LOCAL_MACHINE

    Full key path:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters

    DWORD value name:  DisableBandwidthThrottling

    Windows 7 does not define the DisableBandwidthThrottling value by default, but that doesn't mean it isn't checked by the software.  I simply don't know if this is the case.

    You could try adding the value and setting it to 1.

    -Noel

    Using those to tweaks got me from 32K transfers speeds up to 6-7Mbps. I finally gave up trying to "fix" the problem, did a fresh install and am now up to 70+ Mbps transfer speeds. Hardly a practical solution, but I'll have to try Noel's fix first on the other three machines. If that fails it's wipe and install time for all of them. The bad part is, 2 of those were just recently installed.

    • Marked as answer by Marc Medina Monday, January 31, 2011 10:54 PM
    Monday, January 31, 2011 10:53 PM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    When you say copy do you mean copy locally or cross operating system? If network file transfer between different OS, what are they? XP to Windows 7, Windows 7 to Server 2008 or Windows 7 to Windows 7?

     

    When did this issue begin to occur? Could you please list the methods you have tried?

     

    Please remove the DNE64x.sys from loading up and check the result.

     

    Also check if you have read this thread.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, January 26, 2011 8:53 AM
  • Hi Magon,

    That thread offers nothing new. I thought I was clear on my description, but I'll do it again:

    Servers are 2008 (not R2) and some are x86, some are x64.

    Workstations are all 32-bit XP or Windows 7

    This is an intermittent problem (just started on my own machine this week, but no changes were made to it), and is only affecting 3 computers that I know of right now.

    The biggest problem is that one of the attorneys computers has this problem. He cannot open a 10 meg XLS file on the server, and also cannot save files to the server. When he tries to open files from the network shares, Word and Excel show a "downloading the file..." message in the lower right. Sometimes the file will open after several minutes, but on a gigabit network there is no reason for users to be delayed like this.

    There are no viruses, etc.

    Installing XP on the same pyhsical system cures the problem, so it's not hardware or network related - it's specific to a problem within Windows 7.

    Friday, January 28, 2011 5:08 PM
  • Please remove the DNE64x.sys from loading up and check the result.


    Since these are 32-bit Windows 7 machines, this file does not exist.
    Friday, January 28, 2011 5:17 PM
  • Hi,

    Please read this:

    Best practices for NTFS compression in Windows

    You can try robocopy which is builded-in windows 7:

    Get to Know Robocopy for More Powerful File Management

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, January 31, 2011 6:32 AM
  • Hi,

    Please read this:

    Best practices for NTFS compression in Windows

    You can try robocopy which is builded-in windows 7:

    Get to Know Robocopy for More Powerful File Management

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    This is a PURELY Windows 7 NETWORKING issue. We do not have any compressed drives here. Having 50+ attorneys and paralegals trying to use robocopy to move data from file servers to local machines just so they can open the files is absolutely unacceptable.

    The most useful thing I've found so far was this:

    http://social.technet.microsoft.com/Forums/en/w7itproperf/thread/4537c7b6-9761-41c5-8b47-0ecb831c8575

    post from Noel Carboni at Thursday, April 22, 2010 9:24 PM
    and also from him at Sunday, May 30, 2010 3:31 PM

    Which I'll add here just to have the info in this thread if someone finds it:

    I ran across a setting in a Windows server tuning document that sounds suspiciously like it could be involved with this problem...

    Found in this document:  http://www.microsoft.com/whdc/system/sysperf/Perf_tun_srv.mspx

    General Tuning Parameters for Client Computers

    ·         DisableBandwidthThrottling

            

    HKLM\system\CurrentControlSet\Services\lanmanworkstation\parameters
    \(REG_DWORD)

     

    The default is 0. This setting is available starting with Windows Server 2008 SP2. By default, the SMB redirector throttles throughput across high-latency network connections in some cases to avoid network-related timeouts. Setting this registry value to 1 disables this throttling, enabling higher file transfer throughput over high-latency network connections.

     -Noel

    In the registry.  HKLM == HKEY_LOCAL_MACHINE

    Full key path:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters

    DWORD value name:  DisableBandwidthThrottling

    Windows 7 does not define the DisableBandwidthThrottling value by default, but that doesn't mean it isn't checked by the software.  I simply don't know if this is the case.

    You could try adding the value and setting it to 1.

    -Noel

    Using those to tweaks got me from 32K transfers speeds up to 6-7Mbps. I finally gave up trying to "fix" the problem, did a fresh install and am now up to 70+ Mbps transfer speeds. Hardly a practical solution, but I'll have to try Noel's fix first on the other three machines. If that fails it's wipe and install time for all of them. The bad part is, 2 of those were just recently installed.

    • Marked as answer by Marc Medina Monday, January 31, 2011 10:54 PM
    Monday, January 31, 2011 10:53 PM
  • An update for anyone elese who is having this issue:

    After spending over 100 hours working on this, the problem came down to default settings for updated NIC drivers sourced from Windows Update. tweaking settings one at a time and re-booting the machine each time eventually fixed the problem, but the settings that worked well for one machine did not always work for the next.

    Thursday, May 5, 2011 3:13 PM