none
Recording off Stereo Mix not working RRS feed

  • Question

  • Hi guys, this is probably a dumb question, but:

    I'm trying to record system audio in a couple of different applications, and it's not working. Specifically, I'm trying to record audio off the web in Audacity, and system audio to accompany screenshot video in Debut Video Capture.

    Based on google-fu, I went into the Sounds Control Panel and enabled Stereo Mix, but even when I select it as the record input in the applications, I get total silence on the recording, even though the expected sound is coming out of my speakers.

    I'm using Windows 7 Home.

    Again: The problem is NOT simply that Stereo Mix is disabled. That seems to be a common problem, and enabling it suffices for most people. But as I said, I've already done this, but when I select Stereo Mix as the input, it simply doesn't work.

    Any help would be much appreciated. It's probably something simple I'm missing, but I've tried everything I can think of or find info about online. Thanks!

    Monday, October 28, 2013 11:36 PM

Answers

All replies

  • Hi,

    1.Have you set Stereo Mix as default device and default communication device? Just as a mention, enable is not the same as default (green check mark).

    2.Also, try disabling Microphone while enabling Stereo Mix.

    3.If the methods above not work, reinstall the sound driver for test.

    Start>Control Panel>Hardware and Sounds> Click "Device Manager".

    Find the driver/device that you wish to reinstall, which would be your sound driver, "right-click" and select "uninstall".

    Then reboot, if this was a Windows provided driver, then your PC should reinstall it the next time you log back in. If it requires the driver from the manufacturer you will be prompted to provide it.

    Meanwhile, I still want to mention the steps to enable Stereo Mix.

    How To Enable “Stereo Mix” in Windows 7 (to Record Audio)

    http://www.howtogeek.com/howto/39532/how-to-enable-stereo-mix-in-windows-7-to-record-audio/

    Please note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Hope this helps,

    Ada Liu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Wednesday, October 30, 2013 12:12 PM
  • Also make sure to use the right playback device. I have AMD HDMI audio as default playback device, but Realtek as Stereo mix. I had to plug something into the onboard audio output to be able to set this playback device (Speakers, by Realtek HD Audio) as default device. Only then the recording device Stereo Mix will be able to connect to the audio channel you are hearing :-)

    • Proposed as answer by Moneigh Monday, November 10, 2014 6:18 AM
    Wednesday, April 9, 2014 10:36 PM
  • Please provide more information. Just 'I did something' does not help anyone.
    Tuesday, June 17, 2014 2:16 PM
  • Hey Folks,

    I'm running on an HP Pavilion Desktop running Windows 7 Home Premium (all maintenance applied) and have uploaded/installed the latest Realtek drivers and I am having the same exact problem.

    I have been researching and working on this for over eight hours and I've exhausted all of the suggestions, fixes on the net and I'm hoping someone can give me some help, here.

    Thanks for your time!

    Thursday, June 26, 2014 1:23 AM
  • I'm not sure why nobody has even mentioned your response there MrKnowsItAll, because it's the correct one.

    1. Stereo Mix (Realtek High Definition Audio) must be enabled and set as the default recording device.

     If you can't see Stereo Mix in your list of options, it's possible that "Show Disabled Devices" or "Show Disconnected Devices" is unchecked. To check this, right click somewhere in the list of options that you do have and select them.

    2. The playback device must be analog, not digital. Basically, if you want to record the Stereo Mix, switch your default playback device to "Speakers (Realtek High Definition Audio)" or plug in any standard headphones/speakers that use a 3.5mm jack. You can leave your digital playback device connected and switch that to your default playback device whenever you're not recording, just be sure to switch back to analog when you want to record from Stereo Mix.

    Stereo Mix will NOT record if your sound playback device is connected via an HDMI cable (High Definition Multimedia Interface), SPDIF cable (Sony/Philips Digital Interface Format), or USB cable (Universal Serial Bus).

    For example, in my case I cannot be playing sound through my TV or my headphones when I want to record because my TV is connected via HDMI and the signal transmitter for my headphones is connected via S/PDIF.

    What WILL work to record are speakers that plug in using a 3.5mm auxiliary jack (typically a green jack at the back of your desktop's tower, or a headphone jack at the front).

    This applies to users with a Realtek HD sound driver running Windows 8.1.





    • Edited by Moneigh Monday, November 10, 2014 6:59 AM Grammatical error
    • Proposed as answer by DTGrayston Saturday, January 9, 2016 6:54 PM
    Monday, November 10, 2014 6:45 AM
  • I've been struggling with this and Moneigh's anwser is excellent since its not well documented that if you are using the HDMI or anyother digital out for audio Audacity won't record using Stereo Mix. And if using HDMI it won't record no matter what you try to do.

    But I've found you can record when using a digital out like optical or spdif. Audacity (win7 and later versions) should have an audio source selection for "Windows WASAP" which can make a direct digital recording (normally you are going from digital -> analog -> digital with other methods). Meaning you'll get a better recording normally.

    For me in Audacity I select:

    Audio Host:Windows WASAP
    Recording source: Realtek Digital (optical)
    Playback source: Realtek Digital (optical)

    (note the recording/playback should be the same).


    • Edited by DTGrayston Saturday, January 9, 2016 7:15 PM format
    Saturday, January 9, 2016 7:14 PM
  • One can not record(or listen) via stereo mix(which is Analog) while default playback is Digital. However there is a trick,

    1. Select Default playback device to Digital Output.

    2. Select default recording device to Stereo Mix.

    3. Play anything over digital output. Whenever you want to record just plug in a blank (unwired) 3.5mm jack into front panel headphone out and PC will allow you to record via stereo mix. (Digital audio will stop outputting)

    Additionally to switch between two devices without going to playback device and change setting all the time

    (say between a USB Headphone and a SPDIF device.)

    Just select 'Listen to this device' under stereo mix setting and select the USB headphone as client. Once this is done, whenever you will plug in the 3.5mm jack the audio will automatically switch to USB headphones and turn off Digital out.

    Monday, January 8, 2018 4:09 PM