none
Error when resubmitting an Infopath form in Sharepoint with a multiple email address field

    Question

  • I am a new SharePoint user and I have only touched on the basic Workflow and Form functionality. I have created a workflow that updates users with a change of status to a list item.

    So user creates list item with form as "assigned" and all parties get notified. User updates status to "work started" and all users get notified, etc. The workflow works perfectly.

    However, I have one field that holds multiple email addresses for local POC's. When completing the initial form (InfoPath 2013, SharePoint 2013) and setting the status (any status), the process works properly and the people in the field are emailed. However, when I click on the list item to edit in the InfoPath form to change the status, the multiple email field causes an error and will not let me submit the amended form - even if I make no changes.

    At this stage I get an error that multiple email addresses are not allowed in the field. This never happens on the initial entry, only when I open the form again to change something which is critical to the status workflow.

    I am at a loss... the field does allow for multiple email addresses and works fine in the workflow until I open the form a second time to modify.

    Any help (please remember I am a basic user) is appreciated.

    Thanks!


    • Edited by u4carson Thursday, April 20, 2017 4:07 PM
    Thursday, April 20, 2017 3:48 PM

All replies

  • Hi u4carson,

    Could you please provide the error message that appears on the page?

    It would be better if you can provide the screenshots about your form and issue. If you cannot post the images in the thread, you can share them with OneDrive or other ways.

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, April 21, 2017 8:46 AM
    Moderator
  • Hi u4carson- what type of field is it, a people picker? Make sure the settings are the same in SharePoint and InfoPath. Check the control in InfoPath to make sure it also allows multiple addresses. Any validation set on the field or other rules?

    cameron rautmann

    Friday, April 21, 2017 2:23 PM
  • Hi u4carson,

    Is there any update?

    Have you resolved this InfoPath form issue?

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, April 25, 2017 8:52 AM
    Moderator