locked
French keyboard layout randomly appers by itself RRS feed

  • Question

  • I have Windows 7 Ultimate x64. I have two keyboard layouts installed - English and Russian. I use Ctrl-Shift to switch between input languages.
    Randomly (usually two or three times per week) French(French) "AZERTY keyboard would get installed by itself. So now my languages would cycle English-French-Russian. If I click on the language bar I can see the French keyboard there. If I go to control panel "Keyboard languages and other input methods" - French keyboard is not mentioned there. If I manually install and then uninstall it via control panel then the "rogue" French keyboard layout goes away from the language bar. Rebooting the computer also does the trick.
    It very much looks like a bug to me and it is extremely annoying.

    Thursday, December 10, 2009 8:53 PM

Answers

  • Hi Ghostrider-13,

     

    Could you please help to confirm the following factors regarding this issue?

     

    -           Is your Windows 7 Ultimate x64 a French version?

    -           Is there any software requires French installed?

    -           Is there any third party language input software installed?

     

    If there is any software mentioned above are installed, please uninstall it to see if the issue can be resolved. Also, let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Hope this helps.

     

    Regards,

    Linda

     

     

     

     

    • Marked as answer by Arthur Xie Thursday, December 17, 2009 7:56 AM
    Tuesday, December 15, 2009 10:13 AM

All replies

  • Hi,

    When did this issue first occur, is there any newly installed software in Frence or have you visit french website? When this issue occurs, switch to another user account to check the result. 1. Click "Start", and then click "Control Panel". 2. Click switch to user "accounts and family safety". 3. Double-click "User Accounts". 4. Click "Create a new account", click "Next" and type the name. 5. Choose account type as "Computer administrator". 6. Click "Create Account". 7. Log off and log on with the new account.
    Friday, December 11, 2009 6:54 AM
  • Hi Ghostrider-13,

     

    Could you please help to confirm the following factors regarding this issue?

     

    -           Is your Windows 7 Ultimate x64 a French version?

    -           Is there any software requires French installed?

    -           Is there any third party language input software installed?

     

    If there is any software mentioned above are installed, please uninstall it to see if the issue can be resolved. Also, let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Hope this helps.

     

    Regards,

    Linda

     

     

     

     

    • Marked as answer by Arthur Xie Thursday, December 17, 2009 7:56 AM
    Tuesday, December 15, 2009 10:13 AM
  • Ièm also running Windoz 7 64 bit and for sure NO other languages and this French keyboard thing is driving me freaking nuts.

     

    Ièm so loving the rest of Windoz 7 but this really pizzes me off.  It isnèt just Ghostrider-13ès problem. Oh ya you can see itès happening right now canèt youÉ  SOB

     

    Alison

    Thursday, April 1, 2010 3:46 PM
  • This problem happens in Vista all the time...I wrote an article here as a simple fix a little while ago and wonder if it applies to Windows 7...

    The premise is that you are probably hitting your shift and ctrl keys at the same time by accident when typing quickly.

    Bonne Chance / Good luck...

    Cheers,

    Kyle

    Sunday, May 30, 2010 11:42 PM
  • I am experiencing exactly the same problem - and no (referring to advice below) - it is not a french version, I don't visit french web-sites, and no software I use is in french (that was for guys below)

    Now to you - seeing as it was 4 years ago, and seeing as you did not find the solution here, seemingly - did you find it anywhere else, and if yes, what IS the solution?

    Thanks in advance

    Monday, September 30, 2013 12:18 AM