none
TF400958 Error: Cannot Register PWA Instance , even though the Project Server Service account has permission already RRS feed

  • Question

  • Good day. 

    I have a problem registering a PWA Instance. Its says that the project Server service account doesn't have permissions to call the Project Server Web Service.  

    I followed the instructions by this link: https://msdn.microsoft.com/en-us/library/gg412653.aspx

    In my scenario, i have Sharepoint 2013 Site running ( http://sharepointsrvr) and i have project Web App instance under it as a subsite : http://sharepointsrvr/ProjectPortal

    The Project Server uses a service account called ProjectServerAppPool.

    And this ProjectServerAppPool is an Administrator in the PWA Site

    Also, that account is also set as one of the Site Collection Administrators, as suggested by the article. 

    In the Team Foundation Administration Console, you can see that the service account is set. 


    And that service account is a member of the TFS Administration Group. 

    However, upon Registering the PWA, i still get this error. 

    I am stuck in this problem. I have done all the permission settings as suggested. Can anyone help me on this? i don't know what im missing. 

    Hoping for your reply and help.

    Thank you,

    Rommel Sudan

    Wednesday, September 30, 2015 12:19 PM

All replies

  • You need to investigate what account is the Project Server service account e.g. what account runs the Project Server services.

    Open the native Windows Services Services and find the 3 Project Server services and lookup the account.

    It might not be ProjectServerAppPool - in fact i hope not. This account should only be used for running the app pool.

    Best Regards | Power2Plan | https://www.power2plan.com

    Wednesday, September 30, 2015 2:22 PM
  • Hello John, 

    I have Set the ProjectServerAppPool as the logon for the Project Server Events Service 2013. Still i get the permission Error.  It's my first time to configure TFS and Project Server Integration. 

    Is there anything else that i need to do? I still can't find the culprit of this issue. 

    Thanks a lot for your reply. 

    Wednesday, September 30, 2015 3:17 PM
  • Hi,

    Looking at the error message, I would say there are some permissions missing. One of the things to check is if the Project Service Service account (the service account used for the Project Server Queue service) has admin permissions to the Project Server Service Application (Centram Admin > Manage Service Application > select Project Server Service App > click Administrators in the ribbon

    Hope this helps

    Paul

    Wednesday, September 30, 2015 3:21 PM
  • Hi Paul, 

    I have set the Application Pool as the administrator of the Project Server, as you can see in the screenshot. I still get the error, its getting frustrating. :(

    Anything else that i need to look into?

    Thanks so much for your reply. 

    Wednesday, September 30, 2015 4:02 PM
  • Hi,

    Another thing to check is if the ProjectServerAppPool and the TFS service accounts have permissions to the ProjectWebApp database

    Paul

    Wednesday, September 30, 2015 7:12 PM