locked
Contextual spelling breaks spell check RRS feed

  • Question

  • I've recently upgrade a 9 computers from Office 2003 to Office 2010. On 2 of the computers the spell check wouldn't find any misspelled words. After I poked around in the options a bit, I discovered that if I turned "Use Contextual Spelling" off, then the spell check started to work again.

    I would like for these 2 computers to be able to use the contextual spelling corrections eventually and hope I could get some advice on how to solve this problem.

    One computer is running 64-bit Vista Pro, and the other computer is running 32-bit XP Pro.

    Monday, June 21, 2010 8:18 PM

Answers

  • I tried to repair Microsoft Office 2010 and that didn't solve the problem. Fortunately, I have found a solution.

    I noticed that the custom dictionary was set for English (Canada), so I went to the Language tab in Options. The editing language was English (U.S.), so I added English (Canada) as an additional editing language.

    The Keyboard Layout was Not Enabled , but I set English (Canada) as the default anyways. I restarted Word 2010 and turned contextual spell checking back on. Low and behold, the Spell Checker and Contextual Spelling Checker work.

    I'm not sure why English (U.S) language setting wouldn't spell check with contextual spelling on. The proofing was listed as Installed in the Language tab.

    • Marked as answer by Dekethedog Thursday, June 24, 2010 8:03 PM
    Thursday, June 24, 2010 8:02 PM
  • I had this problem- uncececked the outlook social connection and spell check worked again.
    • Marked as answer by Sally Tang Thursday, July 1, 2010 3:31 AM
    Wednesday, June 30, 2010 8:54 PM

All replies

  • Hi,

     

    I have checked on my side but could not re-produce this issue. Based on the current situation, this issue may be caused by some corrupted Office settings or third-party conflicts. I would like to confirm if this issue occurs in all the Office components, or only occur in Word, Outlook, etc..?

     

    First, let’s try to check the issue by starting the Office program in safe mode.

     

    Step 1: Start the Office program in safe mode

    ==============

    1.       Click Start, point to All Programs, and then point to Microsoft Office.

    2.        Press and hold the CTRL key, and then click the Office program you want to start.

     

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Office program, we can try to disable them. Normally, you could do the following to disable the conflict add-ins in your Office program:

     

    Disable add-ins

    ***************************

    1. Click File menu, click Options >  Add-in, click Go button in the Manage: Com-in Add.
    1. Check if there are any add-ins, clear the checkbox to disable them.
    2. Close the Office program and restart it.
    3. Add one check back each time to the list of Add-In, restart the Office program, and repeat the above procedure. Once the issue reappears again, we can determine which add-in causes this problem and then disable it.

     

    If the problem persists, at this this, let’s check the issue in Word 2010 by starting the program using default settings:

     

    Step 2: Start Word 2010 using default settings

    =====================

    You can use the /a switch to start Word 2010 by using only the default settings in Word 2010. When you use the /a switch, Word does not load any add-ins. Additionally, Word 2010 does not use your existing Normal.dotm template. Restart Word 2010 by using the /a switch.

    In Windows Vista and Windows 7

    1. Exit Word 2010
    1. Click Start
    2. In the Start Search box, type the following text, and then press ENTER:
      "%programfiles%\microsoft office\office14\winword.exe" /a

     

    In Windows XP

    1. Exit Word 2010
    1. Click Start, and then click Run.
    1. In the Open box, type the following text, and then press ENTER:
      "%programfiles%\microsoft office\office14\winword.exe" /a

     

    Does the problem occur now? If this issue does not occur when starting Word using /a switch, we can try to rename the Word Global Template:

    ================

    1.       Exit all Office programs.

    2.       Click Start, click Run, type cmd, and then click OK.

    Note: If you are using Windows Vista or Windows 7, click Start, in the Search box, type command prompt. right click on command prompt and choose run as administrator.

    3.       Type the following command, as appropriate for the version of Word that you are running, and then press ENTER:

    ren %userprofile%\Application Data\Microsoft\Templates\Normal.dotm OldNormal.dotm

    4.       Type exit, and then press ENTER.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

    Tuesday, June 22, 2010 3:06 AM
  • Thanks for replying to me.

    The spell check does not work in Word, Outlook, or Powerpoint while "Use contextual spelling" is on. I also want to note that even though the spell check doesn't work, the grammar check still works.

    I tried both of the steps you listed, and neither one solved the problem.

    Tuesday, June 22, 2010 9:28 PM
  • Hi,

     

    Thank you for  your reply. I am sorry to hear that the problem persists.

     

    Based on the current situation, I suggest trying to repair the Office program from Add/Remove Programs, locate Microsoft Office, right click it and choose Change, then Repair.

     

    Then, reboot the computer and check the result again.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    Thursday, June 24, 2010 2:46 AM
  • I tried to repair Microsoft Office 2010 and that didn't solve the problem. Fortunately, I have found a solution.

    I noticed that the custom dictionary was set for English (Canada), so I went to the Language tab in Options. The editing language was English (U.S.), so I added English (Canada) as an additional editing language.

    The Keyboard Layout was Not Enabled , but I set English (Canada) as the default anyways. I restarted Word 2010 and turned contextual spell checking back on. Low and behold, the Spell Checker and Contextual Spelling Checker work.

    I'm not sure why English (U.S) language setting wouldn't spell check with contextual spelling on. The proofing was listed as Installed in the Language tab.

    • Marked as answer by Dekethedog Thursday, June 24, 2010 8:03 PM
    Thursday, June 24, 2010 8:02 PM
  • Hi,

     

    I am glad to hear that the problem is resolved, and I appreciate all of your time and effort on this issue.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    Friday, June 25, 2010 2:57 AM
  • I had this problem- uncececked the outlook social connection and spell check worked again.
    • Marked as answer by Sally Tang Thursday, July 1, 2010 3:31 AM
    Wednesday, June 30, 2010 8:54 PM