none
Error Message While Saving Resource Plan RRS feed

  • Question

  • We have been getting this error often when you try to save a resource plan(PS2010) and it throws out message saying

    "The Resource Plan is no longer checked out to you and your changes will not be saved. contact the project server administrator"

    Also this behavior is intermittent, once in a while we get this message, hence difficult to reproduce it at will

    While doing a research, i found this another thread talking about the same perhaps it was in 2007 but doesn't has a resolution

    http://www.microsoft-questions.com/microsoft/Project-Server/31608762/resource-plan-checkin-problem.aspx

    http://www.office-forums.com/threads/resource-plan-check-in-problem.1593563/  

    Any experiences ?


    Tuesday, June 10, 2014 1:25 PM

All replies

  • Hi,

    The issue might be happening due to the missing information of Resource plan in draft database. Please run the below 2 queries to compare the both draft and publish database.

    1] Run the below queries on the project draft database

    select * from MSP_RESOURCE_PLAN_ASSIGNMENTS where ASSN_UID not in (select assn_uid from  MSP_RESOURCE_PLAN_ASSIGNMENTS)

    2] Run the below query on the publish database

    select * from MSP_RESOURCE_PLAN_ASSIGNMENTS where ASSN_UID not in (select assn_uid from  MSP_RESOURCE_PLAN_ASSIGNMENTS)

    Tuesday, June 10, 2014 3:24 PM
  • No rows returned while executing the query

    Tuesday, June 10, 2014 4:00 PM
  • Hi,

    Is you PS2010 environment up to date with the latest SP and CU?

    http://technet.microsoft.com/en-US/office/ee748587


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Tuesday, June 10, 2014 5:43 PM
    Moderator
  • SP1 + October CU, is there any KB article which mentions this it in any later SP or hotfix ? i haven't seen any for 2010 with my research

    i recollect there was one for 2007 for this issue, but i am assuming this should already be included with 2010 release

    Wednesday, June 11, 2014 5:56 PM
  • Hi,

    As per the link I gave you in my previous reply, SP2 has been released for PS2010. Also a CU in may 2014.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Wednesday, June 11, 2014 6:02 PM
    Moderator
  • Even though SP2 is there but i did checked and it doesn't mention any changes to the resource plan behaviour or related, so not sure how its going to fix the related problem

    Also to note as i mentioned in my earlier thread, since similar kind of behaviour was noted in 2007 i am assuming if there was a fix it would be already icluded in earlier release itself


    Wednesday, June 11, 2014 6:27 PM
  • Note that SP, KB, CU usually fix a lot of issues and not all of them are listed in the Microsoft articles.

    Indeed since this issue was spotted since 2007 version, it is more than likely that it has been already fixed in a previous package. But "more than likely" is not 100%. Anyway a Project Server environment should as soon as possible be upgraded with the latest packages, particularly if you are experiencing such unexpected behaviors. It would be much time spent on debugging (and for us on the forum useless time of writing) when a SP or CU might solve the issue.

    That being said, not having more answers for your issue, maybe other users on this forum will jump in with more suggestions.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Wednesday, June 11, 2014 6:37 PM
    Moderator