Virtual PC XP Mode Integration Features mapped Drives


  • Im having issues with my Virtual PC XP Mode. Im trying to get a few mapped drives to show up when i have them checked in the Itegration Features settings. But they do not show up when i have only a few checked (C:,U:,X:,W:) but when i have them all checked it does map them. Im running windows 7 professional and it is on a domain.
    Friday, August 02, 2013 6:57 PM


  • Actually i figured out the problem. its in a update. its update named KB2592687

    thanks again for all your help!

    Friday, August 30, 2013 12:10 PM

All replies

  • Hi,

    From your post, I know that Virtual PC didn’t map local drive properly. We can only see the mapped drive by checking on all drives in Integration features setting.

    Regarding current situation, I suggest we reinstall the integration feature to check the issue:

    Install or upgrade the Integration Components package

    Please take time to perform above troubleshooting steps and let me know the results.

    Hope these could be helpful and look forward to your response.

    Kate Li TechNet Community Support

    Tuesday, August 06, 2013 3:26 AM
  • Generally, you can't map a mapped drive.  Why not map then directly in XP Mode?
    Tuesday, August 06, 2013 6:08 PM
  • Thanks for the quick response. Well i have done that update already. I noticed that mine was a version behind from looking at another computer that I have it on so I updated it. Before I re imaged the computer you didn't have to have all of the boxes checked it worked properly. so I hooked up another computer that I haven't re imaged yet and it works fine too but all the settings seem the same.
    Wednesday, August 07, 2013 12:11 PM
  • Thanks for responding. Well I believe I trued that and the drives don't show up when i look for them while I"m in XP mode.
    Wednesday, August 07, 2013 12:13 PM
  • Have you thought of anything else? Steps you told me before didnt work. i have updated the integration features and nothing changed. Note that it worked fine before i re-imaged it. and i hooked up another one that I haven't re-imaged yet and it works fine. As far as i can see the settings are the same on the old on and the new one.

    Thanks Travis.

    Wednesday, August 21, 2013 5:45 PM
  • Hi Travis,

    Regarding current situation, it appeared that the virtualization features may be corrupted.

    At this point, I suggest we reinstall Virtual PC and Update BIOS to check the results.

    Install and use Windows XP Mode in Windows 7

    Hope these could be helpful.

    Kate Li

    TechNet Community Support

    Friday, August 23, 2013 7:56 AM
  • I have tried this step many times and nothing changed. it said my Bios was up to date. 
    Wednesday, August 28, 2013 12:33 PM
  • have you tried mapping the drives manually

    like if you wanna map the g drive on your host. Map it in the client to \\tsclient\g

    (if tsclient is your guestname)

    Don't forget about Alt+Esc!

    • Proposed as answer by Weslee db Friday, August 30, 2013 12:34 PM
    Wednesday, August 28, 2013 1:17 PM
  • How do you map the drives to XP mode. Im not familiar with that. my XP mode name is "XPMUser". I wanna map my drives form my main computer to my XP Mode.


    Wednesday, August 28, 2013 1:39 PM
  • Right click My Computer

    Select map network drive...

    Select a letter you want to use & as folder put \\tsclient\G (if the G is the drive you want to map on your host).

    Also if you want to make a batch file you can use the following command:

    net use x: \\tsclient\G


    Don't forget about Alt+Esc!

    • Edited by Weslee db Thursday, August 29, 2013 11:22 AM
    Thursday, August 29, 2013 6:17 AM
  • Actually i figured out the problem. its in a update. its update named KB2592687

    thanks again for all your help!

    Friday, August 30, 2013 12:10 PM