locked
Windows Mobile Device Center with Win 7 RTM - GuestOnly partnership RRS feed

  • Question

  • On XP with ActiveSync 4.5, there is a registry hack you can add so it connects any devices as Guest only, so no partship wizard any more. Does Windows 7 have that too?
    • Moved by Carey FrischMVP Monday, September 14, 2009 3:53 PM Moved to relevant category (From:Windows 7 Miscellaneous)
    Monday, September 14, 2009 3:42 PM

Answers

  • Hi Jack,

     

    According to my test, we are not able to disable this prompt window in Windows 7 and there is document shows how to disable it. So, it should be a by designed feature. I will forward your feedback to the appropriate department through our internal channel. Both the Microsoft Product Team and Development Team take into consideration all suggestions and feedback for future releases.

     

    Thank you for your comments on our product.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Wednesday, September 23, 2009 9:30 AM
    Monday, September 21, 2009 2:16 AM

All replies

  • Hi,

     

    In Windows 7, you need to install Windows Mobile Device Center  (WMDC) to manage the mobile devices.

     

    In WMDC, try the following registry file to enable the guest mode:

     

    Change Registry value

    ====================

    1. Click Start button, type REGEDIT in the Start Search bar, and press Enter.

    2. Select Computer (the root node) in the left pane, click Export under the File menu, choose All under Export range, Select Desktop in the Save in box and type backup in File Name, then click Save.

     

    Note: The backup file is on the Desktop and named backup.reg. You can simply restore the registry by double-clicking the backup.reg file.

     

    3. Click Start button, type: "notepad" (without the quote) in the Start Search and press Enter.

    4. Copy the following commands and then paste them into the opened Notepad window.

     

    Windows Registry Editor Version 5.00

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows CE Services]

    "GuestOnly"=dword:00000001

    [HKEY_CURRENT_USER\Software\Microsoft\Windows CE Services]

    "Sync window display mode"=dword:00000000

     

    5. After you paste the above commands, please click "File" on the menu and click "Save".

    6. Type in "fix.reg" as the file name select to save the file on the Desktop. Click "Save".     

    7. Go to the desktop, double click fix.reg. A dialog box will pop-up saying "Are you sure you want to add the information in fix.reg to the registry?". Click Yes on this dialog box.

     

    If it does not work, you can try a third party tool to force the GuestOnly mode on Windows Mobile Device Center. Here is the link for your reference.

     

    http://blog.markarteaga.com/ConfiguringWindowsMobileDeviceFromDesktop.aspx

    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.


    Vivian Xing - MSFT
    Wednesday, September 16, 2009 8:15 AM
  • Acutally the GuestOnly key is already there (where did my eyes go?), it was set to 0 by default, changed it to 0, and added the other key "Sync window display mode", doesn't help - the setup window still pops up - quote annoying. And I don't want to install a third-party software just for that......

    Why WINDOWS 7 would remove that VERY NICE feature while the GuestOnly key still exists?
    Wednesday, September 16, 2009 3:38 PM
  • Hi,

     

    According to my test, when connecting a mobile device and start WMDC, the following screen will prompt:

     

    WMDC

     

    You can choose setup the device or not. If choosing the second one, the partnership will not setup and I can browse the contents directly.

     

    At current situation, please let me know what you would like to achieve:

     

    1. Disable this prompt window

     

    Or

     

    2. Choose "Connect without setting up your device"

     

    Thank you for your clarifying. I will perform further test then.


    Vivian Xing - MSFT
    Thursday, September 17, 2009 9:47 AM
  • I know it's connected, and I don't want to setup a partnership, so I want "1" - Disable the prompt window.

    thanks
    Friday, September 18, 2009 7:18 PM
  • Hi Jack,

     

    According to my test, we are not able to disable this prompt window in Windows 7 and there is document shows how to disable it. So, it should be a by designed feature. I will forward your feedback to the appropriate department through our internal channel. Both the Microsoft Product Team and Development Team take into consideration all suggestions and feedback for future releases.

     

    Thank you for your comments on our product.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Wednesday, September 23, 2009 9:30 AM
    Monday, September 21, 2009 2:16 AM
  • Yes please add this to future releases. It causes a security issue in that Outlook Data from one user can be inadvertently transfered to a public device such as a Windows Mobile handheld scanner which is shared by more than one user.

    Thank you for your help.

    Tim
    Friday, February 26, 2010 7:36 PM
  • Vivian,

    Any update on if this prompt can be removed by an option and always have the device go into Guest Mode?  I agree with Tim regarding the security issue.  For public devices, there is no need for partnership.

    Bobby

    Monday, November 15, 2010 3:10 PM
  • Hi Vivian,

    I would also be interested in being able to disable this prompt window. 

    I develop apps for Windows CE based data collection terminals for stocktaking etc. Our users connect and disconnect many times a day, and this window can become annoying.

    We only need to be connected as guest to transfer files.

    When using ActiveSync, we provide our users with a setup option to enable or disable the window so they can easily re-enable it if required.

    Thanks.

     

    Wednesday, December 8, 2010 6:01 AM
  • Any news? Still waiting!.....
    • Proposed as answer by FS-Andermann Wednesday, October 5, 2011 1:14 PM
    • Unproposed as answer by FS-Andermann Wednesday, October 5, 2011 1:15 PM
    Wednesday, March 16, 2011 10:32 AM
  • It looks like many people need this option, but nothing option to set it.

    What we need is the same like ActiveSync 4.x :

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows CE Services]
    "GuestOnly"=dword:00000001

    • Proposed as answer by RunDOSRun Wednesday, February 8, 2012 10:23 PM
    • Unproposed as answer by RunDOSRun Wednesday, February 8, 2012 10:24 PM
    Wednesday, October 5, 2011 1:14 PM
  • If you just want to disable the Windows Mobile Device Center popup in

    Windows 7, change the following key in the registery: 

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]  

    from %windir%\WindowsMobile\wmdc.exe to %windir%\WindowsMobile\wmdcbase.exe
    This elimitates the popup window each time you sync the device.

    Wednesday, February 8, 2012 10:25 PM
  • Hi RunDOSRun !

    Your post is very helpfull !

    But have you got information about difference between wmcd.exe and wmcdbase.exe ? The file length are equal. I didn't find any information about this subject with my friend Google ;-)

    Oliver.

    Tuesday, February 14, 2012 11:37 AM
  • Olivertoy, wmcdbase.exe is just the 'lite' version of the tool.  It doesn't display the WMCD screen every time you connect the device.  I also learned today that you still need to use the old "GuestOnly" registry entry if you want it to work properly.

    So in conclusion use both of these and you should be all set.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]  %windir%\WindowsMobile\wmdcbase.exe
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows CE Services]  "GuestOnly"=dword:00000001

    I've rebooted a number of times to test it and it works great.  Just know that you have to manually run wmdc.exe under "C:\Windows\Windows Mobile" if you want to change any of the sync options.  Or you can just change the 1st registy entry back by removing the word "base", and rebooting.

    • Proposed as answer by RunDOSRun Monday, March 12, 2012 5:50 PM
    Monday, March 12, 2012 5:50 PM