locked
IE11 Enterprise Mode and the IIS Logging Website EmIE.asp (Log the Toggle) RRS feed

Answers

  • OK, it's logging everything now.  Here are the possibilities:

    • I failed to install the classic ASP server role (IIS server add/remove features) (theory)
    • As an alternative, we converted the code to a modern C# ASP.net (aspx) solution.
    • Make sure Anonymous Authentication is enabled so that it'll record the logged-on username (theory)
    • Marked as answer by raydlevel5 Tuesday, January 6, 2015 5:13 PM
    Tuesday, January 6, 2015 5:13 PM

All replies

  • Hi,

    see ieem.asp

    <% @ LANGUAGE=javascript %>
    
    <%
    
    Response.AppendToLog(" ;" + Request.Form("URL") + " ;" + Request.Form("EnterpriseMode"));
    
    %>

    debug using visual studio, placing break points on the response.AppendToLog line above....and using the Object Inspector to view the members of the Request object.
    Regards.


    Rob^_^

    • Proposed as answer by 网游 - wang'you Wednesday, December 17, 2014 7:41 AM
    • Marked as answer by Yolanda Zhu Friday, December 26, 2014 9:45 AM
    • Unmarked as answer by raydlevel5 Monday, January 5, 2015 8:02 PM
    Wednesday, December 17, 2014 7:41 AM
  • We are attempting to debug and I will post here if the it's fruitful.
    Monday, January 5, 2015 9:08 PM
  • Hi raydlevel5,

    Considering this case is more likely a developing issue, it is recommended to post the case in our Internet Explorer web development forum. The people there are more experienced in handling with this case. To understand this case better, please explain the details of the issue as much as possible there.                                     
    Internet Explorer Web Development                     
    https://social.msdn.microsoft.com/Forums/ie/en-US/home?forum=iewebdevelopment

    Best regards


    Tuesday, January 6, 2015 2:04 AM
  • I used Fiddler to inspect the internet headers.  There are 401 and 405 authentication errors when IE tries to send data back to the ASP.net page.  My teammate, who is a Wizard with ASP.net, does not beleive it is a problem with the code, but with how I configured IIS.

    Probably either the NTFS permissions on the Folder I created, and/or the acutal IIS authentication settings.


    • Edited by raydlevel5 Tuesday, January 6, 2015 3:13 PM grammar
    Tuesday, January 6, 2015 3:12 PM
  • OK, it's logging everything now.  Here are the possibilities:

    • I failed to install the classic ASP server role (IIS server add/remove features) (theory)
    • As an alternative, we converted the code to a modern C# ASP.net (aspx) solution.
    • Make sure Anonymous Authentication is enabled so that it'll record the logged-on username (theory)
    • Marked as answer by raydlevel5 Tuesday, January 6, 2015 5:13 PM
    Tuesday, January 6, 2015 5:13 PM
  • Hi raydlevel5,

    I am glad this issue has been resolved and thanks for sharing the troubleshooting experience.

    Best regards

    Wednesday, January 7, 2015 1:20 AM
  • I have successfully created Group Policies, and an IIS web service for IE11 Enterprise Mode Logging as per related TechNet articles.

    The IE11 Enterprise Mode Logging feature appears to log the time I toggle Enterprise Mode; however, it doesn't record all the fields.... This is what the file looks like.

    #Fields:date cs-uri-query cs-username c-ip

    2014-12-16 - - 10.31.92.21
    2014-12-16 - - 10.31.92.21

    What am I missing?  I assume, perhaps, I have misconfigured something on the IIS Web Service?

    Here are the reference articles:

    http://msdn.microsoft.com/en-us/library/dn781326.aspx

    http://www.grouppolicy.biz/2014/04/setup-internet-explorer-11-enterprise-mode-logging/



    i am encountering this same issue- did you ever figure out exactly what caused yours?

    i'm also using fiddler to investigate- each time i toggle EM from the tools menu in IE i see error 405, when i look at the Inspectors tab in fiddler it's missing the path to my iis server under Request Headers (ie, should be showing 'POST <servername>\emIE.asp' but instead only shows '\emIE.asp').

    it looks like the GP isn't applying the logging URL properly, though the GP is working because i can togggle EM in the Tools menu, so maybe it's an IIS issue?  i've double-checked my iis configuration against the ms documenation and other setup articles i've found.

    this is the post that i started for my issue:

    https://social.technet.microsoft.com/Forums/en-US/e94c98d9-8bd7-4ee0-a7e8-29086cd8fc95/ie-11-enterprise-mode-logging-not-working?forum=ieitprocurrentver

    Sunday, December 20, 2015 9:14 PM
  • did more digging in fiddler and found this under inspectors/headers tabs:

    under Response Headers:

    HTTP/1.1 405 Method Not Allowed

    under the Security tab:

    Allow: GET, HEAD, OPTIONS, TRACE

    and under the TextView tab:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
    <title>405 - HTTP verb used to access this page is not allowed.</title>
    <style type="text/css">
    <!--
    body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
    fieldset{padding:0 15px 10px 15px;}
    h1{font-size:2.4em;margin:0;color:#FFF;}
    h2{font-size:1.7em;margin:0;color:#CC0000;}
    h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}
    #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
    background-color:#555555;}
    #content{margin:0 0 0 2%;;}
    .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;;}
    -->
    </style>
    </head>
    <body>
    <div id="header"><h1>Server Error</h1></div>
    <div id="content">
     <div class="content-container"><fieldset>
      <h2>405 - HTTP verb used to access this page is not allowed.</h2>
      <h3>The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.</h3>
     </fieldset></div>
    </div>
    </body>
    </html>

    so this appears to be an iis configuration issue?  i'm not really familiar with iis setup so i don't really know what i need to change here, do i have to allow POST submissions in iis?  looks like that feature is either missing or not set up correctly, so toggling EM isn't successfully getting sent to the iss log file?

    Sunday, December 20, 2015 9:38 PM