locked
Cannot update document properties in a SharePoint 2007 document library RRS feed

  • Question

  • All,

    Im having an issue with MOSS 2007 (similar to http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/e47af42f-0f5e-4180-a7d4-9c8e989b3804) but not the same.

    I created a document library to be filled with Word Documents.

    Created 2 new Custom Content Types and added them to the document library

    Then removed the Document Content Type so I have my own custom defined Content types

    I hav a fileshare containing lots of word files and uploaded them to the document library.

    All properties are filled in where possible.

    When I now try to edit the properties, it fails. no errors but changes are not saved. Not only Can't I select a new content type, but every field I modified and Saved, still holds its previous information.

    Any suggestions?

    Tuesday, March 22, 2011 9:30 PM

Answers

  • Hi Rashu,

     

    Thanks for the reply, but the issue seems gone now. What it looked like, was that for all documents saved in 2003 format, everything was fine, but when an Office 2007 document was uploaded, the whole thing just fell appart.

    What I did was a download of all Office 2007 formatted documents, resaved them to Office 2003 versions and uploaded them again. Now the issue seems to be gone.

     

    Probably something is not quite ok between the Office 2007 collaboration and SP2007

     

    Regards

    • Marked as answer by Yveke Wednesday, June 1, 2011 12:28 PM
    Wednesday, June 1, 2011 12:28 PM

All replies

  • Hi,

     

    According to your description, in my opinion, it is possible to break the property mapping between the list and office.

    I have found a useful blog about Synchronization of Office Document Properties with WSS Document Libraries. For more information, please refer to this:

    http://weblogs.asp.net/bsimser/archive/2004/11/22/267846.aspx

     

     

    Best Regards
    David Hu

     

    • Marked as answer by Emir Liu Thursday, March 31, 2011 1:29 AM
    • Unmarked as answer by Yveke Tuesday, April 5, 2011 11:49 AM
    Thursday, March 24, 2011 1:29 AM
  • Thx David,

     

    What I use to upload my documents is the Copy Web Service.

    All meta data is added to the Web Service Call and is filled when able.

     

    The problem is, that when I don't know all the meta data or I want to change them, these changes are discarded when I click OK in the Edit Form.

    All documents are checked in.

     

    Regards

    Tuesday, April 5, 2011 11:55 AM
  • Hi,

    I suggest you to carry out the same while enabling logging in Verbose mode.

    So that you will get more details.

    I hope this will help you out.

    Thanks,

    Rahul Rashu

    Friday, May 27, 2011 12:58 PM
  • Have you been able to remove the delete the unused content types from the document library? Normally SharEPoint should prevent you from doing it if some documents are still using the Site Columns unique to the content type.

    What is the error you are getting when trying to edit the document?

     

    Nik

    http://ignitesoft.ca


    Nikolas Charlebois-Laprade Microsoft Certified Professional Software Engineer and Project Manager http://nikcharlebois.sharepointspace.com
    Monday, May 30, 2011 7:01 PM
  • Hi Rashu,

     

    Thanks for the reply, but the issue seems gone now. What it looked like, was that for all documents saved in 2003 format, everything was fine, but when an Office 2007 document was uploaded, the whole thing just fell appart.

    What I did was a download of all Office 2007 formatted documents, resaved them to Office 2003 versions and uploaded them again. Now the issue seems to be gone.

     

    Probably something is not quite ok between the Office 2007 collaboration and SP2007

     

    Regards

    • Marked as answer by Yveke Wednesday, June 1, 2011 12:28 PM
    Wednesday, June 1, 2011 12:28 PM
  • Hey Nikolas,

     

    I didn't get an error, just that when you edit the properties of the uploaded document, all changes are discarded after you click OK.

    I did create a Windows application to copy documents to other CT's and then delete the unused ones.

     

    thanks for the reply, but as you can see in my last post, the issue seems to be resolved.

     

     

     

    Wednesday, June 1, 2011 12:31 PM