locked
CAPS lock turns on and off by itself" issue in Windows 7 64-bit Enterprise Service pack 1 operating system RRS feed

  • Question

  • Hi All,

    Recently we are facing "CAPS lock turns on and off by itself" issue in Windows 7 64-bit Enterprise Service pack 1 operating system, issue is coming quite frequently now a days in all the Windows 7 machines.

    For testing purpose,we have tried replacing the key board's on the machines, but no luck issue is still occurring.. Have to give a try updating the respective machine model keyboard driver....

    Kindly suggest us the possible solution to fix this issue.

    Thanks,

    Paramaguru


    • Edited by Paramaguru S Tuesday, September 24, 2013 11:16 AM
    Tuesday, September 24, 2013 8:03 AM

Answers

  • Hi Paramaguru,

    Open your Task Manager and see whether wscript.exe is running, if yes, end task for that program and see whether the problem still occurring.

    Freak05

    • Marked as answer by Paramaguru S Monday, September 30, 2013 2:15 AM
    Wednesday, September 25, 2013 1:53 AM
  • Hi Freak05,

    Thanks for your valuable inputs, Issue is, there is a wscript.exe (custom script) is running in the task manager. wscript.exe is a command script which causes the keyboard to go erratic if it is present in the task manager.

    Once we are ending the wscript.exe from task manager, Issue got resolved.

    Thanks,

    Paramaguru

    • Marked as answer by Paramaguru S Monday, September 30, 2013 2:23 AM
    Monday, September 30, 2013 2:22 AM

All replies

  • 1. Interesting. Never have problem like this one. If this occurs on more PCs, then I would check applications installed. Is this the case on vanilla plain Windows 7. Also which application is susceptible to this phenomenon?

    2. Try troubleshooter

    http://windows.microsoft.com/en-us/windows7/Open-the-Hardware-and-Devices-troubleshooter

    3. Try clean boot

    http://support.microsoft.com/kb/929135

    Regards

    Milos

    Tuesday, September 24, 2013 11:16 AM
  • Hi Paramaguru,

    Open your Task Manager and see whether wscript.exe is running, if yes, end task for that program and see whether the problem still occurring.

    Freak05

    • Marked as answer by Paramaguru S Monday, September 30, 2013 2:15 AM
    Wednesday, September 25, 2013 1:53 AM
  • Hi,

    Does this issue occur when you launch a specific program or randomly?

    In addition to the solution provided by Milos and Freak, I also would like to suggest you perform a scan to check for the malware:

    Malicious Software Removal Tool

    http://www.microsoft.com/en-in/download/malicious-software-removal-tool-details.aspx

    Regards,

    Yolanda

    Wednesday, September 25, 2013 9:10 AM
  • Hi Freak05,

    Thanks for your valuable inputs, Issue is, there is a wscript.exe (custom script) is running in the task manager. wscript.exe is a command script which causes the keyboard to go erratic if it is present in the task manager.

    Once we are ending the wscript.exe from task manager, Issue got resolved.

    Thanks,

    Paramaguru

    • Marked as answer by Paramaguru S Monday, September 30, 2013 2:23 AM
    Monday, September 30, 2013 2:22 AM
  • I have exactly the same problem,

    running Windows 7 64 bit Home Premium with Service Pack 1 on a Dell Alienware M18

    Full malware protection is active and the laptop is remotely serviced every 3 months by a MS partner engineers.

    The caps lock intermittently switches on an off. I have checked the hardware and the mechanics of the keyboard as well as the keyboard driver. All are OK

    The issue happens with every program used and is not unique to a single one.

    Infuriating as it will happily switch on halfway through a word or a sentence and then switches off when you require capitals.

     

    Monday, July 20, 2015 1:07 PM
  • I found that my laptop was running too long and was too hot. After shutting it down and not letting it run too long it stop doing this. Problem solved. Hope this helps.
    Saturday, February 27, 2016 2:56 PM
  • We had the same issue at work. Turns out some users had sticky keys activated (by pressing 5 times on shift). Don't know if it applies to you but worth a look.
    Thursday, April 21, 2016 3:52 PM
  • Open control panel and select ease of access center and select make keyboard easier to use.

    At the bottom look for KEYBOARD SETTINGS and select it. Keyboard Properties will open. 

    For Repeat Rate if the slider is all the way to the right for Fast, persons with a shake may trigger this behavior without knowing it. Move the slider to the mid position and click apply.

    Sunday, December 4, 2016 9:28 AM
  • Thanks, this helped me!
    Saturday, March 3, 2018 10:45 AM