locked
problem with permission for anonymous user RRS feed

  • Question

  • Hi,

    I enable anonymous access for my site in central administration and set below settings in my site:

    site actions->site settings-> Modify all site settings-> User & permission part-> Advanced permission settings->anonymous access   & in “Anonymous users can access” part i select "Entire web site".

    but when i go to list->settings->permission for this list-> settings->anonymous access   in change anonymous access settings : My ListName page, i cant give any permission because all of options disable for me.( my user have full access permission on site & on this list)

    how i can enable this part that i can set permission for anonymous users?

    I’m very appriciated if anyone help me.

    Thanx.

     

    • Moved by Mike Walsh FIN Wednesday, December 22, 2010 8:03 PM Not a customization question (From:SharePoint - Design and Customization (pre-SharePoint 2010))
    Wednesday, December 22, 2010 4:15 PM

Answers

  • Sadomovalex,

    I found where the problem is. I go to below path:

    List settings-> Advanced settings

    And in Item Level Permission set Read Access to Only their own, although only anonymous user use this site & this setting is wrong & meaningless for them.I change this setting to Allitems,then anonymous access settings in

    list->settings->permission for this list-> settings->anonymous access be enable. J

     

    • Marked as answer by Ameneh.Maleki Monday, December 27, 2010 6:11 AM
    Monday, December 27, 2010 6:11 AM

All replies

  • hi

    this is OTB behavior for lists. But you should have it enabled for document libraries. In order to show them in lists as well change "LIST" in query string on "DOCLIB" (if I didn't forget the actual query string parameters names). BTW - why do you need to change anonymous access for lists if you enabled it for entire site?


    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    Wednesday, December 22, 2010 6:55 PM
  • Thanx Sadomovalex,

    Are you sure it is OBT behavior for lists?! because i can set anonymous access

    permission for list through mentioned path in another sharepoint site. but in one

    of my sharepoint site(on the internet) , this settings are disable.

    I want to change anonymous access for list  because users can't create new item(in spite of they have

    contribute permission). when they want to create new item in this this thay face with permission error page.

    • Marked as answer by Ameneh.Maleki Monday, December 27, 2010 6:11 AM
    • Unmarked as answer by Mike Walsh FIN Monday, December 27, 2010 8:10 AM
    Wednesday, December 22, 2010 7:59 PM
  • Sadomovalex,

    I found where the problem is. I go to below path:

    List settings-> Advanced settings

    And in Item Level Permission set Read Access to Only their own, although only anonymous user use this site & this setting is wrong & meaningless for them.I change this setting to Allitems,then anonymous access settings in

    list->settings->permission for this list-> settings->anonymous access be enable. J

     

    • Marked as answer by Ameneh.Maleki Monday, December 27, 2010 6:11 AM
    Monday, December 27, 2010 6:11 AM