locked
Cannot set a retention policy on a Library in Information Management Policy Settings RRS feed

  • Question

  • Cannot set a retention policy on a Library in Information Management Policy Settings. It says You cannot change policy settings for this content type because it inherited the settings from its parent content type or a site level content type. To change these policy settings, change the settings for the parent of this content type.                

    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG



    • Edited by RonJohnMSU Tuesday, November 10, 2015 4:03 PM
    Tuesday, November 3, 2015 8:39 PM

Answers

  • Hi Ron,

    Please check this article on the section of  "Create a policy for a list, library or folder (location-based retention policy)"

    https://support.office.com/en-us/article/Create-and-apply-information-management-policies-eb501fe9-2ef6-4150-945a-65a6451ee9e9

    Thanks

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Wednesday, November 4, 2015 5:15 AM
  • Hi Ron,

     

    There is a retention policy defined in Site Content Type level. I believe you are trying to change from List Settings.

    You could follow the link in the message, it should take you to the page where you can edit policy for Site Content types.

    If link is not working, you can navigate to

    Site Actions=>Site Settings=>Site Content Types=Choose Content Type=> Information management policy settings.

     

    Thank you 


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, November 4, 2015 5:38 AM
  • I do not want it to affect all of the other lists and libraries. I only want to have this setting on the one library.

    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Friday, November 6, 2015 7:22 PM
  • Hi Ron,

    You need to activate “Library and Folder based retention” in site collection features to define retention schedule for a library.

    More Info:

    http://www.c-sharpcorner.com/uploadfile/anavijai/retention-policy-for-a-document-library-in-sharepoint-2010/

     

    Thank you


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Monday, November 9, 2015 2:08 AM
  • I have already activated the Library and Folder retention. It lets me set a retention on the folder but, does nothing. If I click on Document in the Content Types it does not let me set a retention and indicates that it is inherited by the parent. However, I do not want to have retention set on the parent site.

    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Monday, November 9, 2015 5:06 PM
  • Hi Ron,

     

    There are 2 timer jobs (Information management policy and Expiration policy) responsible for Information Management Policy, by default they run weekly.

    Make sure they are enabled, and for testing purposes, you can run them manually to check if retention policy is working.

    Central Administration=>Monitoring=> Review Job Definitions=>locate jobs (Information management policy and Expiration policy, click “Run Now”)

     

    Thank you


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Tuesday, November 10, 2015 3:07 AM
  • I did kick off the job and it does not seem to work. Very strange? It shows it is enabled.


    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Tuesday, November 10, 2015 4:05 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG


    • Edited by RonJohnMSU Tuesday, November 10, 2015 4:09 PM
    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Tuesday, November 10, 2015 4:07 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Tuesday, November 10, 2015 4:09 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Tuesday, November 10, 2015 4:11 PM
  • Hi,

    Judging by the images, you might be setting the event/action for the content type not for the Library and Folders. But since this library is using library and folder retention (I can see it in the image), content type retention policies are ignored.

    Just to clarify, you need to set event/action from:

    Library Settings=> Information Management Settings=> Change Source or configure library schedule (if you want it to be only for this document library, not for content type)

    It does not matter if “Folder” Content type has Retention Policy defined, because for this library we are not using Content Type Retention Policy, that’s why we activated “Library and Folder based retention” feature.

    Please let me know if I am misinterpreting the images.

    This is the page:

    Thank you


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, November 11, 2015 7:16 AM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Wednesday, November 11, 2015 4:56 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Wednesday, November 11, 2015 5:01 PM
  • Not sure why but, this obviously does not work.

    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Friday, November 13, 2015 6:05 PM

All replies

  • Hi Ron,

    Please check this article on the section of  "Create a policy for a list, library or folder (location-based retention policy)"

    https://support.office.com/en-us/article/Create-and-apply-information-management-policies-eb501fe9-2ef6-4150-945a-65a6451ee9e9

    Thanks

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Wednesday, November 4, 2015 5:15 AM
  • Hi Ron,

     

    There is a retention policy defined in Site Content Type level. I believe you are trying to change from List Settings.

    You could follow the link in the message, it should take you to the page where you can edit policy for Site Content types.

    If link is not working, you can navigate to

    Site Actions=>Site Settings=>Site Content Types=Choose Content Type=> Information management policy settings.

     

    Thank you 


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, November 4, 2015 5:38 AM
  • I do not want it to affect all of the other lists and libraries. I only want to have this setting on the one library.

    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Friday, November 6, 2015 7:22 PM
  • Hi Ron,

    You need to activate “Library and Folder based retention” in site collection features to define retention schedule for a library.

    More Info:

    http://www.c-sharpcorner.com/uploadfile/anavijai/retention-policy-for-a-document-library-in-sharepoint-2010/

     

    Thank you


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Monday, November 9, 2015 2:08 AM
  • I have already activated the Library and Folder retention. It lets me set a retention on the folder but, does nothing. If I click on Document in the Content Types it does not let me set a retention and indicates that it is inherited by the parent. However, I do not want to have retention set on the parent site.

    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Monday, November 9, 2015 5:06 PM
  • Hi Ron,

     

    There are 2 timer jobs (Information management policy and Expiration policy) responsible for Information Management Policy, by default they run weekly.

    Make sure they are enabled, and for testing purposes, you can run them manually to check if retention policy is working.

    Central Administration=>Monitoring=> Review Job Definitions=>locate jobs (Information management policy and Expiration policy, click “Run Now”)

     

    Thank you


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Tuesday, November 10, 2015 3:07 AM
  • I did kick off the job and it does not seem to work. Very strange? It shows it is enabled.


    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Tuesday, November 10, 2015 4:05 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG


    • Edited by RonJohnMSU Tuesday, November 10, 2015 4:09 PM
    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Tuesday, November 10, 2015 4:07 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Tuesday, November 10, 2015 4:09 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Tuesday, November 10, 2015 4:11 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    Tuesday, November 10, 2015 4:13 PM
  • Hi,

    Judging by the images, you might be setting the event/action for the content type not for the Library and Folders. But since this library is using library and folder retention (I can see it in the image), content type retention policies are ignored.

    Just to clarify, you need to set event/action from:

    Library Settings=> Information Management Settings=> Change Source or configure library schedule (if you want it to be only for this document library, not for content type)

    It does not matter if “Folder” Content type has Retention Policy defined, because for this library we are not using Content Type Retention Policy, that’s why we activated “Library and Folder based retention” feature.

    Please let me know if I am misinterpreting the images.

    This is the page:

    Thank you


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, November 11, 2015 7:16 AM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Wednesday, November 11, 2015 4:56 PM

  • Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Wednesday, November 11, 2015 5:01 PM
  • Not sure why but, this obviously does not work.

    Ron Johnson Systems Administrator Michigan State University Federal Credit Union Office – (517) 333-2391 ron.johnson@msufcu.org WWW.MSUFCU.ORG

    • Marked as answer by RonJohnMSU Tuesday, November 17, 2015 2:22 PM
    Friday, November 13, 2015 6:05 PM