none
Server 2016 DHCP Issue RRS feed

  • Question

  • Hi all,

    I have just deployed a 2016 AD server and there is a strange issue with DHCP on the machine. If i set it up using the normal scope option of 003 Router then although it adds a route to the router in the route table none of the clients have any internet access, this applies to PCs as well as phones/tablets etc. However if i use option 121 instead and add the equilivant static route (0.0.0.0 / 255.255.255.255 / Router IP) then everything works.

    Ive compared the setup to the 2012 server it has replaced (which is now demoted and removed from the domain) so im wondering if this is an issue with Server 2016s implementation of DHCP.

    Any comments appreciated

    Thanks,

    Anthony

    Monday, October 17, 2016 12:10 AM

Answers

  • Hi Anthony,

    Please try to add route record in client by running route add command, configure metric to 1.

    Meanwhile, please try to disable 121 option and configure option 03, renew IP address on client.

    You could post result of operation above to here for further troubleshooting.

    Have you try to catch network packet of DHCP? How about result?

    Best Regards

    John


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by John Lii Monday, October 31, 2016 6:49 AM
    • Marked as answer by Leo HanModerator Wednesday, November 2, 2016 5:19 AM
    Tuesday, October 18, 2016 8:39 AM

All replies

  • Hi Anthony,

    Please run ipconfig /all to check if DHCP client has obtained value of option 3.

    You could catch network packet by using Microsoft Monitor to analyze DHCP packet.

    Here is link about Microsoft monitor download:

    https://www.microsoft.com/en-sg/download/details.aspx?id=4865

    Best Regards

    John


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 17, 2016 8:17 AM
  • Yeah it has, what seems to happen is if i add the extra 121 option is it adds an extra route thats idential to the default gateway route it just has a metric 1 lower, very odd
    Monday, October 17, 2016 6:45 PM
  • Hi Anthony,

    Please try to add route record in client by running route add command, configure metric to 1.

    Meanwhile, please try to disable 121 option and configure option 03, renew IP address on client.

    You could post result of operation above to here for further troubleshooting.

    Have you try to catch network packet of DHCP? How about result?

    Best Regards

    John


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by John Lii Monday, October 31, 2016 6:49 AM
    • Marked as answer by Leo HanModerator Wednesday, November 2, 2016 5:19 AM
    Tuesday, October 18, 2016 8:39 AM
  • Hi Anthony,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.

    Best Regards,

    John


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 31, 2016 6:49 AM